[RELEASE] Universal Enhanced Z-Wave Lock, Schlage Lock, Yale Lock, Kwikset Lock, IDLock, DanaLock, August Pro and Samsung Lock Device Handler with Alarm Control, Notification, RFID, Door Sensor and advanced features

dth_locks
yale
smartapp_alerts
smartapp_locks
smartapp_security

(www.rboyapps.com - Make your home your butler!) #126

I would say separate.

First they is no correlation between this functionality and the door user management. It will just confuse the user esp since non Schlage locks don't support this functionality and that too only theBE469 supports alarms.

Second the door user mgmt is designed to work with the standard ST device type where as this app is designed specifically for this custom device.


(www.rboyapps.com - Make your home your butler!) #127

Also works with the FE469 series, it's a very similar model to the more popular BE469


(Mark) #128

@RBoy , I've just installed your smart device and smartapp. The tiles for lock and unlock work but the others show "unknown". I have a BE469. Any ideas?


(Colin) #129

Did you tap each one of them at least once? After you have, exit out of the app and go back in and re-check


(Mark) #130

I think that took care of it - did it a couple times and now the buttons work. Thanks!


(www.rboyapps.com - Make your home your butler!) #131

Added support for attribute ‘invalidCode’ to Schlage SmartDevice to report when too many invalid codes have been entered

E.g. of a SmartApp that uses this attribute


(Jim) #132

I installed the app and the custom device type a few days ago. My primary reason was to use temporary codes. I setup a one time code which was pushed to the lock and it worked. The code only worked one time, that is after the update delay, but still shows up in the list of codes in the app and is not flagged as being used or disabled. How am I supposed to know if the code was used? Am I missing something? Also, is there a way to see how many times a code was used?


(www.rboyapps.com - Make your home your butler!) #133

Keeping the app simple. Why do you need to know how many times a code is used?


(www.rboyapps.com - Make your home your butler!) #134

BTW you're posting on the wrong thread, this is about the Schlage lock device type and that is about the code management app. Completely different.


(Fast, Good, Cheap...pick two.) #135

There is a learning curve there for us all. With ST selling to the general public now, let's not assume everyone knows the difference between a device type and an app; therefore, know where to request features.

Instead of seemingly shaming someone in a public forum, just ask a moderator to move the post to the correct thread as it will be more friendly to your customer :smile:


(www.rboyapps.com - Make your home your butler!) #136

Agreed!, so the right place to post the comment would be this thread:


(www.rboyapps.com - Make your home your butler!) #137

Version 2.3.0
- Added fix for non motorized deadbolt locks like FE599 not reporting locked after user unlocks the door using a code and it relocks automatically


FE599NX specific device type?
(Michael K) #138

thanks for the FE599 fix.

the first couple times i did it there was a ~3 minutes delay but i realized i was making changes to the smartapp at the time so it apparently waits to reprogram the lock before sending the locked status.

After the lock was all programmed it's close to real time. I unlock with the pin and get the notification on my phone that the pin was entered and then immediately after get a notification that the lock re-locked electronically.

perfect!


(Fast, Good, Cheap...pick two.) #139

@RBoy

Your most recent code changes to this app have now (in my mind anyway) made this the "go to" app for door lock control in SmartThings.

There were obviously a lot of great features before, which is why I donated; however, now that you have pulled in open / close sensor integration and individual functions based off individual door unlock events, your code is both ultimately flexible and all encompassing.

You've put in a lot of hard work and it shows!

Thank you sir.


(Goose) #140

First off, RBoy has been awesome and very helpful and I love the app!

My lock is the Schlage Connect (FE469NX)

I've noticed since the last ST update, the lock is sometimes slow, or doesn't even tell me via the 'messages' on the ST app if the door was locked or unlock or who used their code. Sometimes it works and registers, but sometimes it doesn't. It worked fine on Thanksgiving day, as I'd show my family how it would respond and how I could unlock from my phone. As of today, it does not unlock/lock from my app, or its very slow in doing so (more like 10% chance it will work).

Now we did have power shut off during a storm after Thanksgiving (when the lock became worse and worse in responding), so I did the following:

Unplugged my STv2 Hub for 5 or so minutes and waited until steady green to do the following:

Removed/Reinstalled the lock app
Removed/Reinstalled lock from my Z Network

Now for today, I reinstalled the app with the newest version, and the codes were sent and all is well. When I used one of the codes, it worked, but ST did not see it as it happened. It just unlocked the door and the activity did not show that it was unlocked, and in which, did not tell me via SMS that it was unlocked.

I just tried it again after a few minutes since the last time I tried, and it worked and show me via the app and SMS. But I tried to unlock the door from the app and it did not work. If I manually lock it, it thinks its still unlocked. I have the Schlage lock to auto-lock after 15 seconds, I'm not using any App to do so, could that be the cause?

I know I rambled on, but I'm fairly new to all HA, and don't know the best way to explain myself.

Thoughts?


(www.rboyapps.com - Make your home your butler!) #141

The most likely cause is the distance between your lock and hub is too far and it causing communication issues. Looks like you've covered the rest of the stuff. If you can't move it closer then try to get a powered Z-Wave repeater device (like a Z-Wave power outlet) in between that will help the communications.


(Goose) #142

Copy that. It's probably 50 feet away or so from the hub. Through walls too.


(www.rboyapps.com - Make your home your butler!) #143

Added a patch to the code to speed up first time install initialization of feature states.


(Goose) #144

Unsure where to put this update.

I installed the new app yesterday. Everything was great. The coded deleted yesterday at 5PM.

The code was not sent today at 8AM, didn't try or anything.

Thoughts? Same issue for the past week. I resent all the codes again and it of course works, but even with the updated code, it still doesn't send the code in the morning.


(www.rboyapps.com - Make your home your butler!) #145

This one belongs on the other thread Goose:

I had answered this questions yesterday in the above link / last 2 posts, please report it to the link I had posted on the above post. It's due to the platform timers dying that ST is looking into.