[RELEASE] Universal Enhanced Z-Wave Lock Driver for Schlage, Yale, Kwikset, IDLock, Popp, Danalock, August Pro, Keywe, Philia, Samsung

Sorry about that, I’m subscribed to both threads and replied to the wrong one. Thanks!

Why don’t you include the Danalock V3 in your list? I’ve been using it paired with ST on Z-wave for almost two years now and never had any problems with it.

1 Like

Are all the options from the Classic app available to the new app? I have just purchased and installed the V3 hub and I do not see any options. Thank you.

1 Like

@RBoy I’m using this device handler and trying to use WebCore if the door is unlocked using specific codes to execute web hook for WyzeCam video capture. I have it working for code #2 properly but when I use code #1 it captures for automated/manual unlocks??? I sent an email for support last week and haven’t heard back.

In my experience with my Schlage BE469 I had similar problems when trying to do things with code#1…it seems the lock and/or smartthings and/or webcore assume that code#1 is one of the DEFAULT codes and then does “funky” unexpected things. I had tried another DTH before I went back to the ST z-wave DTH for my lock and was too lazy to factory reset the lock so I just added one of the default codes in first so it is now #1. As long as I stayed away from code #1, everything else worked fine. I was originally using an array based on someone else’s example to pull the code names and slots from the lock and figure out who unlocked the door but I ended up simplifying it and just pulling the codeUsed and codeName from the $args. This way I have no problems at all and I can reliably know if the door was unlocked manually, or using default code#1 or any of the other codes and based on who came in, I can activate certain lights to their room. (we run a small B&B so this was great for guests coming back after we locked up for the night.)

It’s a bug in the webcore “piston” smartapp. If you select User 1 or 0 in the UI rule, when the piston executes, it seems to treat users 0 and 1 as a boolean instead of a user number (1 as any unlock event and 0 ignores all unlock events). Would recommend reporting it on the WebCoRE forum.

LUM, RLA and other ST apps don’t have an issue handling code 1 reports and creating custom actions.


Can someone post a piston code, and logs for this?

I was able to use a separate code and worked fine, this only fails to act properly with lock codes 2 and over…

Here is my webcore piston as I had cross posted:

IDE Logs:
53ec4eb8-a0b9-4af7-9513-30d2cecaaa77 10:02:35 AM: info [DTH] parse() - returning result=[[name:alarm, value:forced, descriptionText:Alarm mode forced, linkText:Front Door Lock, isStateChange:false, displayed:false]]
53ec4eb8-a0b9-4af7-9513-30d2cecaaa77 10:02:35 AM: trace ConfigurationReport ConfigurationReport(parameterNumber: 7, scaledConfigurationValue: 3, reserved11: 0, size: 1, configurationValue: [3])
53ec4eb8-a0b9-4af7-9513-30d2cecaaa77 10:02:32 AM: info [DTH] parse() - returning result=[[name:codeLength, value:4, descriptionText:Code length is 4, displayed:false, linkText:Front Door Lock, isStateChange:false]]
53ec4eb8-a0b9-4af7-9513-30d2cecaaa77 10:02:32 AM: trace [DTH] Executing ‘ConfigurationReport’ for device Front Door Lock with code length := 4
53ec4eb8-a0b9-4af7-9513-30d2cecaaa77 10:02:32 AM: trace ConfigurationReport ConfigurationReport(parameterNumber: 16, scaledConfigurationValue: 4, reserved11: 0, size: 1, configurationValue: [4])
53ec4eb8-a0b9-4af7-9513-30d2cecaaa77 10:02:30 AM: info [DTH] parse() - returning result=[name:lock, data:[lockName:Front Door Lock], value:unlocked, descriptionText:Unlocked, linkText:Front Door Lock, isStateChange:true, displayed:true]
53ec4eb8-a0b9-4af7-9513-30d2cecaaa77 10:02:30 AM: trace [DTH] Executing ‘zwaveEvent(DoorLockOperationReport)’ with cmd = DoorLockOperationReport(lockTimeoutMinutes: 254, doorLockMode: 0, insideDoorHandlesMode: 0, doorCondition: 2, outsideDoorHandlesMode: 0, lockTimeoutSeconds: 254)
53ec4eb8-a0b9-4af7-9513-30d2cecaaa77 10:02:28 AM: info [DTH] parse() - returning result=[[descriptionText:Is associated, linkText:Front Door Lock, isStateChange:false, displayed:false]]
53ec4eb8-a0b9-4af7-9513-30d2cecaaa77 10:02:28 AM: trace [DTH] Executing ‘zwaveEvent(physicalgraph.zwave.commands.associationv2.AssociationReport)’ with cmd = AssociationReport(reportsToFollow: 0, maxNodesSupported: 2, nodeId: [1], groupingIdentifier: 1)
53ec4eb8-a0b9-4af7-9513-30d2cecaaa77 10:02:22 AM: trace [DTH] Executing unlock() for device Front Door Lock
53ec4eb8-a0b9-4af7-9513-30d2cecaaa77 10:02:11 AM: trace Found Schlage
53ec4eb8-a0b9-4af7-9513-30d2cecaaa77 10:02:11 AM: trace Found Schlage
53ec4eb8-a0b9-4af7-9513-30d2cecaaa77 10:02:11 AM: trace Found Schlage
53ec4eb8-a0b9-4af7-9513-30d2cecaaa77 10:02:11 AM: debug Getting Sensitivity Level, current Alarm Mode forced
53ec4eb8-a0b9-4af7-9513-30d2cecaaa77 10:02:11 AM: debug Getting Alarm Level

I will go back and look but I think it has been reported. At least I recall a post related to this problem which was what got me unstuck. Thanks.


I’m trying to register some users in my IDLock (101) but I’m running into a wired problem.
I’m able to register 2 users. But for user 3-5 I always get errors.
Things I tried after this:

  • Deleting all users by setting the users to 0 and confirm. Then waited for quite a while before trying again.
  • Tried to install the Basic Lock User Management to delet users 2-5. But still the same.

What I see in the ST Log console for those users:

  • Retry programming exceeded, user 4 deletion not confirmed by lock Frontoor lock

I couldn’t find any post related to that. Any pointers would be greatly appreciated.

That’s because IDlock 101 only supports 2 programmable keypad users (master and service, master can’t be deleted). The 150 supports 25 keypad users. The first post has a comparison table between various lock models which may help.

I was looking through the post and couldn’t find that limitation.
From what I can see does the table only mention idlock and 25. No specifics for 101.

But in any case. Thanks for clarifying. :slight_smile:

1 Like

Hi, I bought some weeks ago an Z-wave ISurpass wall reader via Amazon (https://www.amazon.com/ISurpass-Magnatic-Suitable-Apartment-Entrance/dp/B07KS5VB1H/ref=sr_1_2?dchild=1&keywords=isurpass&qid=1587061156&sr=8-2) Will your Smart App control this device? I need to open my door using Smartthings

@RBoy My DTH needs to be updated. Can I delete the DTH in my SmartThings ID EA and then copy and paste your new code into my SmartThings IDE Without excluding my lock?

Don’t DELETE the DTH, Just go into the DTH, Edit, wipe out what’s in there and past over the top of it with the updated code. Save, Publish, Then go back into your SmartThings UI and run through the config again to initialize the new settings.


I’ve updated to the latest code for the lock user management DTH, but in the new smart things app, I still don’t have all of the options that the classic app has. See the screenshot below.

Any ideas what’s going on?

Normal. NewApp doesnt support custom tiles yet.

Well that’s really annoying. Smartthings is pushing us to use the new app but doesn’t support basic functions .Thanks for your help.

Do anyone know if this works with the Yale z-wave unit or Verisure z-wave unit in Norway?

If it’s a Yale Z-Wave module yes it’ll work. As I understand the Verisure is a WiFi lock.