[RELEASE] Universal Enhanced Z-Wave Lock Device Handler for Schlage, Yale, Kwikset, IDLock, Popp, Danalock, August Pro, Keywe, Philia, Samsung

It’s the same. Lock reports specific codes to the DTH to indicate issues with the mechanism which the DTH reports as state “unknown” to ST (which is what ActionTiles shows, it doesn’t translate).
Unknown, most of the time, represents a jammed/blocked situation where the lock is unable to operate because something is blocking the physical operation which is why the DTH displays it as Jammed to the user. If you see your recently tab it’ll show more details about the source of the problem as reported by the lock.

1 Like

I’ve got a few problems using this with my August Pro.

First, I noticed that on the device page I only have a couple of tiles visible; lock/unlock, battery level, and open indicator. All other tiles are blank.

Second, I can’t seem to clear the autolock feature. I go into the settings and turn off the feature (I see it in two places). But it always appears to still be set (and the lock continues to auto-lock).

I am running v04.00.09

Nothing wrong with that. You’ll only see tiles that you lock/model supports and is discovered by the DTH.

If you lock supports auto lock configuration remotely the tile will show up. If you don’t see a tile, it doesn’t support the configuration over Z-Wave. August lock firmware doesn’t support configuring auto lock over z-wave as yet.

This looks awesome @RBoy! I can’t wait to get this set up with my new Yale locks.

Is there any way to automatically call a web hook when a door is unlocked? I’d like to be able to do that to make a POST to an IFTTT Maker webhook to disarm my Abode alarm system.

You’ll need a SmartApp to subscribe to the events and make that happen. You can use something like CoRE or WebCoRE, see this post:

I just updated to the newest DH and SmartApp for the Universal Enhanced Z-Wave Lock with Alarm, Notification, RFID, Door Sensor and Advanced Features and Door Lock Code User Management with Unlock Notifications, Advanced Scheduling and Automatic Lock/Unlock.

I opened the app and saved it for my locks (I have two sets of locks and did it for both)

Now My locks are no longer working. The key codes still work, yes, and if I switch the deadbolt then SmartThings registers the change, but I can’t lock or unlock it from the app or any routines. It sticks on ‘unlocking’ or ‘locking’ and nothing happens. If I then manually lock it it registers and completes the change to whatever I was asking it to do, but it doesn’t lock it itself through the app.

I’ve been using this for quite a while and have not had any issues with updates before. This is for all of the locks (Schlage) in the house, they will update if done manually but the lock/unlock doesn’t do anything. Android Samsung S8+. Updated through the API in Windows. Even disconnected the batteries and tried it, then replaced the batteries in one lock which was at 71%. Battery is reporting fine.

I also shut down the smartthings app on my phone, cleared the cache, then reopened it and tried things. Then I rebooted the hub and tried it.

Still same behavior.

Ideas?

Almost forgot, I also ran a repair zwave network since the locks showed as inactive - the repair didn’t help either.

Reboot your hub, Exclude and re pair your lock and then do a z wave repair. Your lock/hub is having mesh issues. Some folks are facing this where it appears to be a one way communication state after the recent hub firmware update.

(moving my thread over here).

So, what is odd about my experience is that the behavior where the lock is locked by an activity yet reports unlocked only appears to happen in the activity. I can still properly lock the lock from the device page itself, and it always performs correctly. SO, I am not sure this is the same issue?

Also, I did, very recently, reboot hub, and re-paired lock and did a z-wave repair.

So your lock is sending an locked event and then is immmediately followed by a unlocked event?

Are you in the UK by any chance?

Nope, in the US.

And I don’t think it is actually sending a command to unlock? I think the state is just reporting unlocked?

Right, it looks like your lock is sending a report that’s saying it’s unlocked.
I would try to reset the lock. If that still doesn’t work try to contact Yale and get a new Z-Wave module. Never seen this before but it appears to be coming from the lock itself.

Yea, I was thinking of going in that direction. But it is still odd that I only see that behavior in the activity.

I did notice that you appear to be pinging the lock every hour and reporting on the battery level. I wonder if (maybe just for debugging purposes) it would be useful to report more of the state of the lock in the logs?

Yes that’s ST. The DTH does not initiate any action on its own, think it as a middle man who translates. ST polls the devices every 15-60 minutes.

Aargh! I shouldn’t have update the device handler then. Repairing locks is an absolute bear!
All was working fine before I updated the device handler. Like I said, no issues before with device handler updates, why was this one different?

I will try to do the lock updates tonight but this usually means taking the lock off the door and bringing it near to the hub. Grrr.

It’s something to do with the latest hub firmware update. Here a report from a user who found a solution:

I’ve also noticed I’ve had to reboot the hub when switching device handlers for the lock. Something causes the whole zwave mesh to seize and without a reboot huge lag of zwave devices.

You should also report it to ST support if you’re facing issues while switching custom handlers and rebooting / re pairing solves the issues for you.

I have rebooted (a couple of times now), and I have what I think might be more information.

The repair z-wave network doesn’t seem to be working. The ‘starting’ and ‘finished’ don’t appear and when I went in to the logs I only see pings, no repair info.

This is after a reboot and I have now tried several times. Is there a way to force a repair to start?

Report it to ST support so they can investigate

… And let us know when it appears to be resolved!

I’m having similar issues to those that others have reported. When trying to pair my August Pro I’m getting the “failed network security exchange” error. I’ve tried excluding, re-pairing, resetting the lock, etc, and get that message every time and am unable to control my lock through Smartthings.

Any ideas?

Means that your lock can’t complete the security protocol exchange with the hub while pairing.
Sometimes it helps to being the lock within 3ft of the hub while trying to pair.