[RELEASE] Universal Enhanced Z-Wave Lock Device Handler for Schlage, Yale, Kwikset, IDLock, Popp, Danalock, August Pro, Keywe, Philia, Samsung

I did the smartapp yesterday, no change. codes still there.

Excellent. Thanks so much.

You may need to reboot your lock, the DH is only reporting what the lock is sending it. PM me your IDE Live Logs,it’ll show what’s going on.

will reboot lock tonight but looking at the event list it does show it coming from the device.

1 Like

Hey Rboy, love your SmartApps and DHs. Is there any way to have them auto update? I hate having to constantly check the threads here, see an update, go to the site, enter login info, copy code, paste in IDE, etc EVERY TIME there is an update…

Thanks!

1 Like

Unfortunately ST hasn’t provided such a mechanism yet. I’ve requested them but no update yet.
For now just subscribe to our Facebook page and you’ll be notified of app and DH updates.

1 Like

Hi there. Here are my things in place:

Schlage Connect Touchscreen Deadbolt with alarm
Smartthing Multipurpose sensor

Sensor is working fine. I can unlock and unlock the deadbolt from Smartthings app with no issue

I’m trying to relock the door automatically after closing/relock immediately but nothing happens. Any ideas

resetting the lock did the trick. It is working now…

1 Like

How did you reset? Did you pull the battery?

Yes, but I’m having issues again, minutes after the reset…

I’m going through the full reset process now. I want to see if that helps communication. I’ll report back once complete.

A full reset did not help.

I guess even with several z-wave repeaters nothing beats the lock being close to the Hub for certain actions.

Same here, hopefully Rboy can give us a clue…

I was talking about this a few days ago with @slagle. Facing similar issues with the lab setup and the solution I found was to repair the z wave network. It worked fine a day then I had to repair it again, I did make a suggestion and Tim is taking to the engineers.

Like pointed out by @Drewbert34 the lock works great if directly communicating with the hub. If there are repeaters in between it sometimes causes a communication issue. One of the big reasons IMHO is the lack of verification or retry from the ST hub (a long standing request to ST). There’s no way to know if the command was successfully relayed to the device. Best option repair the Z-Wave network or try to re arranging your network setup

I’m using this device handler with a Yale Keyless lock - even with brand new lithium batteries it always reports the battery level as 10%?

The DH reports what the lock tells it. Try using regular alkaline batteries instead and see if it makes a difference.

It says 10% no matter what batteries - and always has done. I’ll get the DH to log the response and see what the lock is reporting tonight.

Hi!
I’m going to buy a Zwave lock called ID Lock. But I’m not sure how it will work with Smartthings

Here is some documentation on the zwave part of the lock:

http://idlock.no/media/wysiwyg/Bruksanvisning/IDL%20Operational%20Manual%20EN.pdf

Can anyone tell me if this can be integrated with smartthings?

They keypad part of the lock will most likely work with SmartThings, the RF part would need a custom DH to program and report

###Universal Enhanced Z-Wave Lock and Schlage Lock, Yale Lock and Kwikset Lock Device Handler - Version 2.10.3

  • Harmonized the code to be more inline with ST’s standards which will allow for easier reverse integration back into the ST Stock handler code over time
1 Like