[RELEASE] Universal Enhanced Z-Wave Lock Device Handler for Schlage, Yale, Kwikset, IDLock, Popp, Danalock, August Pro, Keywe, Philia, Samsung

I think you’re confusing 2 things, device handlers cannot be linked to other physical devices other than the core device itself (or should not be). What you’re referring to is the ability to use a third party sensor along with the lock door, that should be done through a SmartApp so for e.g. if you’re using the Multi User Code Management App it allows you to use a lock (this) and a door sensor (DPS) to make for use cases.

If you’re asking to separate the DPS as a separate sensor then that is not possible for a single device, it need to be one device. Hope this addresses your question.

@RBoy i copy and pasted everything the code for new smart app and got this error:

No signature of method: script1489718044292645365079.metadata() is applicable for argument types: (script1489718044292645365079$_run_closure1) values: [script1489718044292645365079$_run_closure1@37edf55d] Possible solutions: getMetadata(), getState(), setState(java.lang.Object), metaClass(groovy.lang.Closure)

How do I fix?

Check the instructions again, this is a Device handler, not a SmartApp.

I am successfully using the latest handler with a Schlage lock, but I recently purchased a Yale lock which appears to be incompatible with the handler. Below are details on the Yale Zigbee lock:

model: YRD210 PB DB
application: 84
manufacturer: Yale
endpointId: 01
Raw Description 01 0104 000A 00 07 0000 0001 0003 0009 000A 0101 0020 02 000A 0019

After discovery, Smartthings associates the default Zigbee Lock handler with this device and it works fine. But, if I attempt to edit the device within the IDE to associate the RBoy Universal Enhanced handler with this device, I cannot control the device.

Is the RBoy handler compatible with this Yale lock?

The Device Handler that this thread here is about is a universal one for z-wave locks, not zigbee locks.

1 Like

This DH is your one stop shop for Z-Wave Locks.

For ZigBee you may want to consider using this one:

1 Like

Thank you for clarifying. I have successfully installed the referenced ZigBee DTH and it works well.


for locks without DPS, would be neat if you could specify an existing paired contact sensor to mimic in the lock’s dashboard :slight_smile:

1 Like

Unfortunate ST doesn’t allow. Way to do that, have one device communicate with another device. That needs to happen through SmartApps.

I’m not sure if this is an issue with ST or the DTH, but I have it set to turn 2 lights on after dark when the door is unlocked. When I first installed it a few months ago, it was practically instantaneous. Since then, there seems to be a delay, sometimes up to 20 secs, or they don’t turn on at all. The Z-wave light is the most reliable one whereas the Zigbee light is hit or miss. Sometimes they’ll even turn on when I unlock the door in the middle of the day, hours away from it being dark. Any ideas?

Installed a new FE599 today. I am seeing the following in log “Unrecognized device. Contact developer with MSR null”

I have 3 schlage connects and switched them all to this dth. 2 are showing advanced tiles but one still only shows lock/unlock tiles. I see contact developer is Unknown lock. MSR null in my logs. Anything I can try to get it detected?

Could be degradation of the z-wave network or just platform issues. The one thing you can do is just reboot the hub and do a Z-Wave repair. Fixes most issues.

You third lock/lock didn’t register properly with the hub which is why it’s showing MSR null. Without the MSR the device handler doesn’t know how to use advanced features hence it defaults to basic lock/unlock only.

Just exclude the lock and pair it again, then hit the refresh tile a few times until the lock responds with the MSR code.

Actually I am having the same issue with my Schlage locks with how they are being paired.

here is how 2 of them are reporting (incorrectly) :
Data No data found for device
Raw Description zw:Fs type:4003 mfr:0000 prod:0000 model:0000 ver:43.37 zwv:2.64 lib:06 cc:85,73,72,98 sec:62,63,80,71,70,86,20

here is how the 3rd one is reporting (correctly):
Data MSR: 003B-634B-504C

Raw Description zw:Fs type:4003 mfr:003B prod:634B model:504C ver:43.37 zwv:2.64 lib:06 cc:85,73,72,98 sec:62,63,80,71,70,86,20

I contacted Schlage and they sent me a new lock free of charge but the new lock is reporting the same as the first 2. I have tried to exclude and remove the locks from the system and repaired and they still come up the same. Is this a problem with the lock or the device handler. I will try and contact Schlage again tomorrow and see if they can give me a straight answer .

That’s the issue. You my also want to reach out to ST support and see if they can figure out why the lock isn’t reporting the mfr, prod and model. It would be a pairing quirk. Try to Exclude the device, reboot the hub and then pair it. Maybe flushing the hub cache may help (i.e. rebooting).

###Universal Enhanced Z-Wave Lock and Schlage Lock, Yale Lock, Kwikset Lock, IDLock and DanaLock Device Handler - Version 03.03.00

  • Added support for reporting Master Codes usage (e.g. Yale, IDLock)
  • Added support for newer Yale locks

###Schlage Lock Alarm Mode and Sensitivity Change and Monitor - Version 01.02.01

  • < no change >

Please refer to the previous post for details on new features in release 03.02.00:
[RELEASE] Universal Enhanced Z-Wave Lock, Schlage Lock, Yale Lock, Kwikset Lock, IDLock, DanaLock and August Lock Device Handler with Alarm Control, Notification, RFID, Door Sensor and advanced features

Thanks. I excluded it and re-paired it a couple of times and it kept reporting MSR null. I finally decided to take it off the door and bring it closer to the hub and it was finally able to pair and report the correct information. Not sure if it was the proximity or just luck that got it to finally work but there is a datapoint for other people having issues at least.

1 Like

Hi Rboy, i am using z-wave lock device handler version 3.03 on 2 of my schlage connect locks. one lock shows all tiles, and beeps when i open close the door. The other only has 2 tiles, lock and unlock and does not beep. I tried reverting back to the original device handler and then going back to your device handler. I did a battery pull, and then a z-wave fix, but that didn’t work. Any ideas?

Goto the IDE -> My devices and click on your other lock, see if the MSR has
populated. Some folks are facing an issue with the recent hub firmware
update. If there’s no MSR, you will need to pair your lock again (bring it
close the the hub) and then click on refresh a couple of times. As soon as
the lock reports the MSR all the functionality will show up.

Also do report back if the MSR is blank or 0000 so we can report it to ST
support to investigate it.