[RELEASE] Universal Enhanced Z-Wave Lock Device Handler for Schlage, Yale, Kwikset, IDLock, Popp, Danalock, August Pro, Keywe, Philia, Samsung

Yes both are reported as “manual” locks (the lock can’t differentiate between inside manual and key as they’re physically connected to the same hardware).

Nuts :frowning: Thanks for the confirmation.

Got it. Thanks. I went for the Lifetime Package and installed this over the weekend. Is there a way in the app to set each lock to “Auto-Lock” after a certain time period after it’s unlocked (rather than if a door is closed) or do I need to go through the lock settings itself?

1 Like

Lock settings, it’s not advisable to auto lock without a sensor as it may end up damaging the door frame (for deadlocks).

1 Like

I’m back with that issue again where communication between the Lock and Smartthings seems good (lot of things going on in the logs) but cannot unlock or lock from the app.
Is there anything I should try before again hard reset evrything?

Edit:
Locking / unlocking manually is correctly logged and reported back to the app
Locking / Unlocking from the App generates NO logs
Enabling Autolock is logged but has no effect on the App (have the blue …) and refreshing will restore whatever status it was.
Same for Alarm Off, Audio On, Logged but nothing happens

Here an example of the logs

9:33:04 PM: debug Disabling keypad code unlock
9:32:19 PM: debug deleting code 2
9:32:19 PM: debug setting code 2 to
9:32:04 PM: trace Alarm off | Battery 87%
9:31:59 PM: debug Getting user pin code length
9:31:59 PM: trace refresh sending [‘988100700507’, ‘delay 5000’, ‘988100700504’, ‘delay 5000’, null, ‘delay 5000’, ‘98810070050F’, ‘delay 5000’, ‘988100700503’, ‘delay 5000’, ‘988100700510’, ‘delay 5000’, ‘9881006202’, ‘delay 5000’, ‘9881008002’, ‘delay 5000’]
9:31:59 PM: trace Current user pin code length 4
9:31:59 PM: debug GetSensitiveLevel Current Alarm mode is off -> 0
9:31:59 PM: debug There is no sensitive level when alarm is in off mode
9:31:59 PM: debug Getting auto lock state
9:31:59 PM: debug Getting Sensitivity Level
9:31:59 PM: debug Found Schlage FE/BE469
9:31:59 PM: debug Found Schlage FE/BE469
9:31:59 PM: debug Getting keypad code unlock state
9:31:59 PM: debug Found Schlage FE/BE469
9:31:59 PM: debug Schlage Touchscreen Deadbolt FE469NX Z-Wave Lock is associated to 1
9:31:59 PM: debug Getting Alarm Level
9:31:59 PM: debug Refresh called, Device MSR is 003B-6341-5044
9:31:29 PM: debug Disabling audio/beeper
9:31:19 PM: debug deleting code 1
9:31:19 PM: debug setting code 1 to
9:30:56 PM: debug GetSensitiveLevel Current Alarm mode is alert -> 1
9:30:56 PM: debug Found Schlage FE/BE469
9:30:56 PM: debug Getting Sensitivity Level
9:30:56 PM: debug AlarmToggle Setting Alarm mode to alert -> 1
9:30:56 PM: debug AlarmToggle Current Alarm mode is off
9:30:56 PM: debug Set Alarm Toggle
9:29:36 PM: debug Enabling auto lock
9:27:47 PM: debug "zw device: 11, command: 9881, payload: 00 71 05 00 00 00 FF 06 01 00 " parsed to [‘name’:‘lock’, ‘value’:‘locked’, ‘descriptionText’:Schlage Touchscreen Deadbolt FE469NX Z-Wave Lock was manually locked, ‘data’:[‘type’:‘manual’], ‘isStateChange’:true, ‘displayed’:true, ‘linkText’:‘Schlage Touchscreen Deadbolt FE469NX Z-Wave Lock’]
9:27:47 PM: trace Alarm off | Battery 87%
9:27:47 PM: debug AlarmReport AlarmReport(alarmLevel: 0, alarmType: 0, eventParameter: [], numberOfEventParameters: 0, zensorNetSourceNodeId: 0, zwaveAlarmEvent: 1, zwaveAlarmStatus: 255, zwaveAlarmType: 6)
9:27:32 PM: debug deleting code 2
9:27:31 PM: debug setting code 2 to
9:27:25 PM: debug "zw device: 11, command: 9881, payload: 00 71 05 00 00 00 FF 06 02 00 " parsed to [‘name’:‘lock’, ‘value’:‘unlocked’, ‘descriptionText’:Schlage Touchscreen Deadbolt FE469NX Z-Wave Lock was manually unlocked, ‘data’:[‘type’:‘manual’], ‘isStateChange’:true, ‘displayed’:true, ‘linkText’:‘Schlage Touchscreen Deadbolt FE469NX Z-Wave Lock’]
9:27:25 PM: trace Alarm off | Battery 87%
9:27:25 PM: debug AlarmReport AlarmReport(alarmLevel: 0, alarmType: 0, eventParameter: [], numberOfEventParameters: 0, zensorNetSourceNodeId: 0, zwaveAlarmEvent: 2, zwaveAlarmStatus: 255, zwaveAlarmType: 6)
9:27:14 PM: debug "zw device: 11, command: 9881, payload: 00 71 05 00 00 00 FF 06 01 00 " parsed to [‘name’:‘lock’, ‘value’:‘locked’, ‘descriptionText’:Schlage Touchscreen Deadbolt FE469NX Z-Wave Lock was manually locked, ‘data’:[‘type’:‘manual’], ‘isStateChange’:true, ‘displayed’:true, ‘linkText’:‘Schlage Touchscreen Deadbolt FE469NX Z-Wave Lock’]
9:27:14 PM: trace Alarm off | Battery 87%
9:27:14 PM: debug AlarmReport AlarmReport(alarmLevel: 0, alarmType: 0, eventParameter: [], numberOfEventParameters: 0, zensorNetSourceNodeId: 0, zwaveAlarmEvent: 1, zwaveAlarmStatus: 255, zwaveAlarmType: 6)
9:27:05 PM: debug "zw device: 11, command: 9881, payload: 00 62 03 00 00 00 FE FE " parsed to [‘name’:‘lock’, ‘value’:‘unlocked’, ‘isStateChange’:false, ‘displayed’:false, ‘linkText’:‘Schlage Touchscreen Deadbolt FE469NX Z-Wave Lock’, ‘descriptionText’:Schlage Touchscreen Deadbolt FE469NX Z-Wave Lock lock is unlocked]
9:27:05 PM: trace Alarm off | Battery 87%
9:27:05 PM: debug DoorLockOperationReport DoorLockOperationReport(doorCondition: 0, doorLockMode: 0, insideDoorHandlesMode: 0, lockTimeoutMinutes: 254, lockTimeoutSeconds: 254, outsideDoorHandlesMode: 0)
9:27:00 PM: debug "zw device: 11, command: 9881, payload: 00 71 05 00 00 00 FF 06 02 00 " parsed to [‘name’:‘lock’, ‘value’:‘unlocked’, ‘descriptionText’:Schlage Touchscreen Deadbolt FE469NX Z-Wave Lock was manually unlocked, ‘data’:[‘type’:‘manual’], ‘isStateChange’:true, ‘displayed’:true, ‘linkText’:‘Schlage Touchscreen Deadbolt FE469NX Z-Wave Lock’]
9:27:00 PM: trace Alarm off | Battery 87%
9:27:00 PM: debug AlarmReport AlarmReport(alarmLevel: 0, alarmType: 0, eventParameter: [], numberOfEventParameters: 0, zensorNetSourceNodeId: 0, zwaveAlarmEvent: 2, zwaveAlarmStatus: 255, zwaveAlarmType: 6)
9:26:30 PM: debug deleting code 1
9:26:30 PM: debug setting code 1 to
9:25:46 PM: debug Disabling keypad code unlock
9:25:39 PM: debug Disabling keypad code unlock
9:25:25 PM: debug GetSensitiveLevel Current Alarm mode is alert -> 1
9:25:25 PM: debug Found Schlage FE/BE469
9:25:25 PM: debug Getting Sensitivity Level
9:25:25 PM: debug AlarmToggle Setting Alarm mode to alert -> 1
9:25:25 PM: debug AlarmToggle Current Alarm mode is off
9:25:25 PM: debug Set Alarm Toggle
9:24:49 PM: debug Enabling auto lock
9:24:38 PM: debug deleting code 2
9:24:38 PM: debug setting code 2 to
9:23:38 PM: debug deleting code 1
9:23:38 PM: debug setting code 1 to

Likely due to the hub firmware update, getting reports of all kinds of issues with existing devices that have stopped working. The typical symptom is communication from device -> hub works but hub -> device does not work. Also a Z-Wave network repair would fail on such devices.

Try these 2 options (your choice):

  1. Cold reboot - unplug and remove batteries from hub for 30 minutes
  2. Exclude and repair the device

anyone able to see the website to download the handler?

You need to subscribe to RBOYAPPS to download the device handler. I did and have installed the handler, it works well and there is nothing else similar. It’s not cheap but it does work and if you compare the time to write it yourself it is very cheap.
Jon

The website is back up now, had an ISP issue. Thanks for your patience.

I unplugged my hub for an hour, and still the same issue…
I guess I should unpair / pair like I did last week .

Even my thermostat is not responding anymore… great… so fed up with Smartthing at the moment… between the routines not triggering and my devices working half way… it’s really annoying.
I guess this is down to the update they did.

Frustrating! Please report it to ST support. Until enough folks report it
they won’t accept the firmware has an issue. Right now they are treating it
like independent anomalies

Also if you have a v2 hub you need to remove the batteries also in addition
to unplugging it.

Sorry for the basic question but I am new to Smarthome and I am not a developer. This is all very interesting to me and I would like to start learning and setting my home up. Do any of the Smart locks work by detecting you phone and opening automatically when you get near the lock?

The only two I know of right now is the Yale Assure lock line and Danalock BTZU (Bluetooth w/Z-Wave). For the Yale lock there is a Z-Wave or ZigBee module you can buy to integrate with SmartThings.

Though it is pricy, I’d recommend the Yale over Danalock.

http://www.yalehome.com/en/yale/yalehome/residential/yale-real-living/yale-real-living-assure-lock-with-bluetooth/

1 Like

You can do that if you’re using a short distance presence sensor like the
SmartThings presence sensor.

Francky: Any update to your lock?

I’m seeing the same symptoms. I’ll report to SmartThings as well.

Tagging @Aaron. Finding this hard to be a coincidence that so many users
with beaming devices are finding the same issue with devices that were
working earlier but suddenly stopped working. May be worth investigating so
it doesn’t happen again in future updates.

I didn’t spent much more time on that issue, I spent enough time on ST recently.
And if I call they will ask to change the battery, unpair, pair… and it might work but that’s what I did last week and the issue came back anyways.

Lock is reporting its unlock or lock status but cannot be controled.

Yes that’s the issue I’m seeing with the new hub firmware update which seem
to be affecting beaming devices. It has one way control. Device can update
hub but hub can’t update (control) device. The only reliable solution is to
exclude the device and pair it again. But do report to ST support otherwise
they won’t investigate / fix it. You don’t need to follow up with them.
Just report it.

Thanks - I reported earlier today.

1 Like

This is the exact same issue I am having with the BE369. I added it, can control it, but it won’t assign codes. It acts like it’s working every time but none of the codes function at the lock. I’ve done everything possible (exclude, include, cold cycle hub, etc) to no avail. Anyone have this issue and solve it? This lock worked perfectly on Vera and Nexia in the past.