[RELEASE] Universal Enhanced Z-Wave Lock Device Handler for Schlage, Yale, Kwikset, IDLock, Popp, Danalock, August Pro, Keywe, Philia, Samsung

Drop our support team an eMail and we’ll look into it

EDIT: Currently you can configure Twist Assist (Turn n Go), Brake n Go Back and Auto Lock timeout through the device settings page for Danalock V3

Audio notifications (beep sounds) can only be enabled/disabled for V2

I’m an RBoy customer, and love all the custom handlers/smart apps. (and got my brother and brother-in-law to buy as well) :slight_smile:

I’ve had this recurring issue for a while know, and I’m hoping someone might be able to help me.

I have the Schlage FE469NX (Camelot).

The issue is that after about 2-3 months, the batteries die, but the lock never notifies me. The battery percentage stays at 97% for the entire 2-3 months, until it’s 0%. And the only way I know it’s at 0% is that I can’t get into my house all of the sudden (and I get the red X’s whenever trying to enter a code).

Is there a way to get actual battery readings? Or at a minimum, some kind of notification as soon as the batteries are depleted? If I look at the device now, it says unavailable and “Battery 0%”.

Did I configure something wrong? Or is this the normal operation?

Thanks in advance!

1 Like

The battery % is reported by the lock directly so there’s no way to adjust that.m, it could be a firmware issue or just a defective lock.
One thing you can try to reset the lock and exclude and pair it again with the hub. Sometimes that helps it reset its battery reporting.
Also are you using alkaline batteries, lithium or rechargeable batteries?

Thanks for the quick response. :slight_smile:

I’m just using standard Rayovac AA batteries.

I spoke with my brother who has 3 Schlage locks (slightly newer model) using your device handler and smart app. All 3 of his locks also report 97% battery, and they were just installed in December 2017. I’m thinking this might not be just a glitch specific to my lock. :frowning:

what is the email for your support team ?

and what is “audio controls” which is only valid for Danalock V2 ?

Possible, it may be new firmware that’s got an issue. The DH only reports what the lock tells it. We’ve got a few BE469 and 468 samples from Schalge and they all seem to report the battery levels fine all the down to 50% before the lock dies (see this topic for recommend battery replacement levels).

You may want to report it to Schlage if after resetting the lock it still doesn’t report the levels properly. I would also try a different battery brand just in case (make sure it’s alkaline and not manganese). This is a known issue with some Yale models but the first time I’m hearing it for Schlage. Check your firmware version under my devices for your lock. All our sample locks have this version

ver:104.21 zwv:3.42

@RBoy I use your DTH for the Danalock V3 and it works very well - thanks.
Howecer I have one question: the manual lock/unlock is not always reported on the “recent” tab in the app.
any suggestions what I could do to resolve that?

The display messages in the recently tab depends on a couple of things like:

  • Did the lock report the event to the hub
  • Did the event reach the hub or was it lost in the mesh
  • Did the state change (ST only displays events if the state has changed)

and a few more but these are the critical ones. When you say it doesn’t always report, I’m guessing it’s one of the conditions above, likely the event didn’t reach the hub. Always helps to have a few repeaters around the home and close to the lock to make for a strong mesh.

How to get this DH?

RBoy, I have a question for you. I’ve been using this DH for a while and wanted to know if the below is possible.

I have a Conexis L1 on my porch door and my front door. I use the same fob to gain entry to the house.

Is it possible rather than me touching the fob on both door panels, when I unlock the door of the porch, the front door unlocks too. BUT this only happens when I unlock the door with a fob, rather than doing a manual unlock by twisting the inside knob and releasing the lock?

Yes it’s possible, recently we released another app the Lock & Door Synchronizer, which basically does what you’re looking to do, when one lock unlocks, another one unlocks. However this one doesn’t differentiate between the “method” of the lock/unlock event, it synchronizes the lock states, so it won’t act only on RFID tags events.

Since the DTH captures the method, ie manual or rfid you can use this information to create a custom rule using CoRE or WebCoRE.

See this post above on how to create a rule using the method information passed by the lock to create your rule.

In your case you’ll be looking for method value of rfid when creating your rule, so if the lock value is unlocked and the method is rfid then unlock the other lock.

This is an important patch, ST deployed a change to their platform last evening which caused some apps/DTH to stop loading in the mobile app (“tiles missing”) due to a change in how they process certain input preferences.
EDIT: ST has patched the issue, the updated and existing device handlers should work fine now.

Universal Enhanced Z-Wave Lock and Schlage Lock, Yale Lock, Kwikset Lock, IDLock, DanaLock, August Pro and Samsung Lock Device Handler - Version 04.00.09

  • Patch for broken ST platform update causing device to show up as “missing tile”
  • Added tamper detection for more locks

Schlage Lock Alarm Mode and Sensitivity Change and Monitor - Version 02.02.00

  • < no changes >

To use with the Smart Locks dashboard refer to this post

This Device Handler has been tested and verified and optimized on the following lock models:

  • Yale Z-Wave locks (Assa Abloy, YRD2xx, YRD4xx, YRL2xx, YRC2xx, B1L, T1L, Keyfree, Assure, Conexis, Touchscreen, Deadbolt, RealLiving, nexTouch)
  • Schlage Z-Wave locks (FE469, BE469, BE468, FE599, BE369)
  • Kwikset (910, 912, 914, 916)
  • DanaLock (V2/V3)
  • August Pro
  • IDLock (101)
  • Samsung (SHP-xxx)
  • Monoprice

Key features include automatic discovery of lock features:

  • Lock/Unlock
  • Privacy/keypad control
  • Autolock
  • Audio control
  • One touch/Lock n leave
  • Alarm mode
  • Alarm sensitivity
  • DPS/Door sense
  • Fire/smoke alarm
  • Tamper/motion alerts
  • Emergency alerts (police/fire)
  • Battery life optimization
  • Configuration of parameters
    • Yale -> relock timeout, wrong code reporting limit and dps
    • Danalock ->turn speed, brake n go, turn n go and relock timeout

Copyright © RBoy Apps

1 Like

Are you able to share any links to information regarding this change to how certain input preferences are processed?

ST deployed a new JSON parser and it didn’t like having integers for enum keys in input preferences. The parser has been rolled back temporarily and they may make changes to the parser to keep with compatible with the existing behavior but as a safety measure we’re updating the apps to not use integer keys as recommended by ST.


@RBoy This Samsung lock is unrecognized MSR 032F-0003-0001. Are you able add support for it? Thanks.

1 Like

Sure we can, just copy, paste and email us the Raw Description from your device page along with your product model number and we’ll make the necessary adjustments. You may want to try to exclude and re pair your lock with the hub, it’s reporting a manufacturer code of 032F where as the Samsung Digital locks start with 022F, it could be a pairing error which is why it may not be recognizing it (it happens sometimes), if not eMail us the info and we’ll take it from there.

Just as a note - I saw the missing tile last night - and it was fixed this morning - and you’ve already posted a patch. This is one of the reasons the $35 lifetime license fee is more than worth it to me. A lock is “mission critical”. Thanks for the quick response!!!


Follow up to my post on the wrong thread. I changed my lock again to your DTH and this time it worked. Have no idea why it wouldn’t work the first time.

1 Like

ST requires perseverance. Given that it runs in the cloud, the majority of issues are resolved with the 3 R’s :wink:

  • Republish (delete and republish code)
  • Reboot (hub)
  • Re-pair (exclude and repair)

Using your DTH + smartapp + action tiles. Your app shows “jammed” on my android while the action tile shows “uknown”. Any way to decipher where the disconnect is?