[RELEASE] Universal Enhanced Z-Wave Lock Device Handler for Schlage, Yale, Kwikset, IDLock, Popp, Danalock, August Pro, Keywe, Philia, Samsung

Nope, you haven’t been doing anything wrong. For the most part that has always worked for most people. I think moving forward and with all the additional enhancements that have been made recently (compatibility with Smart Locks, etc.), additional issues are possible and with the procedures Maddie posted, you will ensure an even more successful upgrade/update without some of the issues you have seen posted the last couple days.

You are simply switching your devices to the stock DTH while you perform your code updates to the SA/DTH, and then change the Type back to the Universal DTH after saving and publishing. This step replaces the need for opening the device in Things and saving from the gear icon. :slight_smile:


Thanks for the response. Although I understood the difference in the procedure, I didn’t understand the need for the change. I’ll keep an eye out for issues.

1 Like

My raw data tile looks like this: zw:Fs type:4003 mfr:003B prod:6341 model:5044 ver:128.22 zwv:3.42 lib:06 cc:22,72,7A,98,86 sec:5D,85,20,80,70,62,71,63

All I show on the Right Now status is Lock/Unlock and a battery status two rows down. Should I reinstall the App and Device Handler in the IDE?

Exclude and repair for best results and update to the v04.00.02 code.

@RBoy was this update supposed to fix the main favorites page for unlocked and locked? I am still having the same issue, locks are unlocked, but main page still shows all locked.

Jason, read posts in other thread. This is a bug that @RBoy has submitted to ST.

1 Like

Always wondered why there are two separate threads for the @RBoy Locks. One for Device Handler and one for the SmartApp itself. Hard to follow everything having to bounce back and forth between both topics.

Wouldn’t it be better to merge the two?

1 Like

I under stand that, but in the post above for the update it says “update with patch for ST firmware bug” So is this the bug that was fixed or a different one.

I gotcha. Further up from Maddie’s post, I think that patch is related to this. Of course I could be wrong, but I think it applies to the following:


Submit a ticket to ST and mention that bug number that RBoy gave. The more traction it gets, the better and maybe quicker they resolve that annoying issue.

That’s the primary reason I have Smart Locks installed, just so I can view/monitor the status from the dashboard when I occasionally open the app.

Worked perfect. Thanks.

1 Like

I think I just got a notification that the DM got updated to 4.0 or something?

Do you know if your Universal Enhanced Z-Wave Lock Device Handler will work with the new IDLock model 150 and the new Z-Wave module?

The 150 z-wave module hasn’t been released as yet, the new 150 locks will be likely be shipping with the older 101 z-wave modules. So it should work fine.

1 Like

Thx a lot m8! :slight_smile:

My Yale conexis L1 eat battery. 3 days drain 50% :tired_face:

DH 4.0 SA 6.00003

That type of drain only has a few reasons:

  1. Battery - make sure you’re using Alkaline or Lithium 1.5V and not NiMH/rechargeable batteries, also check if you have a bad battery
  2. Defective unit in which case contact Yale support to get a replacement. (Some Schlage locks are known to have defective firmware which cause higher than normal battery drain but that’s measured in months)

if use as stand alone the battery goes normal of cause cant get any information from ST
and i see the ST send deletecode command every min.

ps The new battery just remain 10% now (9:30AM) that installed @ sat ( around 6pm)

I have the same issue with the Conexis L1

I had the issue a while ago and contacted Yale and they replaced the unit.
After the replacement it was doing about 2 months on a set of batteries -
not good but manageable. Now it is only doing 2 weeks maximum. There is
plenty of signal where it is. I have two other Yale locks both connected
to ST and they are fine. Just the Conexis which is the issue. I’ve
removed the Z-wave module yesterday to see how long it lasts


https://mailtrack.io/ Sent with Mailtrack

Jon Eskdale
07530 112233
Skype “eskdale”

1 Like

You must have figured out that “Universal…” was for the Device Handler :slight_smile:

1 Like