[RELEASE] Universal Ecobee Suite, Version 1.8.01

With my Ecobee Suite, there is a way. Unfortunately, there isn’t in the standard Ecobee support provided by SmartThings.

If you are using my Ecobee Suite, you should use the thermostat.setHumidifierMode( mode ) API call to change between “off”, “on”, or “auto”. The current setting is available in the humidifierMode attribute.

Frost Control is reported with the condensationAvoid attribute. You can enable/disable this using the thermostat.setEcobeeSettings( "condensationAvoid", "newValue" ) API call, specifying either “true” or “false”. There does not appear to be a way to change the window rating via the API, however.

I am wanting to create an automation that returns the ecobee to auto mode but am not seeing the option. Am I missing something? I feel like this used to be there.

That option is available on stock integration

1 Like

I guess I will have to use both stock and smartapp for now. :+1:

Ecobee Suite supports the Auto mode - the fact it is missing indicates that your installation didn’t complete correctly.

Try opening ES Manager, then saving it. Then do the same for the Thermostat device. it should populate then.

If it doesn’t, turn on Live Logging in the IDE, then repeat the above - watch for any Errors that may have occurred. If so, let me know…

Hi Barry. I did as you suggested and there are no errors in live logging and I still don’t have an auto option under the then in automations

The stock device handlers seem to hard-code this, but it is actually an option that has to be enabled on each thermostat.

Check your Ecobee Suite device page, and verify that these attributes are true:

  • autoHeatCoolFeatureEnabled : true
  • autoMode : true

If not, then you need to enable the feature on the thermostat:

Settings / Installation Settings / Thresholds / Enabled

You may need to repeat the open/save process from above again to get the driver to pick up the updated option.

I don’t seem to have those options. I’ve been having issues with both the ESM and Ecobee stock devices since the outage. I may try doing a fresh install of ESM. this is what I have on the device settings

No, the Auto setting is on the physical thermostat, not in ES Manager or ES Thermostat.

Is anyone else having problems after the latest hub update? I have 3 simple smart helpers for home away and sleep. All of which rely on the Smarthings location to put the thermostat in its corresponding mode. I noticed last night they stopped working. I have rebooted the hub, reinstalled the Ecobee Suite and reconfigured and I still cant get it to work. I also set the the option in the Ecobee Suite to send me a notification when an action occurs and that is not working for me either, even though I know it previously did. If I set a scene in Smartthings to change the temp on the thermostat it works but that obviously is not using the location like the Suite does.

I am having issues with Smart Lighting automations that are based on location mode changes no longer working. In my case, when the location mode changes to away, the automation to trigger my “All Lights Off” scene is not executing. This occurs even when I force the hub mode to “Away”.

JKP asked whether I had updated to iOS 15 (I have). Did you recently upgrade to iOS 15 - perhaps that’s the same root cause…

Seems similar, but I am on an Android. Last time the Android app was updated was Aug 23rd. I checked the date time my hub updated and it was at 5:22pm last night and that is pretty much when the location mode changed stopped working for me. It worked in the morning as my thermostat changed to away mode and then back to home when I got home yesterday right before 5:00pm. The rest of my automation that are based on location are working still which leads to to believe it has something to do with Smarththings transferring that location to the Ecobee smart app. But that is just a guess.

Good luck. I just found that by adding a similar Automation (outside of Smart Lighting App), the automation triggered the scene when the location mode changed.

After running a couple of tests, it seems time based automations are triggering ok in Smart Lighting but no location mode changes seem to be working.

Good thought. I actually did a similar action and believe it is related to something being broken with location mode change. I bypassed the location mode change selection in the helper and instead told it to use a switch. Turning the switch off (as i configured it) kicks off the correct action on the thermostat and I get a notification.

@wilds.west & @jmm0122 -

It seems pretty clear that this is a SmartThings issue. I suggest you both log a ticket with SmartThings Support.

PS. This is the primary reason so many SmartThings users have switched to Hubitat - With Hubitat, you get to choose when updates are applied, AND you can roll back to the previous version if things like this break.

IMHO, SmartThings is in a slow death spiral…

Thanks Barry. Couldn’t agree more … it is indeed a slow death spiral and I’m getting tired of rewriting and doing work arounds - starting with the transition from Classic app. I’ll submit a ticket.

I agree. I am planning on making the switch I’m just dreading moving all my devices and automation over. And lets be honest it is not the first or the last time Samsung will break location services so it will be a welcome switch.

I have the same issue on webCoRE smart app.
And submitted a ticket to the support…
No one here from SmartThings to help? :slight_smile:
They should understand that smarthome it’s not a game…

Auto Heat/Cool is enabled on physical ecobee

Then it is back to an incomplete installation.

Did you check that the 2 attributes mentioned above are in fact True?

You could try:

  • turn on Live Logging
  • deselect the thermostat in Ecobee Suite Manager
  • exit ES Manager
  • verify that the thermostat device was removed (if not, delete manually)
  • re-select the thermostat in ESM
  • exit back out of ESM

Hopefully, when the device is re-created, it will pick up the Auto option (I know it works - I use it all the time).

If it still didn’t work, check the Live Logs for errors in the ESM and ES Thermostat

Thanks!
Barry