[RELEASE] Universal Ecobee Suite, Version 1.8.01

After the recent V2 hub firmware updates I am getting an error (An unexpected error occurred) when trying to create (or edit) a Smart Circulation Helper. I’ve tried it from both the old and new app. After the migration I had to remove and reinstall the entire suite and I thought all was working well after that. I don’t remember the circulation helper having and issue other than not recognizing the ecobee mode. I’ve tried removing the helper and recreating it with both apps and get the same result. Any ideas what I may have set up wrong or may be missing?

7606fca0-b981-45c9-b11a-4f9c3d35354b 12:40:07 PM: error java.lang.ClassCastException

7606fca0-b981-45c9-b11a-4f9c3d35354b 12:40:07 PM: info Ecobee Suite Smart Circulation Helper, version 1.8.11 on SmartThings Initializing…

7606fca0-b981-45c9-b11a-4f9c3d35354b 12:40:07 PM: trace Installed with settings [fanOnTimeDelta:5, fanAdjustMinutes:10, infoOff:false, theSensors:[EcobeeSensor: Bedroom (M8Z6), EcobeeSensor: Family Room (M8YL), EcobeeSensor: Hallway (8SV8), EcobeeSensor: Kitchen (PLTB), EcobeeSensor: Office (BY78)], debugOff:false, maxFanOnTime:55, tempDisable:false, vacationOverride:false, minFanOnTime:5, theThermostat:EcobeeTherm: My ecobee, deltaTemp:5.0, minimize:false]

7606fca0-b981-45c9-b11a-4f9c3d35354b 12:39:49 PM: debug false and null

Edit: I should also add that when I create the helper in the old App it does finish but in the IDE it lists the State as “INCOMPLETE”. In the new App the helper never gets created after the error.

I have just noticed that my Smart Modes don’t seem to be working, which they were very recently.

Looking in my IDE I see the following error, and in the app I get a message about not being able to connect.

error physicalgraph.exception.StateCharacterLimitExceededException: State cannot be greater than 100000.0 characters @line 6788 (makeReservation)

I can save other Helper Smart Apps, but all my smart modes fail. I don’t see an update in the IDE, so I should be on the latest versions.

Still can’t get the smart modes to work, anyone else have it working? I am at the point of removing everything and installing clean, I just hate to lose the other helpers that are all configured

This SmartApp has basically stopped working for me. I’m about to completely remove it and maybe try to reinstall it.

Hopefully development on it will continue in the near future.

Same here. Just recently stopped polling weather data and making changes based on outdoor temp :frowning: did the removal and reinstall fix for you?

I confirm. After migrating to the new app, the motion is no longer reporting.
When I open the old app again, it shows stuck at either “Motion” or “No Motion” but not updating.
I just lost 3 motion sensors from the house :frowning:

Barry, thanks for providing us what Samsung and Ecobee won’t. Hoping you can resolve this new issue.

I haven’t yet completed this process. It was a PITA to even remove it, between the old and new apps. It kept erroring out when trying to remove it from the new app. I had to delete everything in the app, device wise, then in the old app I was finally able to remove the smartapp.

I haven’t yet reinstalled it.

Don’t bother y’all…I removed and uninstalled EVERYTHING and did a clean install, still could not get anything in Smart mode to work

I will look into this, but it appears that SmartThings may be imposing new limits on 3rd party code causing these errors. The problem could be aggravated by the fact that Ecobee recently changed from 128 character tokens to 7000+ character tokens. If this is the issue, a solution may take a while…

I am also having trouble with smart mode. It is not switching from “heat” to “auxHeatOnly” or “auxHeatOnly” to “heat”. It is getting cold enough here that I started using this again. I am on versions Suite Manager smart app 1.8.47, Suite Thermostat device handler 1.8.17, and Smart Mode smart app 1.8.22

In the logs for the smart mode helper it says it is switching to “auxHeatOnly” when the temp drops to the correct setting:


6:21:29 AM: trace Temp is 32.5°F, changed EcobeeTherm: Home to “auxHeatOnly” mode
6:21:29 AM: debug 411988522637 - currentMode: heat, desiredMode: “auxHeatOnly”, changing mode
6:21:27 AM: info Outside Temperature is: 32.5°F


This is correct, but in the logs for EcobeeTherm:Home I get this warning:


warn Requested Thermostat Mode (“auxHeatOnly”) is not supported by EcobeeTherm: Home


When the smartmode helper wants to switch to “heat” I get:


warn Requested Thermostat Mode (“heat”) is not supported by EcobeeTherm: Home


I’m not understanding how to changes modes (away / resume) with the new ST app. I had everything working in the old app for 2 years but now its broken with the new app. I understand creating the virtual switches but I don’t see anywhere I can set the mode of the thermostat. I have updated all my DH and Smart App code to the latest. Also under the thermostat I have like duplicate temp settings and mode setting (heat/cool/etc). Anyone else seeing this? This was one of my favorite things I had running with ST and I’d really like to get it working again.

Edit: NVM I found it. For anyone having the same issues you have to go to the smart app itself. Then you can use virtual switches to set the modes. Still curious about the duplicates under the thermostats.

@storageanarchy, I have a theory on why notifications that worked in the Classic app don’t in the new App. I noticed with some of my Webcore pistons they were only notifying in Classic. I had to flip them to “Store in Messages” and then the push notifications work in the new app.

Perhaps you need to set your code to store in messages?

More info here:

Not sure what I am doing wrong but I am not able to adjust my thermostat when I change the device handler to the ecobee Suite thermostat? It says network or server error occurred. Not sure if I am missed a step.

I figured it out. Another Device was created automatically under device that I can control.

Hello.
First of all, thank you Barry for this great suite of app. It’s a great package.
I mostly installed the suite in order to control my Keen vents. I had a false start on inital install but everything is back to working. No issues with the second round of installation.

What I would like to accomplish with this would be to have room level temperature control simply by going in the smarthings app and adjusting the temperature on a room by room basis. I see that the suite now supports virtual thermostat. Are there any recommendations of virtual thermostat implementations that work well with this suite?
I really would like to see a virtual device handler to control the temperature so I can have one per room and that it can easily be controlled with Google home.

You can use any Virtual Thermostat device handler you can find that works with the new SmartThings.

Thanks!
Barry

Hi Barry
I’m only aware of the samsung virtual thermostat one. I know Rboys has a few but they need a switch to control based on what I could see…

From your apps, do you read the value from the device or is it an event based subscribtion, which in my head implies an app?

@storageanarchy
I uninstalled and reinstalled the Ecobee suite, but I still get this warning in EcobeeTherm: Thermostat when my smart mode helper tries to switch modes:

warn Requested Thermostat Mode (“auxHeatOnly”) is not supported by EcobeeTherm: Thermostat

When the smartmode helper wants to switch to “heat” I get:

warn Requested Thermostat Mode (“heat”) is not supported by EcobeeTherm: Thermostat

I am looking for some clarification in the circulation helper. It says "Adjust Circulation when the indoor/outdoor temperature difference is: " If I select “5 to 10 degrees warmer,” does that mean the indoor temperature is 5 to 10 degrees warmer than the outdoor. I wanted to make sure that it was not outdoor temperature is 5 to 10 degrees warmer than the indoor.