[RELEASE] Universal Ecobee Suite, Version 1.8.01

Barry, youre a rockstar…I really appreciate the time you put into this software. I have been using it for a while now and today I noticed that some of my automations no longer worked…so I updated the suite and I noticed that in the Smart Mode smartapp, it will no longer allow me to use the indoor temperature setpoints to change the mode( it’s a crucial addition that I really liked). It says you should be able to and there a “button” for it but it’s “greyed” out, and gives you no options when you tap it. Is it just a bug or it that a feature you later decided to remove?

Hi Barry,
Thank you so much for this app I have been using it for the last year. However it seems like new smart mode, program and setpoint helper used to have a indoor temp. For example I set outside temp from the sensor if it is below 68 turn on the heat to 75 and if it is above 78 turn it to cool to 75. What is happening is that the inside temp will rise to like 80 when it is set to heat and it gets too hot. I guess having two hvac units? I thought there used to be something that said something like if it gets to like 78 inside then cool it down. I am using auto right now but it is not really what I want because you have specify that range instead of saying try to keep it at 75. I hope that makes sense and you could point me to the right direction. Thanks Barry!

First Thank you for wonderful smartapp ! I’m using Ecobee Suite version 1.8.47 (Ecobee Suite Thermostat 1.8.17) and it’s working great so far except smart mode. it says
"(warn) Requested Thermostat Mode (“auto”) is not supported by EcobeeTherm: "
"Can you fix this ? Thanks!

I’m having a bit of a hard time following the recent conversation, with “Mode” referring to multiple things. I performed the install, and everything looks fine, but I don’t see any way to change the mode to “Home” or “Away”. Unfortunately, this functionality was the whole reason I am trying this custom code out.

Is this supposed to be an included feature, or did I misunderstand? My goal is to be able to change the mode to “Away” in SmartThings when I leave, and back to “Home” when I arrive. The built-in handler for Ecobee does not allow this, nor does the integration with Google Home or Alexa. It seems that IFTTT is the only official integration that allows you to change to “Home” or “Away” mode. Based on the upcoming IFTTT account changes, I’m hoping there is an unofficial integration that will allow this in SmartThings.

Thanks

Update: Never mind. I realize now that I need to use one of the “Helpers” to do this.

Yes, the helper can allow you to do this. I use Life360 as our presence sensors. When everyone is sensed as being away, ST changes the location mode to Away which triggers Ecobee suite sensor to change the thermostat to Away.

1 Like

So the smart mode smartapp is now acting weirdly with 1.8.22 update…it is actually changing the mode based on the indoor temp, problem is…I didn’t set it up to do that, nor can I access the indoor temp setpoint menu. I have 2thermostats and on the upstairs one I used to use the indoor temp setpoint to change the mode, but all of the sudden I lost that functionality with one of the recent updates. Now with the 1.8.22 update the downstairs thermostat is changing mode based on indoor temp and I never set that one to do that, that one was always set to change based on outdoor temp

I opened an issue because it looks like ES somehow set the thermostatOperatingMode to “offline”. I had created a thread at the webCoRE forum about this: https://community.webcore.co/t/thermostatoperatingstate-missing-an-enumeration-offline/18197

As I posted over on the gitHub thread:

You have made an incorrect assumption that if the operating state isn’t “idle” or “fan only”, then your HVAC is operating - this is not necessarily true. If you want to write code that does something if a certain state exists (e.g., “cooling” or “heating”), then you should check for the presence of those values - in this way you future-proof your code in the event the definition is expanded.

FWIW, there is nothing that states that an attribute cannot contain more values than are currently defined - additional attributes and attribute values can be added at ANY time. And in fact, the current definition includes operating_state values that are not supported by most thermostats (pending_heat and pending_cool).

An operating state of “offline” indicates that the Driver is no longer in communication with the device. And if you think about it, returning ANY OTHER OPERATING STATE would be incorrect, because the code does not know what state the thermostat is in while it is offline. Thus, the added functionality of “offline” allows you to code how you want to handle the situation, instead of keeping you blind to the fact that the thermostat is offline.

I will not be changing my Ecobee Suite, so if you want to use your code as it is, then please install some other Ecobee integration…

2 Likes

I started my thread over there thinking it’s a bug in webCoRE, since it won’t let you select any more values other than the predefined ones. The only workaround there is to change my copy of webCoRE to include an additional value. Instead, you’ll see I already did what you suggest, flipping the logic and only check for the 4 active states (pending heat, heating, pending cool, cooling).

But you can see the problem: if some device can add “offline”, it can also add a new value indicating the system is running (I could make up"extended cooling" for when an Ecobee runs cooling to decrease humidty). That would also break my piston.

But my piston is fixed and 'm exceptionally happy with your Ecobee Suite.

@storageanarchy - welcome back (I think you were off the boards for a few weeks) - any updates on when you might get to triggering SHM in the new app based upon a scene execution?

That’s the one thing keeping me from changing my EcoBee modes through your app versus just setting temperature setpoints through the automation.

What you describe is already supported: simply create a virtual switch for each desired climate/comfort setting, then have your scenes turn on the appropriate virtual switch, and have a Routine/Switch/Mode/Program helper do the change based on the Virtual Switch being turned on.

This is supported on both SmartThings and Hubitat; I prefer not to add any more platform-specific features…

2 Likes

hi Barry,

Do i have to perform any special steps to enable 2FA on my ecobee account to use this app ? Trying to get my ecobee camera working again if possible…

  • Works with both the Ecobee standard and the new 2-factor authentication schemas

Got it - I prefer that you don’t add platform specific features either :slight_smile: will create more virtual switches to do what I need - thanks!!!

Hi barry,
Any plans to enable indoor temps as trigger setpoints in the smart mode smartapp?

There is something really off with the smart mode smartapp or device handler…I have the outdoor temperature set as setpoints to change between heat and cool with text notifications when it makes changes. The outside temp has just fallen below the setpoint so it should be changing it to heat and I am getting the text notifications that it is doing so …problem is, the setting in the thermostat is not changing. Please advise!

hi barry, can we use Mode(/Routine)/Switches/Program Helper to return back to ecobee’s schedule? it seems that I can only set to Home, Sleep, Away, or Vacation

In the “Actions” section of the Program Helper under “Switch to this Ecobee Program:” I have the option “Resume Program”, which returns Ecobee to it’s schedule.

Thanks!! Found it!!

Hello. I’m having an issue with the smart circulation helper app. If I go into the helper apps and click on my smart circulation app it gives an error of “Something went wrong. Please try to install the SmartApp again”. Is it possible to remove 1 helper? If so, how?

Versions:
Ecobee Suite Manager: 1.8.47
Ecobee Suite Therm: 1.8.17
Ecobee Suite Smart Circulation Handler: 1.8.11

I suggest verifying that Smart Circulation is installed properly as a SmartApp, and not as a Device Handler.