[RELEASE] Universal Ecobee Suite, Version 1.8.01

Please see the first item in the FAQ (you need to manually remove the temporary devices).

That’s what I get for doing this at 6am before coffee. That was it - thanks!

1 Like

Please get the 1.8.19 version of Ecobee Suite Routines and let me know if that fixes it…

Barry - Awesome! It seems to work. I will continue testing and will let you know if anything comes up. Thank you so much for your great work.

Hi, Barry,

While testing the mode/routine helper for other scenarios, I came across a couple of cases that still generate an error. If “Switches On/Off” is selected as a trigger, the app successfully finishes the action including turning on/off a virtual switch as an action. However, if “Ecobee Program Change” is selected as a trigger, an error is generated when trying to turn on/off a virtual switch as an action. See the following live log.


[f41dc272-6a45-4a52-ba7a-455717f2c0c6] 6:24:11 PM: error groovy.lang.MissingMethodException: No signature of method: script_app_8d0272203f60ce3779a9e7e4fc9c4468a8e7a5d0c00de9bc624713f09fafdea5.runin() is applicable for argument types: (java.lang.Integer, java.lang.String, java.util.LinkedHashMap) values: [15, changeSwitches, [overwrite:true]]
Possible solutions: run(), run(), runIn(java.lang.Object, java.lang.Object), runIn(java.lang.Object, java.lang.Object, java.util.Map), url(), find() @line 576 (changeSTHandler)

[f41dc272-6a45-4a52-ba7a-455717f2c0c6] 6:24:11 PM: trace Notification Message (notify=false): Changing Mode to Work Home because EcobeeTherm: Home changed to Work Home

[f41dc272-6a45-4a52-ba7a-455717f2c0c6] 6:24:10 PM: info Changing Mode to Work Home because EcobeeTherm: Home changed to Work Home

[f41dc272-6a45-4a52-ba7a-455717f2c0c6] 6:24:10 PM: trace changeSTHandler() - entered with evt: currentProgram: Work Home


I suspect the mode/routing app still has an issue when executing “switch on/off” as an action when trigger is Ecobee Program Change. (And possibly other triggers such as Location Mode Change although I haven’t tested it.)

Thank you for your attention to this.

Fixed in Ecobee Suite Routines, v1.8.20

Ecobee Suite Routines updated 1 July 2020 at 7:00am EDT

Fixes issues with turning on/off switches

Has anyone else noticed a problem with Smart Circulation Helper since the last firmware push? The IDE log looks like everything is fine so I’m suspecting a problem with the ecobee firmware. What I’m seeing is that when the ecobee is placed into hold it is ignoring any changes in the fan runtime. For example, if the fan is at 55 min/hr when the hold happens it is staying at 55 until the hold is lifted. When I look at the log I can see the fan times reduce as expected until it reaches 5 min/hr. However, the fan continues to run at 55 min/hr even though both the ST and ecobee aps both show it should be 5 min/hr.

Please report this to Ecobee support - perhaps if they see it coming from multiple people they will actually look into it (you are the 2nd or 3rd person to mention it).

Thanks, I’ll pass it along.

I wanted to follow up on my issue about the fan control. As suspected, it had nothing to do with your app but it does affect the functionality of your app in some circumstances. Apparently if the thermostat is in a hold mode, any changes to the fan runtime will not take effect until you toggle the fan on/auto slider, or cancel the hold. It didn’t used to behave this way (I frequently run in hold mode) but apparently it does now. This is confirmed from Ecobee support.

Interesting…

Does it work if you use the fan toggle on the ES Thermostat device page? If so, I can look into adding an option to the Smart Circulation Helper toggle the fan on/auto whenever the circulation time is changed while a hold is set.

Yes it does. That should be a good workaround. Thanks!

Just for some more data…

This is what I am seeing also. Today I’m WFH and the ecobee is in smart home/away hold. I watched the IDE live logs walk back the fan on time from 55min to 5 min in 10 min increments. The ST Classic app and the ecobee app both show the correct 5min but the ecobee itself is still showing 55 min. Cycling the fan auto/on slide on the tstat did not clear it. But, cycling the same toggle in the app did set to the correct time.

QQ, do you know if Ecobee solved the 2FA problem? Just checking since I couldn’t find it on the thread. Thanks!

I don’t think Ecobee has fixed the 2FA issue with 3rd party apps yet, no…

Oh, that’s bad news. I just got one of their Smart Cameras, and I found I have to enable 2FA before I can set it up.

Smart Circulation enhancement idea…

I love the smart circulation helper app. I’ve been using it since I installed this smart app over a year ago. However, there is one downfall of running in fan-only mode during AC season: Humidity. If the fan runs within 15-20 minutes of the AC shutting off, the condensation on the A-Coil just gets redistributed around the house like a humidifier. If you let the A-Coil sit and drip for 15-20 minutes, this effect seems to be lessened significantly. Maybe an option could be added that would allow for a delay between AC-off and the beginning of the circulation? I realize this is a pretty niche ask, but this app seems to be able to handle just about any scenario if you know how to configure it, so I wanted to mention it.

Smart Circulation does not control WHEN the fan runs - it only adjusts the minimum fan run time per hour. It is the thermostat that figures out if and when to run the fan.

The good news is that the thermostat’s fan time is predictable: it takes the number of minutes, divides by 4, and runs the fan starting every 15 minutes if the fan hasn’t been run by the HVAC heat/cool demand. So, the way to compensate for your humidity case is to set the MAXIMUM fan run time that the Helper will adjust to only 30 minutes (or less). This will run 7-8 minutes every 15 minutes, and generally WON’T keep the fan running after a cooling session runs.

Do you have an Ecobee support ticket number or something else identifying the problem on their end? I’m in touch with some people from their Vibee program and want to highlight this issue to them.

Nope - I don’t have a ticket number…sorry. I learned from my users about the issue, and I haven’t turn 2FA on because I don’t want to lock myself out.

Barry