[RELEASE] Universal Ecobee Suite, Version 1.8.01

I’m not sure if this was already asked (sorry if it was, I couldn’t find it), but will you be supporting the ecobee door and window smartsensors (these guys) at any time in the near future?

I picked up the sensor pack and was disappointed to find out that the door sensor doesn’t really do anything but tell you if the door is open or not in the ecobee app. I’m afraid that this probably means that you are unable to get at it from the API as well…

I have no plans to support these devices at this time, mainly because the API I use doesn’t support them. SmartThings may have access to the dynamic device API (if there is such a thing), so best to ask them if they plan on supporting them…they already support the Ecobee Switch, so it’s possible. And yes, you can run both the SmartThings and Ecobee Suite integrations on the same SmartThings hub.

1 Like

I will look into adding a “don’t close THIS vent if THIS room temperature is (higher/lower) than THAT room temperature” option.

Or maybe better/simpler would be “don’t (close/open) THIS vent if (any/all) of THOSE vents are (open/closed)” - this would support more use cases.

Thoughts/feedback???

Hi, Barry,

This is an incredibly useful app and I really appreciate your work. I am a new user running a few Helper apps.

I am having an issue with Mode/routine/switches/program helper version 1.8.17. I am trying to use the helper to turn on/off a virtual switch when the Ecobee program changes to a specific comfort setting (Home, Sleep, custom setting, etc.). The “Actions” in the helper seems to require change of mode or execute routine before changing switches (optional). Since I just want to flip the virtual switch, I simply selected “routine” without specifying any routine. Currently I don’t have any routine in the SmartThings app and the helper is not asking me to choose any. But when the helper is triggered, it seems that a “null” routine is executed and doesn’t seem to move forward to flipping the switch. The SmartThings app doesn’t allow me to create routines any more, so I can’t even create a dummy routine.

Is there any way to skip change mode/execute routine and simply flip a switch?

Thank you in advance.

Ecobee Suite update posted 28 June 2020 at 12:00pm EDT

Enhancement:

  • Ecobee Suite Routines, v1.8.18
    • Allows Action to be switch change only (Mode and/or Routine are no longer required)

This enhancement is primarily for SmartThings users who can no longer create new Routines.

1 Like

@sr1212 See update to Routines Helper that I just posted.

Hi, Barry - thanks so much for your quick response. I successfully updated SmartThings IDE from the repo, but the Ecobee Suite Routine helper in the SmartThings app still shows as version 1.8.17. Should I remove and reinstall the whole suite? If I do it, will I lose all SmartApp helpers I created so far?

I am sure I am missing something. Thank you for your help again.

Did you republish it after doing the update?

John - I believe so. I followed the “ Updating with GitHub Integration” instruction on the github page and finished all steps down to “Click Execute Update,” and confirmed the “1 published” message. Is there any additional step I have to go through?

Thanks.

No, that should be all you need to do. I just confirmed I got 1.8.18 after doing the same steps.

Can you go to the “My SmartApps” tab in the IDE, click on the underlined words:
image
And verify that line 41 says “1.8.18”. Then you can always click Publish->For Me in the tool strip on the upper right.
image

Hi, John,

Thanks so much for responding. I checked the ide and it has the new version 1.8.18. I also clicked the “publish - for me” drop down menu to make sure again.

However, when I go to the SmartThings app, it still shows the old version number:

Not sure what I am doing wrong. Thanks a lot for your help.

You don’t appear to be doing anything wrong. I’m not sure what is going wrong.

Just to be sure this isn’t a shard mismatch: did you go to the IDE via ide.smartthings.com or account.smartthings.com (and not directly to graph.api.smartthings.com)?

Interesting. I just checked the “update from repo” one more time and found that the new version showed up again in the “Obsolete (updated in GitHub)” box. I updated the ide with it and now SmartThings app properly displays version 1.8.18.

Thanks so much. I will start testing it. (For what is worth, I have been going to the ide through https://graph.api.smartthings.com/ which directs me to https://account.smartthings.com/login for login.)

Don’t go directly to graph.api – always use one of the other two links. They will redirect you to the correct shard after you login (many details you don’t need to know at FAQ: How to find out what "shard" (cloud slice IDE URL) your Account / Location is on?). If you login to the wrong shard and install a SmartApp or DTH, you won’t see it in your account (and it will be confusing).

John - thanks for the tip. I will definitely keep it in mind.

Barry - I started testing the switch function in the routine helper v1.8.18, but somehow cannot get it to work. I created two virtual switches for testing. I use one for trigger and the other for action. I also set the Ecobee program to change as an “action” in the helper.

When I push the trigger virtual switch, I see in the activity feed that the Ecobee program is changed as expected, but the “action” switch is not activated. I created a few different scenarios but the switch doesn’t seem to be activated while the location mode or ecobee program successfully gets updated by the app.

Could you check if the switch function is working properly? I am new to SmartThings and couldn’t understand the code. I am running the app on iOS 13 and I don’t use any hub. (Essentially I am using SmartThings app as an automation tool for Ecobee without SmartThings hub.)

Thanks you a lot for the great work and your generous help.

Thanks for the info! I contacted ecobee, but they haven’t responded.

First - thanks for giving me additional information I need to understand what you are trying to do.

Second - Please turn on Live Logging in the SmartThings IDE and then run your test again. When it fails again, click on each of the 3 apps/devices listed below and look for any “Error” messages at the time of your test:

  • Ecobee Suite Manager
  • Ecobee Suite Thermostat
  • Ecobee Suite Mode/Routine/Switches/Program Helper

These logs should record what went wrong. If so, please copy/paste the surrounding 10-20 lines before and 5-10 lines after the error message…

Hi Barry

This is what I got from the live log when the app tries to turn on a virtual switch. It’s the routine app. It’s the only log that shows an error. Ecobee suite manager did not show any error.

[1708827f-23ac-4410-bfe4-e6f0d2d72808] 5:58:16 PM: error java.lang.IllegalArgumentException: Property ‘on()’ is not supported for devices @line -1 (doCall)

[1708827f-23ac-4410-bfe4-e6f0d2d72808] 5:58:16 PM: trace Notification Message (notify=false): I set EcobeeTherm: Home to Hold: Work Home until next scheduled program change

[1708827f-23ac-4410-bfe4-e6f0d2d72808] 5:58:14 PM: debug sendHoldType: nextTransition, sendHoldHours: null

[1708827f-23ac-4410-bfe4-e6f0d2d72808] 5:58:14 PM: info Using holdType nextTransition

[1708827f-23ac-4410-bfe4-e6f0d2d72808] 5:58:12 PM: trace Setting Thermostat Program to programParam: Work Home and holdType: Thermostat Setting

[1708827f-23ac-4410-bfe4-e6f0d2d72808] 5:58:12 PM: debug thermostatHold:

[1708827f-23ac-4410-bfe4-e6f0d2d72808] 5:58:12 PM: trace In each loop: Working on stat: EcobeeTherm: Home

[1708827f-23ac-4410-bfe4-e6f0d2d72808] 5:58:12 PM: trace changeProgramHandler() entered with evt: switch: on

[1708827f-23ac-4410-bfe4-e6f0d2d72808] 5:58:12 PM: trace changeSwitchHandler() entered with evt: Test button (VS) switch turned on

As you predicted, an error message showed up. Hope this is helpful.

Hoping that somebody can shed some light for me on this. I’ve gone through the GitHub installation method and got to the point of installing the app on my iPhone. I can authorize it in ecobee just fine (can see it in My Apps), and when I click Done the first time, I do see the “Ecobee Suite Manager is now installed and automating” message - which is immediately followed by this message:

I’ve removed everything from IDE and my ST app and gone through the process twice now to no avail. Any ideas? I haven’t skipped a single step (including OAuth).

Please see the first item in the FAQ (you need to manually remove the temporary devices).