[RELEASE] Universal Ecobee Suite, Version 1.8.01

John - I believe so. I followed the “ Updating with GitHub Integration” instruction on the github page and finished all steps down to “Click Execute Update,” and confirmed the “1 published” message. Is there any additional step I have to go through?

Thanks.

No, that should be all you need to do. I just confirmed I got 1.8.18 after doing the same steps.

Can you go to the “My SmartApps” tab in the IDE, click on the underlined words:
image
And verify that line 41 says “1.8.18”. Then you can always click Publish->For Me in the tool strip on the upper right.
image

Hi, John,

Thanks so much for responding. I checked the ide and it has the new version 1.8.18. I also clicked the “publish - for me” drop down menu to make sure again.

However, when I go to the SmartThings app, it still shows the old version number:

Not sure what I am doing wrong. Thanks a lot for your help.

You don’t appear to be doing anything wrong. I’m not sure what is going wrong.

Just to be sure this isn’t a shard mismatch: did you go to the IDE via ide.smartthings.com or account.smartthings.com (and not directly to graph.api.smartthings.com)?

Interesting. I just checked the “update from repo” one more time and found that the new version showed up again in the “Obsolete (updated in GitHub)” box. I updated the ide with it and now SmartThings app properly displays version 1.8.18.

Thanks so much. I will start testing it. (For what is worth, I have been going to the ide through https://graph.api.smartthings.com/ which directs me to https://account.smartthings.com/login for login.)

Don’t go directly to graph.api – always use one of the other two links. They will redirect you to the correct shard after you login (many details you don’t need to know at FAQ: How to find out what "shard" (cloud slice IDE URL) your Account / Location is on?). If you login to the wrong shard and install a SmartApp or DTH, you won’t see it in your account (and it will be confusing).

John - thanks for the tip. I will definitely keep it in mind.

Barry - I started testing the switch function in the routine helper v1.8.18, but somehow cannot get it to work. I created two virtual switches for testing. I use one for trigger and the other for action. I also set the Ecobee program to change as an “action” in the helper.

When I push the trigger virtual switch, I see in the activity feed that the Ecobee program is changed as expected, but the “action” switch is not activated. I created a few different scenarios but the switch doesn’t seem to be activated while the location mode or ecobee program successfully gets updated by the app.

Could you check if the switch function is working properly? I am new to SmartThings and couldn’t understand the code. I am running the app on iOS 13 and I don’t use any hub. (Essentially I am using SmartThings app as an automation tool for Ecobee without SmartThings hub.)

Thanks you a lot for the great work and your generous help.

Thanks for the info! I contacted ecobee, but they haven’t responded.

First - thanks for giving me additional information I need to understand what you are trying to do.

Second - Please turn on Live Logging in the SmartThings IDE and then run your test again. When it fails again, click on each of the 3 apps/devices listed below and look for any “Error” messages at the time of your test:

  • Ecobee Suite Manager
  • Ecobee Suite Thermostat
  • Ecobee Suite Mode/Routine/Switches/Program Helper

These logs should record what went wrong. If so, please copy/paste the surrounding 10-20 lines before and 5-10 lines after the error message…

Hi Barry

This is what I got from the live log when the app tries to turn on a virtual switch. It’s the routine app. It’s the only log that shows an error. Ecobee suite manager did not show any error.

[1708827f-23ac-4410-bfe4-e6f0d2d72808] 5:58:16 PM: error java.lang.IllegalArgumentException: Property ‘on()’ is not supported for devices @line -1 (doCall)

[1708827f-23ac-4410-bfe4-e6f0d2d72808] 5:58:16 PM: trace Notification Message (notify=false): I set EcobeeTherm: Home to Hold: Work Home until next scheduled program change

[1708827f-23ac-4410-bfe4-e6f0d2d72808] 5:58:14 PM: debug sendHoldType: nextTransition, sendHoldHours: null

[1708827f-23ac-4410-bfe4-e6f0d2d72808] 5:58:14 PM: info Using holdType nextTransition

[1708827f-23ac-4410-bfe4-e6f0d2d72808] 5:58:12 PM: trace Setting Thermostat Program to programParam: Work Home and holdType: Thermostat Setting

[1708827f-23ac-4410-bfe4-e6f0d2d72808] 5:58:12 PM: debug thermostatHold:

[1708827f-23ac-4410-bfe4-e6f0d2d72808] 5:58:12 PM: trace In each loop: Working on stat: EcobeeTherm: Home

[1708827f-23ac-4410-bfe4-e6f0d2d72808] 5:58:12 PM: trace changeProgramHandler() entered with evt: switch: on

[1708827f-23ac-4410-bfe4-e6f0d2d72808] 5:58:12 PM: trace changeSwitchHandler() entered with evt: Test button (VS) switch turned on

As you predicted, an error message showed up. Hope this is helpful.

Hoping that somebody can shed some light for me on this. I’ve gone through the GitHub installation method and got to the point of installing the app on my iPhone. I can authorize it in ecobee just fine (can see it in My Apps), and when I click Done the first time, I do see the “Ecobee Suite Manager is now installed and automating” message - which is immediately followed by this message:

I’ve removed everything from IDE and my ST app and gone through the process twice now to no avail. Any ideas? I haven’t skipped a single step (including OAuth).

Please see the first item in the FAQ (you need to manually remove the temporary devices).

Please see the first item in the FAQ (you need to manually remove the temporary devices).

That’s what I get for doing this at 6am before coffee. That was it - thanks!

1 Like

Please get the 1.8.19 version of Ecobee Suite Routines and let me know if that fixes it…

Barry - Awesome! It seems to work. I will continue testing and will let you know if anything comes up. Thank you so much for your great work.

Hi, Barry,

While testing the mode/routine helper for other scenarios, I came across a couple of cases that still generate an error. If “Switches On/Off” is selected as a trigger, the app successfully finishes the action including turning on/off a virtual switch as an action. However, if “Ecobee Program Change” is selected as a trigger, an error is generated when trying to turn on/off a virtual switch as an action. See the following live log.


[f41dc272-6a45-4a52-ba7a-455717f2c0c6] 6:24:11 PM: error groovy.lang.MissingMethodException: No signature of method: script_app_8d0272203f60ce3779a9e7e4fc9c4468a8e7a5d0c00de9bc624713f09fafdea5.runin() is applicable for argument types: (java.lang.Integer, java.lang.String, java.util.LinkedHashMap) values: [15, changeSwitches, [overwrite:true]]
Possible solutions: run(), run(), runIn(java.lang.Object, java.lang.Object), runIn(java.lang.Object, java.lang.Object, java.util.Map), url(), find() @line 576 (changeSTHandler)

[f41dc272-6a45-4a52-ba7a-455717f2c0c6] 6:24:11 PM: trace Notification Message (notify=false): Changing Mode to Work Home because EcobeeTherm: Home changed to Work Home

[f41dc272-6a45-4a52-ba7a-455717f2c0c6] 6:24:10 PM: info Changing Mode to Work Home because EcobeeTherm: Home changed to Work Home

[f41dc272-6a45-4a52-ba7a-455717f2c0c6] 6:24:10 PM: trace changeSTHandler() - entered with evt: currentProgram: Work Home


I suspect the mode/routing app still has an issue when executing “switch on/off” as an action when trigger is Ecobee Program Change. (And possibly other triggers such as Location Mode Change although I haven’t tested it.)

Thank you for your attention to this.

Fixed in Ecobee Suite Routines, v1.8.20

Ecobee Suite Routines updated 1 July 2020 at 7:00am EDT

Fixes issues with turning on/off switches

Has anyone else noticed a problem with Smart Circulation Helper since the last firmware push? The IDE log looks like everything is fine so I’m suspecting a problem with the ecobee firmware. What I’m seeing is that when the ecobee is placed into hold it is ignoring any changes in the fan runtime. For example, if the fan is at 55 min/hr when the hold happens it is staying at 55 until the hold is lifted. When I look at the log I can see the fan times reduce as expected until it reaches 5 min/hr. However, the fan continues to run at 55 min/hr even though both the ST and ecobee aps both show it should be 5 min/hr.

Please report this to Ecobee support - perhaps if they see it coming from multiple people they will actually look into it (you are the 2nd or 3rd person to mention it).