[RELEASE] Universal Ecobee Suite, version 1.7.**

@storageanarchy very nice work. I love the update.

About ‘Working From Home Helper’ would it be possible to override the thermostat’s Program/Climate/Schedule changes by looking at the ST Mode? For exemple, if I’m working from home ST Mode would be set to ‘Home-Day’. I would like the Ecobee program to not change to ‘Away’ as programmed in ecobee schedule.

Doesn’t the WFH Helper do exactly what you want?

Just set the “check time” to a few minutes after the scheduled program change.

Or are you asking for something different than what WFH does currently?

maybe I’m not using it properly… Right now the helper logic looks like this:

WHEN (Condition) the thermostat changes to ‘Away’ AND Presence_sensor is present
SET (Action) thermostat to ‘Home’.

It would be nice if that helper could be more generic. Like this:

WHEN (Condition) the thermostat changes to ‘Away’ AND Smartthings_Mode is HOME (selectable list of smartthings mode)
SET (Action) thermostat to ‘Home’ (selectable list of ecobee mode).

My goal is to prevent an ecobee mode changes when smartthings mode is in a certain mode. Right now the only conditions WFH permits is Presence Sensor and Time.

Sounds more like a job for the Mode/Routine/Switches/Programs Helper…have you tried using that instead?

I don’t think the Mode/Routine/Switches/Programs Helper is working the way I’m looking for. The only actions possibles in that helper are Change location Mode or Execute a routine. Realy, what I’m trying to do is very close to WFH Helper is doing but using it more flexibly.

I don’t want to change Location Mode when ecobee change its program. I’m looking to switch back Ecobee mode to ‘home’ when location mode is ‘home’. Right now WFH Helper doesn’t allow me to look for Location Mode in the condition section. That would be very helpful if it does.

Also, in the action section of WFH Helper would be nice to have the Thermostat Program being selectable instead of having it fixed to ‘Home’ like it is coded right now. The same thing for the trigger section, make Ecobee mode selectable instead of being fixed to ‘Away’. That way, that helper would be more generic and could be used also in a situation where I’m still awake, ecobee goes to sleep and want to have Ecobee go back to ‘Home’.

Is this making sense?

Thanks for all your hard work on this!

I just had a zoning system installed in my home:

  • Single furnace/AC
  • 1st Ecobee for the top floor controlling a damper for the upstairs vents
  • 2nd Ecobee Thermostat for the main floor controlling a damper for the main floor vents

I’m looking to set up some rules such that if neither Ecobee needs heat or AC that they both have the fan on. As soon as either Ecobee flips to Heat/Cool mode, both change fan to Auto to optimize for the dampeners. When both Ecobee’s are idle, turn both fans back on.

The Smart Zones app you made is close, but instead of a Master / Slave, I think I’d need peers that can both trigger the change. Does this make sense? Perhaps with a small mod to the Zones app?

Thanks!

IIRC, I think I created the SZ helper such that you can create 2 instances, one for each “master” zone. Set them both to share the fan only; SZ monitors the Operating State of the master and changes the slave fan between on/auto based on the master’s changes to operating state.

Let me know if that doesn’t work.

I’ll give it a try - didn’t know if they’d be fighting with each other at that point.

Thanks!

Hi @storageanarchy - I’m noticing odd behavior where my thermostat shows shifting the temp to Sleep mode but continues cooling as if still in Home mode, without logging the cooling to HomeIQ. I’m using the Modes helper to sync it to ST. It seems like an ecobee issue but I thought I’d check here first just in case.

I guess I don’t understand - the screen shot shows the target temp being increased (the blue line) and no cooling thereafter (the blue bars at the top). Seems to me it is doing what you want?

No cooling is shown but the system is still cooling - see the interior temp staying flat, then briefly increasing then coming back down? That’s why I assume it’s on the Ecobee side, but I figured I should consider the possibility that you’ve implemented a stealth cooling mode :rofl:

Edited to add: I think what I saw this morning that concerned me was probably pre-cooling for the scheduled morning change; it probably makes sense that the temp would hold steady with minimal heat generation in the house and falling temperatures outside, it’s just the blip that seems odd to me; at the scale of that graph it could just be a sensor reading that’s right on the edge of the higher value and reads as fluctuating…

Nothing I do could cause the “blip” to occur - and theoretically the Ecobee could not have run cooling without showing that on the screen (note that you can “zoom” on that screen to see more detail/bigger bars). Even when pre-cooling, you will see the cooling bar indicate that it was calling for cool.

If your HVAC runs without the thermostat calling for heat/cool, then you probably should discuss with Ecobee.

BTW - do you have a 2-zone system with a single air handler? If so, could it be that the other zone was calling for cool? The methods of balancing airflow with a single air handler and 2 zones includes “bleeding” some of one zones’ airflow into the other zone…

Ecobee Suite updates posted on 17 September 2019 at 3:40pm ADT

Updated:

  • Ecobee Suite Working From Home, version 1.7.11
    • Both the Trigger (“Away”) thermostat program, and the Action “Home” thermostat program can be selected/specified. This allows WFH to be used (for example) to manage overriding the “Sleep” program.

The trigger is still based off of Presence. For those that use other means to control the Location Mode (e.g., lock codes or service buttons), you will need to create a Virtual Presence sensor that is activated when your location changes to “Home” (or “Night” or whatever you choose), and then use this sensor as the trigger for WFH.

Is anyone else having issues with thermostats inconsistently not changing programs? (E.g. sometimes it does, sometimes not) I’m using webcore and the latest ecobee suite manager custom device handler to try to change thermostat programs based on contact sensor states. My webcore logs say I’m sending ecobee the change program. Sometimes it’s fine other times it’s like ecobee didn’t respond, I still find them in last state.

Best bet is to turn on Live Logging at debug level 4 to see what is going on with the thermostat device and ES manager.

You might want to use the Helpers instead of WebCoRE.

I have a few webcore pistons that change the program based on motion, switches being activated, or modes and all have been working consistently for several weeks now.

Thanks for the logging tip. Ive enabled that and will watch.

Yes, for the last two days, it’s not switching when my morning routine runs. I look in the history and it always says API not fully connected. The other routines it works just fine.

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.