[RELEASE] Universal Ecobee Suite, version 1.7.**

I just posted about the same Smart Helper App so, it has a couple issues with it :slight_smile:

Jordan -

The method currentValue() is a built-in and is supported for ALL devices, so this error is a red herring. Possibly something else is wrong, but I can’t reproduce it. Perhaps you can try simply opening this Helper instance, verifying all the selections, and then saving it again…

Tony -

Fix will be posted momentarily…

Updates posted for the Entire Ecobee Suite

These updates implement fixes, enhancements and new features:

  • Ecobee Suite Thermostat, version 1.7.25
    • More fanMinOnTime cleanup
    • Argument typing & hinting (Hubitat only)
  • Ecobee Suite Sensor, version 1.7.07
    • NEW! add or delete sensor from ANY Named Program/Schedule/Climate
      (with argument typing & hinting on Hubitat only)
      • <device>.addSensorToProgram( programName )
      • <device>.deleteSensorFromProgram( programName )
  • All Ecobee Suite Helper Applications
    • New option to disable logging of ‘debug’ messages to the local device (logging is still sent to Ecobee Suite Manager, where the logLevel setting controls what is displayed)
    • For those Helpers that send Notifications, added support for Notification devices on SmartThings
      • Enables mixed hub environments using Hubitat HubConnect to utilize the Hubitat Mobile App for individually targeted notifications
  • Ecobee Suite Manager, version 1.7.33
    • Fixed null values during Hubitat Hub reboot recovery
    • Optimized LOG() handling, fanMode/fanMinOnTime tweaks
    • Now sends host thermostat’s programsList to sensors, to support add/deleteSensorFromProgram
  • Ecobee Suite Open Contacts, version 1.7.32
  • Ecobee Suite Quiet Time, version 1.7.05
  • Ecobee Suite Routines, version1.7.16
  • Ecobee Suite Smart Circulation, version 1.7.12
  • Ecobee Suite Smart Mode, version 1.7.19
    • Fixed appLabel error during installation
  • Ecobee Suite Smart Room, version 1.7.06
  • Ecobee Suite Smart Switches, version 1.7.05
  • Ecobee Suite Smart Vents, version 1.7.10
  • Ecobee Suite Smart Zones, version 1.7.05
  • Ecobee Suite Thermal Comfort, version 1.7.15
  • Ecobee Suite Working From Home, version 1.7.10

These updates are highly recommended for ALL users

2 Likes

You nailed it, Barry. Deleting and setting up a new helper solved it.

1 Like

Do you have any idea what is going on with webCoRE? I have at least 3 pistons that are not firing right. It worked fine for a year but now, useless.

I love waking up to 76 degrees but it is hell on the electric bill on Phoenix :slight_smile:

The mode changes from “sleeping” to “home” and it doesn’t have any effect.

I am certainly not blaming you, I was hoping that you have a better idea before I head over to the forums there.

What types of things are not working? I ask because I have had some issues myself. Anything that I try to start at a specific time never works. Daily at type things. If I look at the logs it says the item is not true but it is usually a couple of minutes after it is supposed to fire. I think the inherent delay from the cloud is causing this, not sure though. I have changed them to a window of 5 or 10 minutes and then if it fires I have a wait to hold it until after the time window is up. This seems to be working for me.

Another thing I have trouble with is reading the name of the program from the Ecobee. There are three variations of current program name I have tried, I can’t remember the exact syntax at the moment. These seem to work at times and not at others. I think it has to do with whether it is in hold or not and I can’t seem to really get it to work right. I just gave up using those and just set a schedule and then used location mode to change the mode and resume program to set it back.

If you don’t mind, I will take this conversation private. Especially because there is no fault in this development. It happens on zigbee and z-wave and, the scheduling of it using. webCoRE

My Heat Differential and Cool Differential are reading as --17.5C and ±17.5C respectively on the EcobeeTherm device, which is throwing off calculations in the Smart Vent helper. I understand from the documentation that these is a read-only setting getting pulled from the actual thermostat. Any idea how I change these values to zero?

Yes - go to the thermostat and change them - they are under settings/thresholds I think.

You can’t set them to 0 though (and you wouldn’t want to if you could), I think for C you can set them to 0.3C

Thanks. I’m still getting -17.5C returned when the setting is 0.3C on the thermostat. Increasing the thermostat differential to 0.6 changes the value to -17.22, and 0.9 to -16.91.

So, we’re definitely connected and getting updated events when the differential is changed, but for some reason the value being reported from the ecobee API seems offset by 17.8C.

The impact is that my temperature readings are getting adjusted down 17.5C (when the differential is at 0.3C) and showing 3-5C instead of 20-22C in the helper apps.

Has anyone seen this before? I’m about to give up and hard code in an offsetting offset, but would rather not.

The heating/cooling differential has no impact whatsoever in the room temperature that is displayed in the thermostat device, and I am pretty sure that it never appears in any of the Helper apps.

The differential controls only when the thermostat calls for heat/cool: if you set the cooling differential to 0.3C and your thermostat settings is 21C, then the thermostat will request cooling when the observed temperature is higher than 21.3C, and it will stop calling for cool once the temperature gets down to 21C again.

Perhaps you have been changing the temperature correction on the thermostat instead of the heating and cooling differentials (there are two of them)? That’s the only way you will be seeing such a big difference from the real temperature…

I’m not sure if I’m missing something, but I can’t seem to get the contact sensor portion to clear. If the sensors I’ve configured are opened the ecobee turns off, but after all the sensors are closed again for the time determined it does not resume it’s previous settings.

Have you perchance looked at the live logging for the Helper, Thermostat and ES Manager when it doesn’t work? I myself use this Helper extensively, and it has been working fine for me.

Note that when you set up the Helper, it needs to be while all the contacts are in the “on” state, and your HVAC also needs to be “on” (auto, cool or heat). Otherwise it doesn’t capture the states correctly - that might be what you are seeing. Check the Live Logging for the Helper while you configure it - it shows an error if anything isn’t closed/off properly…

Thanks I will take a look. The notification I get is from the program helper when it compares to the outside temperature and tries to turn on the thermostat. It says that the contacts helper holds a modeoff.

Opening and re-saving the helper (when everything is in the “On” state) will clear the reservation…

Closed contacts would equal on state right

Depends on your configuration, but generally yes.

Anyone having issues with thermostats showing as “unavailable” in smart things? I added 3 ecobee’s under this ecobee suite manager version 1.7.29. All 3 add OK. However after a short duration (a few hours?) one of the 3 persistently shows as “unavailable”. The only solution i’ve found is to remove/re-add it.

I can confirm its not a local issue - the device is online/OK in the ecobee vendor app even while “unavailable” in smart things. While unavailable i’m also seeing things under “recently” in smartthings like temps, pressure, humidity, etc.

Any idea what i’m doing wrong?

Pay no attention to that status WRT Ecobee Suite.

The solution is to turn off Health Check. Or just ignore that status - it doesn’t mean anything.

1 Like

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.