[RELEASE] Universal Ecobee Suite, version 1.7.**

Ah Thanks! I learned something new today. I was using the My SmartApps link along the top. Never saw (never paid attention to) the link to the right on my Locations. I’ll keep an eye out for my issue with Reservations now…

1 Like

One more issue that I have found.

I am trying to use the Contacts and Switches to turn my Ecobee off when a door is opened.

When I save, I get these errors

24215814-aff1-4d15-8fed-783d4c2f251c 12:57:53 PM: error java.lang.NullPointerException: Cannot set property ‘mode’ on null object @line 342 (doCall)

d5a63432-25c8-4cf6-9a4a-831c44770b42 12:57:53 PM: warn Contacts & Switches Initialized while should be ‘Off’ - can’t update states

24215814-aff1-4d15-8fed-783d4c2f251c 12:57:53 PM: warn Initialized while should be ‘Off’ - can’t update states

24215814-aff1-4d15-8fed-783d4c2f251c 12:57:53 PM: info switchOffState = false

24215814-aff1-4d15-8fed-783d4c2f251c 12:57:53 PM: info contactOffState = true

24215814-aff1-4d15-8fed-783d4c2f251c 12:57:53 PM: info Ecobee Suite Contacts & Switches Helper, version 1.7.29 on SmartThings - Initializing…

24215814-aff1-4d15-8fed-783d4c2f251c 12:57:53 PM: trace Installed with settings [contactOpen:true, quietTime:false, contactSensors:[Basement Windows, Main Floor Windows, Front & Garage Door, Patio Door, Second Floor Windows], whichAction:Notify Only, tempDisable:false, offDelay:5, pushNotify:true, hvacOff:true, theThermostats:[EcobeeTherm: Main Floor], onDelay:5, speak:false]

24215814-aff1-4d15-8fed-783d4c2f251c 12:57:36 PM: error java.lang.NullPointerException: Cannot set property ‘mode’ on null object @line 342 (doCall)

d5a63432-25c8-4cf6-9a4a-831c44770b42 12:57:36 PM: warn Contacts & Switches Initialized while should be ‘Off’ - can’t update states

24215814-aff1-4d15-8fed-783d4c2f251c 12:57:36 PM: warn Initialized while should be ‘Off’ - can’t update states

Would something like this work?

No one home for 15 minutes, set to away, unless it is set to Sleep, then as long as it was set to Away and sees motion, return to home

Yes, unfortunately, you cannot configure Contact & Switches while any of the sensors are in the state that the thermostat should be set to Mode = Off. You have to have everything in the state that the Mode should NOT be Off, then configure the Helper, and everything should work…

@storageanarchy I thought I updated all the code, but for some reason the DHT code wasn’t being updated even though I updated the main app. Thanks for pointing me in the right direction. All is well now!

1 Like

Loving the Ecobee Suite so far, but I’ve run into an issue with Holds. I’ve got my Thermostat setting set to “Until the next scheduled activity”. I’ve also got the Ecobee Suite global setting for Select Hold Type set to “Until Next Program”. However whenever I change modes in ST, for example from Away to Home, it seems to set an indefinite hold. I check the Ecobee app and it’s showing “Home and Holding”. Is that expected? I would have assumed it would say “Home until 8PM” or whatever the next scheduled change is. It seems like Ecobee is setting all holds to indefinite no matter what.

Nobody has reported an issue with holds before.

You sure that the Ecobee App just says “holding.” What does it show on the Ecobee Suite thermostat device display in SmartThings? What about on the thermostat itself? And the Ecobee web app?

Within a few minutes of the hold being set, all four should reflect the same hold end time. If not, we need to check what hold is being requested by ES: get into LIve Logging before the event change should happen, and the afterwards look at the log for the timeframe for:

  1. the Helper app that should be making the request
  2. the ES thermostat device
  3. ES manager

You should be able to find the log entries when the request was made showing the type of hold requested and the returned response.

Let me know what you see in the logs; hopefully this will give us a clue as to what is happening.

My apologies! I dug a bit deeper and now that you mention it, I think it’s an issue with the UI in the Ecobee iOS app.

As you can see in this screenshot, it’s showing an indefinite hold. However, here’s the web app and the ST app.

40

So nevermind! Thanks!

1 Like

OMG, I had been looking for some way to turn my a/c off when the sliding door was open since I always forget. So after a google search led me to this post then reading and following your instructions I installed Ecobee Suite with contacts helper and boom just want I needed. if the door is open more than a min the mode changes from auto to off.
Thank you so much for this!!

2 Likes

so today it stopped working and threw this error

also will whatever I set it to on the device (off/auto) override the helper request? If i have set it off the helper will not change it to auto?

Eric -

Sorry for the delayed response - was pretty much off-the-grid for the last week…

That error pops up occaisionally on SmartThings, generally with no apparent cause. Is it ALWAYS throwing that error for you, or did it happen only once or twice?

I’ve seemed to hit a similar issue to what millsjq hit back in Jun. I get to step 10 in the “Finalizing Installation on SmartThings Mobile” of the readme, but re-opening the suite doesn’t continue the process. I have tried deleting the test devices as instructed, but the installation does not continue. Once the devices are deleted, the Ecobee Suite Manager no longer shows in the Automation tab.

Ecobee Suite updates posted on 22 August 2019 at 7:05am EDT

  • Ecobee Suite Open Contacts, version 1.7.30
    • Fixed typo in tmpThermSave(d)State

This fix is highly recommended for all users of ES Open Contacts

1 Like

Jonathan -

I"m not sure what’s going on with your installation - deleting the test devices shouldn’t also delete the ES Manager SmartApp.

As I haven’t heard any other such reports lately, you might want to start over from scratch, deleting ALL the ES SmartApps and DTHs and then re-installing.

I can remove the devices which also deletes the ES Manager SmartApp, however from there the installation doesn’t continue. Am I missing something? it doesnt seem to find the ecobee

Jonathan -

Like I said, removing the temporary devices should not delete ES Manager - I can only guess that something isn’t installed correctly…

Some things to check:

  • Be sure that you are using the SmartThings Classic mobile app - you can’t do the installation with the “new” mobile app
  • Be sure that you have installed all 14 files: 2 device handlers (thermostat & sensor), plus the 12 SmartApps - you need them all installed, even if you aren’t going to use them all
  • The first time you run Ecobee Suite Manager should be from the Marketplace/SmartApps/MyApps
  • After completing the initial login to Ecobee, exit from ES Manager. Then go to the Applications tab in the (old, classic) mobile app, and find the installed instance of Ecobee Suite Manager. Run that, and it should now allow you to select thermostats and sensors you want to use…

It might help to run Live Logging from the IDE while you attempt the installation - that way you can look for errors that may have been logged in the process…

Managed to finally get it working. Had to go through the steps really fast after removing the temp devices.

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.