[RELEASE] Universal Ecobee Suite, version 1.7.**

Ecobee Suite Updates posted on 2 August 2019 at 11:10am EDT

Two fixes posted:

  • Ecobee Suite Smart Mode, version 1.7.17
    • On SmartThings only, wasn’t properly updating the appLabel (wasn’t clearing old context when it wasn’t (paused)
  • Ecobee Suite Thermal Comfort, version 1.7.14
    • Wasn’t displaying Notifications options for new or existing instances

These fixes are highly recommended for all users of these two Helpers

I had mine set to change based on Mode. When the thermostat failed to change to the sleeping comfort setting the other night, I was able to trigger it manually from the device screen in SmartThings. I subsequently changed the app so that it changes based on Routine instead of Mode and that seems to have resolved whatever the problem was. Both times I’ve had issues, I’ve made sure the app and handler were updated to the latest version. If it fails again, I’ll note the time and get all of the other information.

This morning, I noticed my virtual thermostat shows as “Unavailable” in the SmartThings app. Suspecting that Ecobee was having server problems again, I logged into their app and everything is operating ok, in fact the thermostat’s status is ok in the SmartThings app as well. So I went on over to the IDE and clicked on the virtual thermostat and it shows Status: HUB_DISCONNECTED. All other devices on my hub are operating fine.

It’s a bug in SmartThings. Either turn off SmartThings Health Check, or ignore the error for your Ecobee devices…if they are working, the hub isn’t disconnected.

Thanks again, Barry. As usual, you have the answer. I wanted to rule that status question out before asking for clarification on another thing I see frequently. When my contacts and Switches tries to turn HVAC back on when all are closed, I frequently see “reservations prevent running HVAC On actions” in my notification but I can’t figure out where that reservation is coming from. Frequently, the HVAC stays in the Off state, which is incorrect. How would I best tell where the state reservation is coming from? Is it possible to provide that information in the Notification?

I can look into doing that, but I probably can’t get to it soon.

You can see the reservations if you look at the atomicState variables for Ecobee Suite Manager: in the IDE, go to “My Locations” at the top, then click on “smartapps”. Scroll down to ES Manager, then right-click to open the status page in another tab or window. You should see the list in “reservations” under “State”.

Let me know what you find - there may be a bug in one of the Helpers that isn’t releasing the reservations correctly…

Barry,
I have a webcore piston that I have that I can manually turn on to trigger 2 of my thermostats to circulate air for a particular set of time. I am getting this error in smartthings trying to execute it.
groovy.lang.MissingPropertyException: No such property: currrentThermostatHold for class: script_dth_1898af2936d2cab2f7c890508bd54937c0d3740268bc742cc223dddce4d007d7 @line 2720 (setThermostatFanMode)

Any ideas what it could be?

Ilya -

What versions of Ecobee Suite Manager and Ecobee Suite Thermostat are you running?

The error indicates an improper reference to currentThermostatHold at line 2720, but the first use of that variable is at line 2774, so I suspect you are running older code. Could you please try with the latest releases of everything and see if the problem is still there?

I thought that might be it as well and I took the latest update. 1.7.29 but am still getting the error. I am not sure if there is a way to clear cache, or something else… I can’t even run it directly from the Smartthings Ecobee Suite app directly. Getting the same error. So at least that eliminates webcore as the culprit.

So, what is the line number of the Error occurrence with the latest code?

And when you say “I can’t even run it from the SmartThings Ecobee Suite app directly”, what exactly are you trying to run?

Error from Smartthings:
groovy.lang.MissingPropertyException: No such property: currrentThermostatHold for class: script_dth_1898af2936d2cab2f7c890508bd54937c0d3740268bc742cc223dddce4d007d7 @line 2720 (setThermostatFanMode)

I am just trying to turn the fan to On and thats when it’s throwing that error.

That error is still for a prior version of my code - because the line number is the same as before…

Are you sure that you installed the code to your proper IDE account on SmartThings, then saved the code, and then published the code?

I’ll certainly look into that next time I see the issue, but can you clarify for me exactly what to right-click on? I couldn’t find a “status” anywhere I looked in the IDE for the smartapp.

Right-click on the link named “Ecobee Suite Manager”…

I have just made the switch from Nest to Ecobee as my Gen1 was causing an issue and have tried the Ecobee Suite Manager.

I am just getting started with it, of course. My one question. My motion sensors are linked to SmartThings.

How can I expose them to the Ecobee for auto-away. I cannot seem to find that option.

Thank you

While Barry may have a method to include those for auto-away in the Ecobee suite… Most users find it easier to trigger the away mode based on the mode change of ST. For me… when all cell phones leave our house, it triggers an ST routine that shuts down the house and changes ST to away mode. When ST shifts into away mode, the mode helper in the Ecobee suite kicks the thermostat to away. Just food for thought! :wink:

1 Like

Fair enough

I don’t see an away more though from the Ecobee suite exposed to WebCore.

Generally, I don’t worry about the whole house in away mode, more just the Ecobee. I can set it to auto/heat/cool but not change comfort to away for some reason

Ecobee Suite does expose away(), home(), night()/asleep() commands. Not sure why you don’t see them from WebCoRE, but they are all implemented. You could also just call setSchedule(“Away”) or (more properly) setThermostatProgram(“Away”).

1 Like

I must be doing something wrong. When I right click on the link and open in a new tab, it shows me the smartapp code, and there is a link to show “logs”. But no “status” page or anything displaying “state”.

From the below screen, click “smartapps” for your location (I have 3):

From this screen, scroll down and right-click on the link “Ecobee Suite Manager”:

that will bring up the SmartApp state page…

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.