SmartThings Community

[RELEASE] Trend Setter

@Kriskit

This is a great tool. thanks for all the work.

I am just having one problem. I am not sure if this problem is strictly related to your app or if it is more systemic in my whole ST setup. I will explain. First the symptoms:

  1. My group is intended to turn off all the front room lights and ceiling fans in the Living Room, Dining room, Kitchen, and Foyer. These are mostly controlled by GE/Jasco z-wave dimmer switches and Fan Control switches, though some of these lights are Philips Hue lights too. There is a significant number of these in the group, 8 Hue bulbs and 11 Switches and Dimmers to be exact. I understand there will always be delays between start and finish of a turn off event with this number but that is fine. Also it might be relevant to note that all of these switches are being controlled by community based DTHs not the ST standard ones.

  2. As i said, it is rare when all of these lights are on at the same time. Thus, usually when I go to turn off the lights your virtual switch is the Onish or MostlyOn state. When I hit the On/Off Icon to turn it off (or when I hit the OFF button at the bottom) the process begins to turn off lights and the percentage counter starts to decrement.

  3. Now for the problem. After hitting OFF in either method, all the lights do indeed go off after the first press. The percentage counter does decrement but only to a point. Then it stops at some number in the 30-50% range and the icon reflects mostly off, Half, or offish even though all the lights have gone off. If i hit the icon again or the off button again it will most times then decrement the percentage further. Most times the second press will result in getting the percentage to 0% and setting the icon and tile to Off. The same thing happens when turning on. the first press does indeed turn on all the lights, but the percentage counter and icon tile reflect ONISH or MostlyOn. A second press gets it all the way there most of the time.

So it seems like there is a timer or certain number of status indicator checks which times out before the process is complete resulting in the incorrect percentage being displayed and the incorrect status being shown. I have looked through the Device handler and can’t see any place where you are specifying a time or number of iterations so I don’t know if this is a DTh issue, a SmartApp issue, or a Smartthings settings issue. It could be a smartthings issue because i see similar behavior in single device device handlers from other developers which dim a switch. The dim level doesn’t ever get to 0 after the first press even after the light has been dimmed to Off.

Any ideas?

LJ

just checking back does anyone have any ideas or @Kriskit?

LJ

Hi,

Have you updated to the latest version?

I am not sure if this might be related to the timer issue from earlier where ST have made the runIn command have a hard minimum time. If so, then the newest version may help.

@Kriskit

Thanks for the reply and sorry for the late response. i was out of town on business. To you question on versions, I am updating from the github repo automatically via the IDE. I even went out to the github repository to verify if I have the latest version. I do, unless there is another repository with a later version. The Smart app shows as version 0.1 and the group shows as 0.2. The device handlers are up to date.

Any other ideas?

LJ

@LJ_inFLA

There have been two githubs over time, though the switch was a long time ago. You should be using the trendsetter app from

(which I don’t see a version on)

and the group app from

which is showing as version 1.2.2
def version() {
return “1.2.2”

(The group was updated 23 days ago).

Worth a check!

Also - my largest group is 16 or so devices, (zigbee downlights) and, although improved w/ newest version, it still takes a while even though I have a strong mesh (maybe 5-10 seconds total). I have (very occasionally) had it “loose sync” with the ‘onish’ ‘offish’ symptoms you’re showing. I’m wondering if it would work better for you if you split out the group into at least two? Might be worth a try.
Alec

Thanks for the reply. I checked your versions against mine and I am current. I am starting to think that i have too many lights in the group. I may have to take your suggestion and split it up a but more. I really just wanted one button and status to turn off everything other than the bedrooms when going to bed. But since this is the best solution I may have to work within the limitations for now.

No idea if this would work, but you could try maybe a device that’s made up of those two groups? (have never tried it myself, though and don’t know if it’s “approved”). Might be worth a try.

I’ve done a stupid thing: I published the group app and added a switch group using the group app. I think this is what caused me to be unable to remove the Group I created (there is no “Remove” option in the Group.) Neither can I remove the Group app to start from scratch, because there is a Switch Group (which I can’t delete.)
Any suggestions how to overcome this check mate situation?
Thank you.

@949BFN

Tricky! I just recreated and you’re right - not obvious how to remove it.

This worked for me:

First - when you created the group you probably created a device associated with this group, delete it under ‘Things’ on your smartphone app then do below to remove the ‘fake app’ in the IDE.

  • Log in to SmartThings IDE (https://graph.api.smartthings.com/)
  • Go to ‘My Locations’
  • Click on ‘smartapps’ under “Installed Smart Apps” for your location
  • You should get your location with a long list of installed smart apps
  • Click on ‘EDIT’
  • Find the Group Smart App you created by mistake (NOT the main Group!)
  • Click on ‘Uninstall’

Good luck!

1 Like

Best to point users to https://account.smartthings.com and not the graph.api link

@jkp - got it! (could you remind me what the difference is? )

In the case you used it above, it makes no difference. But in other situations, if users go to that link then they will most likely be on the wrong shard and will experience issues.

2 Likes

Thank you Alex, that worked!
Do you know of a way to “unpublish” an app? Or is the only way to remove and add it again?

I discovered a further issue. I have 2 hubs at different locations. The above issue I had at my holiday home. I have since realized that the Switches and groups I created a very long time ago, have all disappeared from the Smartapps section (in the Classic phone app) at my home location. The switches are still available as Things in the phone app, and webCore is still able to control them. Since they no longer exist as Smartapps, I’m unable to add any switches or lights. And I’m afraid if I recreate them, it will destroy the existing things, which will be a major hassle as far as webCore is concerned (because of the number of pistons and Trendsetter groups involved)

I’ve never figured out how to ‘unpublish’ besides what you suggested. (Delete and readd).

Glad it worked!

1 Like