[RELEASE] Trend Setter

No idea if this would work, but you could try maybe a device that’s made up of those two groups? (have never tried it myself, though and don’t know if it’s “approved”). Might be worth a try.

I’ve done a stupid thing: I published the group app and added a switch group using the group app. I think this is what caused me to be unable to remove the Group I created (there is no “Remove” option in the Group.) Neither can I remove the Group app to start from scratch, because there is a Switch Group (which I can’t delete.)
Any suggestions how to overcome this check mate situation?
Thank you.

@949BFN

Tricky! I just recreated and you’re right - not obvious how to remove it.

This worked for me:

First - when you created the group you probably created a device associated with this group, delete it under ‘Things’ on your smartphone app then do below to remove the ‘fake app’ in the IDE.

  • Log in to SmartThings IDE (https://graph.api.smartthings.com/)
  • Go to ‘My Locations’
  • Click on ‘smartapps’ under “Installed Smart Apps” for your location
  • You should get your location with a long list of installed smart apps
  • Click on ‘EDIT’
  • Find the Group Smart App you created by mistake (NOT the main Group!)
  • Click on ‘Uninstall’

Good luck!

1 Like

Best to point users to https://account.smartthings.com and not the graph.api link

@jkp - got it! (could you remind me what the difference is? )

In the case you used it above, it makes no difference. But in other situations, if users go to that link then they will most likely be on the wrong shard and will experience issues.

2 Likes

Thank you Alex, that worked!
Do you know of a way to “unpublish” an app? Or is the only way to remove and add it again?

I discovered a further issue. I have 2 hubs at different locations. The above issue I had at my holiday home. I have since realized that the Switches and groups I created a very long time ago, have all disappeared from the Smartapps section (in the Classic phone app) at my home location. The switches are still available as Things in the phone app, and webCore is still able to control them. Since they no longer exist as Smartapps, I’m unable to add any switches or lights. And I’m afraid if I recreate them, it will destroy the existing things, which will be a major hassle as far as webCore is concerned (because of the number of pistons and Trendsetter groups involved)

I’ve never figured out how to ‘unpublish’ besides what you suggested. (Delete and readd).

Glad it worked!

1 Like

@Kriskit, Have you or anybody attempted to port this to Hubitat or approached you about trying to do it? I am not sure I have the skills to do it myself.

LJ

@Kriskit I’d mentioned this before about my Trend Setter power monitoring devices not showing any information and wanted to follow up and show you the logs. Not sure why but there’s two entries for each device group I’ve tried creating, but one shows errors and the other one doesn’t. Any ideas?

TREND%20POWER%201

TREND%20POWER%202

TREND%20POWER%203

I am trying to remove a bunch of groups I built in Trendsetter after migrating those devices to another platform. I can’t seem to remove them without getting an error. I have even tried to remove trendsetter with the intention of reinstalling later but trying to delete the main or the child app results in errors both in the Smartthings app and in the IDE. How can get this thing removed and start over?

LJ

@LJ_inFLA

Have you tried via ‘Hub’ in the IDE?

My Hubs --> Location --> List Smart Apps (down at bottom) --> Click on Edit (right under your location name–> Go to Trend Setter (which has ‘Group’ and whatever groups you created listed under it --> Click on ‘Uninstall’ for each group you want to get rid of.

Note - I’d delete everything you wanted to before deleting the ‘Group’ group - which I think is kind of a default.

Hope this helps! (I think this is what I did a year or so ago when I wanted a fresh install)

Thanks for this. I did not think to go there, but still no luck there. I throws an error there too.

LJ

@LJ_inFLA - when you try to uninstall any group? What error?

Never mind, I discovered that some of these groups were still attached to ActionTiles and Logitech Harmony (Connect). Once I cleared those connection the Trendsetter groups deleted fine. Thanks for pointing me in the right direction to lead me there.

LJ

1 Like

Just installed everything via GitHub (what a cool thing that is!!) and I created my first group using 3 of Philips’ new WiFi Connected by Wiz lights, and when I use the group switch there’s like a 1/2 sec delay between each bulb turning on. Doesn’t seem to be much faster than just hitting a virtual switch to control them. How do we get it as fast as the native “Lighting Groups”? When I click on those they all turn on and off perfectly synced every time. But it doesn’t seem to let you use those in automations??!! :rage::rage: Totally new to all of this so maybe I’m missing something?

I haven’t kept up with the updates and just reinstalled everything as my setup stopped working recently. My problem is that my virtual dimmers are not dimming my group of lights. three bulbs paired with one virtual dimmer. The lights turn off and on fine with the virtual but when I dim the virtual nothing happens. Am I missing something?

Same problem happens to me since last night. I’m wondering if it’s not a global ST issues since Dim With Me smartapp has the same issue: turn on/off fine, but won’t dim

do you get this error in your dimmer group log:
java.lang.NullPointerException: Cannot get property ‘value’ on null object @line 190 (setLevel)

If yes , try commenting the line 190 of the dimmer group device handler:
//sendEvent(name: “switch.setLevel”, value: val, rate: 0, isStateChange: true)

it worked for me.

1 Like

Sorry I’m pretty new to this. How do I check the dimmer group logs?