[RELEASE] Thermostat Manager - An alternative to Thermostat Mode Director

This won’t help you with your automation but could help you achieve your goals. You might look into using a different thermostat. With my ecobee I can set it so that any temp change will only be effective for up to 2 hours or until the next time the thermostat is set to transition to a different schedule. You can also program the min/max temp that the thermostat can be set to. With my model I think you can even set a temperature offset so it will show a temperature higher or lower than what it actually is.

Update: I’ve redesigned Smart Home Monitor setPoint Enforcement into a mode based setPoint enforcement. Currently in the testing phase.

@Roderic100, I’ve been thinking about the change you asked for, and it seems like a bad idea to me to be switching modes on the thermostat that often. How about an alternative?: Say you could set maximum and minimum temperature values for particular modes and if the user sets the thermostat above/below a max/min temperature value, Thermostat Manager will reset the thermostat to your configured max/min temperature instead. Let me know what you think.

Hi, can’t find my netatmo thermostats, connected to ST via Netatmos own hub.? Am I doing something wrong or are these popular thermostats not working with this app?

Thanks /Andreas

@Dr_Crimper,

I can’t seem to find the device handler for this thermostat. Thermostat Manager currently supports any thermostat that uses the common, “thermostat” device capability. If you could point me to the direction of the device handler, I’ll take a look and see what the issue is.

ok jmarkwell, I thought DH wasn’t necessary when the thermostat was seen by ST app. I can’t find any DH sadly, just thought netatmo was a big player on the thermostatmarked… just have to wait for somebody that’s techsavy enough to make a DH :wink:

@Dr_Crimper, well - everything has a device handler. SmartThings just has many of them pre-installed for you. So we just have to figure out why we can’t see your thermostat in Thermostat Manager. I was able to find these:


But if you’re able to use your thermostat through SmartThings there must be a device handler that includes some type of thermostat capabilities somewhere.

The most likely case is that this thermostat uses a different capability set. One thing you could try is to replace this code: “capability.thermostat” with, “capability.thermostatMode” on line 236 of Thermostat Manager. If you are able to find your thermostat after that, then we’ll know that it is probably just missing the, “thermostat” capability.

Another thing you can do is to login to the IDE and select the thermostat from your list of devices. The 3rd line down has the, “type” listing. This should be the name of the device handler you’re using. If you can let me know what that is, that might help me find it.

I did find this exchange regarding Netatmo thermostats in the forums:


It seems to be not well supported…

NEW BUILD: 2020111401

  1. Redesigned Smart Home Monitor based setPoint enforcement into mode based setPoint enforcement.

I replaced the 3 Smart Home Monitor status settings with 3 new mode based configuration settings. Users will now be able to select a series of modes in which they want these temperatures to be enforced. For now there are 3 configurations that allow multiple mode selections. Try it out and tell me what you think.

Thanks for your help, I tried the change in code, didn’t work. Then I tried to change the device type to netatmo but that didn’t help either. As you can see the termostat is registered as “placeholder”.
tHe 2 empty slots are “Hub” and “Zigbee id”.

@Dr_Crimper It looks like some kind of cloud integration. I would suggest contacting Netatmo support. Tell them your situation and ask them if you can get a look at the code - or if not, what capabilities does this thermostat have?

ok, I tried to contact them, we will see what they say.

@jmarkwell I may be having the same type of issue. I had to reload the thermostat dashboard controller as it started showing only as a sensor, with no ability to control the thermostat. All is the same - honeywell 9000, etc. The dashboard control works again as it has for years, however the thermostat manager is saying no device found under main configuration. All has worked perfectly until this moment, and it seemed to start with the st app update. wanted to see if you or anybody had any ideas… Thanks

@jmarkwell
I think I may have it back up and running. I changed 239 as you said in the earlier post, and also had to edit the DH for the thermostat. “Type” was “placeholder”, which I changed to my honeywell model, and had to change “HUB” from nothing to “smartthings hub”. Everything seems to be talking again. As I have said earlier, this app works perfectly, and allows me to keep my guests from trying to A/C or heat the entire neighborhood. Thank you again

1 Like

@hsbarrett Interesting. You’re the first person who has reported this issue. While the change you made may allow the interface to function, there may still be underlying issues. I’ll get to work on a more permanent solution. Thanks for reporting. Until then, if you notice any specific issues, let me know and I’ll check for them.

One question: When you say that you changed the type and hub, are you talking about the device settings in the IDE? If so, what type did you set?

@Dr_Crimper, you may want to check your thermostat’s device settings as well.

@jmarkwell
I will, and thanks. It may be a minute or two before I get a full test, as I use this system on a vacation rental.
Yes. I changed those in the IDE, my device tab. The “hub” had nothing listed, so when I clicked it, the only other choice was “smartthings hub”. The type had “placeholder” as its listing, and clicking on it listed a LOT of choices, including Honeywell 8000/9000 tcc thermostat, which is what I have. Both choices seemed logical, and in conjunction with the line change you recommended, all parameters seem to be in place at least. I still say all this changed with the app update, but nevertheless. I will monitor it closely, and report back. Thanks again

@hsbarret I see. I’m thinking that maybe it was this change that actually solved the issue. What you did was to change the device handler that the thermostat was using.

If you would, please revert the Thermostat Manager code to the latest repository code and see if it works with the changes that you made to the device settings. If it does, then my guess was right and I will probably have to talk with SmartThings people about what all this, “placeholder” stuff is all about.

BTW, if this change does work, then you should be back to full functionality and shouldn’t have anything to worry about for the time being. That is unless there is a problem with the old device handler… in which case you may begin to notice problems with the thermostat device handler and may have to revert to the, “placeholder” type…

@jmarkwell
Well, this is where I am at this point with troubleshooting. I realized that although the thermostat DH was showing changes (made through the actual app for the thermostat), the ST DH would not allow me to make changes. Therefore, I removed the DH, and Thermostat Manager, and started over.

  1. changing the “hub” from nothing to “smartthings hub” in IDE devices takes away the ability to make changes from the ST DH.
  2. In order for Thermostat Manager to recognize the thermostat, both “Type” (in IDE devices) and the code change on 239 have to be made. “Type” has to be changed from placeholder to the model of my thermostat.
    Now, all indications show that Thermostat Manager is in charge, including in the IDE devices under thermostat, and control is established from the thermostat DH. However, I cannot seem to actually get thermostat manager to work… all I can really test (I am not there) is the heat and cool thresholds. They do not seem to be responding. Being that thermostat manager has worked flawlessly unto this point, I have to point to some type of problem with the ST DH for the thermostat. Best I can tell at this point, however I will keep trying.

@hsbarrett That actually makes sense. The capability change to the code that you made allows the interface to find the thermostat but it doesn’t allow full control.

So if you use the standard repo code you can’t see the thermostat even after you update the “type” (device handler) to the old one? If so, this may be a difficult problem…

@jmarkwell
I have tried every configuration I can think of. The only way to make Thermostat manager recognize the thermostat is to change the code line. This is regardless of placeholder or hub settings on the thermostat DH in ide. I have deleted the DH and reloaded from ST, no luck. Thermostat manager is not controlling the DH. I may be missing something simple, but I cannot get it to talk. I still have to think this is a problem with the DH. When this started (last week), the DH for the thermostat suddenly became a sensor only - would not even show the controls. Reloaded with the specific DH for my thermostat from ST, and this is where the problems started. Leave it to my luck for strange problems such as this. Thank you again for your help and time

@hsbarret OK. I think I can fix this, but it’ll take some time and I’m not sure it’ll work. For the time being, I recommend using manual settings or an alternative app. I’ll get back to you when I add this code in. You’ll have to act as kindof a beta tester since I can’t test this myself. I’ll have to add in all of these separate capabilities and allow for alternative control methods…

@jmarkwell
… Just for the hell of it, I tried the thermostat mode director (which never worked properly in the past for me), and it would also not recognize the thermostat. I called Samsung, and was informed that they are aware of an issue with the thermostat DH, and they are working on it now, however they do not have a timeline for the fix.

1 Like