[RELEASE] Tasmota (Connect) for Sonoff, Tuya, SmartLife & other ESP8266 devices)



@Edu - The additional 4 outlets would appear in ST as separate devices, Power Strip 2, 3, 4, 5 - they don’t appear in here, only the main device would show up.

Should be appear automatically, right? But not !

Just flashed my Tuya plug after they cease support on IFTTT, work super well on yr Tasmota Connect.

Thanks @hongtat

Hello @hongtat great piece of work.

I am using a ifan03, but I cannot control the light relay with the device driver. It seems that the switch capability is only used for the fan, and not for the light.

I checked the device driver code of tasmota-fan-light.src and when the rule1 for light relay changes of state is triggered in the device, parse() will record the new light state (POWER1) in the log, but it does not issue any event.

Is that a functionality that it is still pending? Or I am missing something?


@Edu In SmartThings New App => “Devices” - It displays a list of all your SmartThings devices, do you see your Power Strip, Power Strip 2, 3, 4, and 5 there?

@PabloGux Have you installed all the device handlers? This is a parent/child which sends event to the child device to control the light.

@hongtat Nope, just one Power Strip and nothing else.
I checked on ST Groovy IDE and also show only one

Opss I thought I had installed them all, but now I see that I missed tasmota-child-switch-device.src
Will try again!


I tried this for my sonoff pow2. Everything seemed to be alright. The device turns up in smartthings app etc. But it does not show powerconsumption. It do show energyconsumption, signal strength etc, and I can turn it on/off. But I can not see power meter. It stays on 0 all the time.
Any clue?

Turning it off/on for some reason worked. Now I can see the power consumption aswell.

And moving it to another place (hence, powering it off) made it report 0 all the time. After some minutes it started showing power-values in the app for again, some minutes. Then it stopped again. It seems like it workes sometimes as seen in the uploaded picture.
Its not the sonoff pow2 itself. Tasmota works and updates the values correctly. It must be something with the smartapp/devicehandler.
Doing some scripts in webcore I can see that
“Received event [Tasmota pow].power = null with a delay of 38ms”.

@Edu, did you add the child switch device handler?

I just tested to setup a power strip, no issue.

1 Like

Its installed as seen in the picture.
The main problem is only that the power-meter reports NULL to often as if it didnt work. In the attached picture it reports 0, and thats ok since it uses 0w at the moment. But NULL is an error somewhere. Thats what you can see in the picture above where in the device-log you can see that it some times report just “w” instead of “0w”.

@CSC I think didn’t. How should I do that ? Please

GREAT !! I found it on Repo, installed and working perfect !!!
Thanks lot , @CSC

1 Like

Can you update the code? It should fix the problem.

The code for the smartapp?

Update from Repo for both SmartApps and Device Handlers.

@hongtat Updated it now. The smartapp didnt have any updates but the devicehandler had one update. Will look into it later to see if it did any difference. Thanks!

@hongtat it seems to be working great now! Thanks! If you were my neighbour I would buy you a bear! :slight_smile:

1 Like

How would I go about adding a Tasmota RGB Bulb?

@Kent_Nyberg Do you have a real time update values in the app or they refresh any time you open the app?