[RELEASE] Tasmota (Connect) for Sonoff, Tuya, SmartLife & other ESP8266 devices)

@Dean_Scott I have ST & HA integration for few years, don’t like the extra SPOF & maintenance.
I have no idea of the error, could you try updating the codes and see whether you still get the error. If you still encounter it, could you paste me the errors from the IDE “live logging” for Tasmota (Connect).

It gives me this error

5580aca-75b5-4984-b763-0ccb64d9d2fe 2:27:27 PM: error java.lang.NullPointerException: Cannot get property ‘settings’ on null object @line 53 (doCall)

e5580aca-75b5-4984-b763-0ccb64d9d2fe 2:27:27 PM: debug getChildDevices(false), children=4

@Dean_Scott Can you update the codes and let me know whether it clears the error?

If it doesn’t, let me know the installed devices.

Thank you, I deleted the devices and the Device handlers, then reinstalled the handlers and everything works fine now. Thank you again for your help.

Awesome project! I forked it in GitHub and I am porting it to Hubitat (very early stage).

Thanks for the good work!

1 Like

@PabloGux @Ryan780
Thanks for bringing it to the Hubitat community - I’ve read your discussion about the real-time status, I don’t have a Hubitat, I’m afraid I’m unable to answer whether it works on Hubitat. I guess as long as it can receive HTTP GET, then the real-time status would work.

The real-time status does work on SmartThings hub, and it doesn’t require MQTT to work. Real-time means any local changes on devices would be reflected on ST immediately, the polling method is simply a “backup” solution.

It doesn’t require users to set any rules manually, everything is done for you automatically.

Other developers’ solution require custom firmware, MQTT or constant polling to get real-time status.
My real-time status solution is achieved by using a combination of stock Tasmota’s Rule Trigger and WebSend.


Backlog Rule1 ON Power#state DO WebSend ["+device.hub.getDataValue("localIP") + ":" + device.hub.getDataValue("localSrvPortTCP")+"] /?json={\"StatusSTS\":{\"POWER\":\"%value%\"}} ENDON;Rule1 1")

Let me know if you have further questions…

But how did you get over the problem that the WEBSEND uses HTTP Get instead of POST? I tried to get the exact same thing to work when Rules were first available in Tasmota and wasn’t able to get it to send the appropriate information to the Hub since it wants it in POST format.

The HTTP GET wasn’t working in ST for a period of time… It would hung for a few seconds before responding, and during that time, I’ve had to modify the Tasmota firmware to send HTTP POST for real-time status or otherwise wait a few seconds for HTTP GET to get a near real-time status.

Thank you.

@Ryan780 @PabloGux You should probably take this dispute to private messages, it adds nothing to the actual topic.


Hi guys, this is a newbie in IOT so please bear with me.
I flashed Tasmota to RF bridge, added Tasmota Connect to ST and paired an rf motion sensor in RF bridge through the web GUI.

It is not clear to me the next step: what should I do in order to pair the sensor and a lamp in ST. Basically, I want to switch on the lamp when the sensor detects movement.

Thanks for your help.


  1. Update to the latest Tasmota (Connect)
  2. Under Tasmota (Connect) SmartApp
  3. Add RF Bridge and fill in the IP address details
  4. Add Virtual Motion Sensor
  5. Under Virtual Motion Sensor - fill in the RFReceived Data (get it from the RF Bridge console) that your RF motion sensor sends for “active” & “inactive” states.

Then add Automation rules in SmartThings App.

@hongtat thank you.
I noticed that, although the sensor captures the movement and the lamp switches on, in ST under MyThings shows NoMotion.

Also, the sensor sometimes doesn;t respond and I receive the following:
16:12:01 RSL: RESULT = {“Time”:“2020-04-19T16:12:01”,“RfReceived”:{“Sync”:12470,“Low”:430,“High”:1210,“Data”:“844AA6”,“RfKey”:1}}
16:12:01 RUL: RFRECEIVED#DATA performs “WebSend [] /?json={“RfReceived”:{“Data”:“844AA6”}}”
16:12:06 RSL: RESULT = {“WebSend”:“Connect failed”}

@gtampako Is this the IP address “” of your ST hub? It appears it is unable to connect to ST hub. Check the IP address or try reboot your hub.

Anybody tried use it with power strip (Tuya based) like this :

Hi guys,

Really I flashed with Tasmota my smart plug and power strip with success…

And using the Tasmota Connect I added the smart plug perfectly but not yet the power strip.
Could you help me, how to add the power strip on ST? I can see it accessing by web mode but on ST I can’t see as multiple outlet (including USB).

Which “device” should I use? I tried some ways but nothing yet.
@hongtat maybe could you help me?


hongtat, thanks so much for making this app. I got it working for my generic dimmer switch.

I noticed in the your 1st post, you are able to display controls for a dimmer in the smartApp.

I have no clue where this option is. Any insight? Thanks!

@Edu Generic Switch (Xch) ; x = number of outlet

@zzaius It is in the device - tap on the device. Note: the screenshot is from the New App, the classic App control’s is different.

1 Like

@hongtat I did, but show me like a single one.
Look there:

ZLD-44USA-W Module


Program Version 8.2.0(tasmota)
Build Date & Time 2020-03-20T14:45:23
Core/SDK Version STAGE/2.2.2-dev(38a443e)
Uptime 0T10:53:00
Flash write Count 47 at 0xF5000
Boot Count 14
Restart Reason Software/System restart
Friendly Name 1 Larkkey_PowerStrip
Friendly Name 2 Larkkey_PowerStrip2
Friendly Name 3 Larkkey_PowerStrip3
Friendly Name 4 Larkkey_PowerStrip4
Friendly Name 5 Larkkey_PowerStrip5
AP1 SSId (RSSI) WiFi (80%, -60 dBm)
Hostname Larkkey_921A6B-6763
IP Address

|DNS Server||
|MAC Address|C4:4F:33:92:1A:6B|
|MQTT Host||
|MQTT Port|1883|
|MQTT Client|DVES_921A6B|
|MQTT Topic|Larkkey_%06X|
|MQTT Group Topic|cmnd/tasmotas/|
|MQTT Full Topic|cmnd/Larkkey_921A6B/|
|MQTT Fallback Topic|cmnd/DVES_921A6B_fb/|
|mDNS Discovery|Disabled|
|ESP Chip Id|9575019|
|Flash Chip Id|0x144051|
|Flash Size|1024kB|
|Program Flash Size|1024kB|
|Program Size|577kB|
|Free Program Space|424kB|
|Free Memory|27kB|


@Edu - The additional 4 outlets would appear in ST as separate devices, Power Strip 2, 3, 4, 5 - they don’t appear in here, only the main device would show up.