[RELEASE] Tasmota (Connect) for Sonoff, Tuya, SmartLife & other ESP8266 devices)

Would it be possible to have a device handler for a contact sensor and a motion sensor?
I know they are the same as a generic switch in tasmota but a device handler for smartthings to show open/closed. Motion / no motion with relevant icons would make this more complete.
Would Alexa then see them as sensors feather than switches too?

Thanks for making these handlers. They work great for me.

@hongtat I can’t find the H801 RGBW LED Strip Wifi Controller in the device selection options. Should I use Generic light (RGBW)?

Yes. Use the closest Generic device. - Generic light (RGBW)

First of all: THANKS A LOT. I literally spend this entire night (with my wife complaining) getting rid of Domoticz (yes, I tried to dump ST after the new app) and starting to get my tasmota´s out of MQTT/Node-Red and back again to ST. I was looking on tasmota website and saw the integration with ST being really supported in the new ST App. literally made my day. Once more: THANK YOU!

So, I have an issue with my Tuya IR Bridge. I had it converted to tasmota and after that to tasmota-ir. I tested my AC remote control at the console and it gave me the reply as “COOLIX” so I created a Virtual AC device of “Coolix” brand. I can do everything with the virtual device but change the temperature that doesnt appear on the virtual device screen on my ST App.

info:

Program Version 9.1.0(ir)
Build Date & Time 2020-11-07T12:00:25
Core/SDK Version 2_7_4_5/2.2.2-dev(38a443e)
Uptime 0T00:07:54
Flash write Count 53 at 0xF6000
Boot Count 25
Restart Reason Power On
AP1 SSId (RSSI) Ale e Debora (98%, -51 dBm)
Hostname YTF IR Bridge Module
MAC Address BC:DDxxxxxxxxx
IP Address (wifi) 192.168.1.100
Gateway 192.168.1.1
Subnet Mask 255.255.255.0
DNS Server 192.168.1.1
MQTT Disabled
Emulation Disabled
mDNS Discovery Disabled
ESP Chip Id 16256179
Flash Chip Id 0x1440C8
Flash Size 1024kB
Program Flash Size 1024kB
Program Size 573kB
Free Program Space 428kB
Free Memory 25kB

the IP is not fixed but the DHCP is set to expire in a week. I will change that but I am still testing to decide my network layout/coverage.

Can you give me a hint on what it could be?

Thanks once more… :slight_smile:

It’s a SmartThings issue. They broke something (again). Wait for them to fix it.

Hi Hongtat:

I setup a sonoff motion detector to trigger alexa routine and trigger a wifi plug switch, it works for a while. and I just discovered it stop turn on the wifi plug switch after detected motion in sonoff. I just the motion sensor and wifi plug in alexa, they both work seperately but just not able to trigger in routine. Do you have any ideas where went wrong? Thanks

It could be something to do to the new Tasmota 9 version that I am using?
Getting in advance the IR topic, is it possible to “learn IR code from the remote” for a AC that is showing the brand (whirlpool) but is not controlling it? I can hear the AC beeping but it is totally messed up. Do you think that maybe the tasmota.ircustom.bin version could have the chance on having the correct support?

If the individual devices are working correctly, but don’t work in automation/routine/scene/Alexa/Google/elsewhere, then you might want to check with the other non-working party.

The virtual AC is simply calling IRHVAC command (https://tasmota.github.io/docs/Tasmota-IR/#sending-irhvac-commands). If it doesn’t work correctly, you might want to report it to Tasmota or IRremoteESP8266 library.

It doesn’t not support learning IR, it will be too many IR code combination to learn.

If you have to use learned IR code, use the Virtual Switch to on & off the AC.

it is working now, I guess it was ST issue, thanks

Until GPIO pins/peripherals are supported there is a workaround in Tasmota 9.1+.

  • Add Sonoff SV as a generic switch 2CH in Tasmota (Connect)/SmartThings
  • In the Tasmota Web UI go to Main Menu | Configuration | Configure Module and set GPIO4 to Relay 2 and set GPIO14 to Switch 2 (magnetic reed sensor). Hit Save.
  • In the Tasmota Web UI go to Main Menu | Console and enter the following commands:
  1. PulseTime 10 (this pulses the relay on and off for 1 second)
  2. SetOption114 1 (this detaches all switches from their relays)
  3. SetOption0 0 (don’t retain power state on restart)
  4. Rule3 ON Switch2#Boot DO Power2 %value% BREAK ON Switch2#state DO Backlog Rule3 0; Power2 %value%; Rule3 1 BREAK ON Power2#state DO Power1 1 ENDON
  5. Rule3 1 (turn on rule 3)

Make the physical changes to the Sonoff SV (remove resistors, configure relay as dry contact etc).

Use Power2 in SmartThings to open/close the garage door. Hide Power1 as this is the dry contact controlled by Power2. If the garage door is opened via a remote fob independently of SmartThings then the sensor will update the status of Power2 and you can use virtual switches to have Alexa etc notify you that the garage door is open or closed. What we are basically doing is tethering a GPIO sensor’s state (unsupported by Tasmota Connect) to a switch (supported by Tasmota Connect). Hope this helps.

Thanks for the support and fas reply. Seriously, I am very excited and have done some of my tasmota already and converted some light bulbs also. Absolutely amazing what have you done.

But coming again to the IR, I understood that learning would be a nogo for the amount of possible codes and combinations, however if I could learn ON and OFF why cant I learn temp up/temp down. For me that would be more than enough. Another point regarding the Virtual Device you said. What I am seeing in there is that for an AC (MIDEA) that I have that is using coolix as the coding standard for the IR the temperature is not reporting on the Virtual Switch down there in the end. I can see all options but the tempup/temp down and actual temp info. I am just repeating this since English is not my forst language and I could not have expressed myself correctly. Even with this new explanation the problem will be at Tasmota/ESPRemoteLibraly?

Hi @hongtat;

Is still with the issue on the DH for the remote control on IR for HVAC? It is still not showing the temperature slide at the bottom and the only temp that is passed to the AC machine is 17C. In fact it is fixed at 17C :slight_smile:

Hi, I have flashed a 2 channel wifi dimmer with tasmota and can switch both channels on and off independently and dimmer both channels independently. Can you provide a dimmer device with 2 channels, thanks?

Status
Module 54
DeviceName “XD0102”
FriendlyName
0 “XD0102”
1 “Tasmota2”
Topic “tasmota_57CF7C”
ButtonTopic “0”
Power 0
PowerOnState 3
LedState 1
LedMask “FFFF”
SaveData 1
SaveState 1
SwitchTopic “0”
SwitchMode
0 0
1 0
2 0
3 0
4 0
5 0
6 0
7 0
ButtonRetain 0
SwitchRetain 0
SensorRetain 0
PowerRetain 0
StatusPRM
Baudrate 9600
SerialConfig “8N1”
GroupTopic “tasmotas”
OtaUrl http://ota.tasmota.com/tasmota/release/tasmota.bin.gz
RestartReason “Software/System restart”
Uptime “0T01:02:16”
StartupUTC “2020-11-30T20:53:33”
Sleep 50
CfgHolder 4617
BootCount 12
BCResetTime “2020-11-30T01:35:01”
SaveCount 149
SaveAddress “F7000”
StatusFWR
Version “9.1.0(tasmota)”
BuildDateTime “2020-11-07T11:57:45”
Boot 31
Core “2_7_4_5”
SDK “2.2.2-dev(38a443e)”
CpuFrequency 80
Hardware “ESP8285”
CR “389/699”
StatusLOG
SerialLog 0
WebLog 4
MqttLog 0
SysLog 0
LogHost “”
LogPort 514
SSId
0 “indigo-priv”
1 “”
TelePeriod 300
Resolution “558180C0”
SetOption
0 “00008009”
1 “2805C8000100060000005A00000000000000”
2 “00040000”
3 “00006000”
4 “00000000”
StatusMEM
ProgramSize 600
Free 400
Heap 24
ProgramFlashSize 1024
FlashSize 1024
FlashChipId “144051”
FlashFrequency 40
FlashMode 3
Features
0 “00000809”
1 “8FDAE797”
2 “04368001”
3 “000000CF”
4 “010013C0”
5 “C000F981”
6 “00004004”
7 “00000000”
Drivers “1,2,3,4,5,6,7,8,9,10,12,16,18,19,20,21,22,24,26,27,29,30,35,37”
Sensors “1,2,3,4,5,6”
StatusNET
Hostname “tasmota_57CF7C-3964”
IPAddress “192.168.0.161”
Gateway “192.168.0.1”
Subnetmask “255.255.255.0”
DNSServer “192.168.0.1”
Mac “C8:2B:96:57:CF:7C”
Webserver 2
WifiConfig 4
WifiPower 17
StatusMQT
MqttHost “”
MqttPort 1883
MqttClientMask “DVES_%06X”
MqttClient “DVES_57CF7C”
MqttUser “DVES_USER”
MqttCount 0
MAX_PACKET_SIZE 1200
KEEPALIVE 30
StatusTIM
UTC “2020-11-30T21:55:49”
Local “2020-11-30T22:55:49”
StartDST “2020-03-29T02:00:00”
EndDST “2020-10-25T03:00:00”
Timezone “+01:00”
Sunrise “08:21”
Sunset “16:55”
StatusSNS
Time “2020-11-30T22:55:49”
StatusSTS
Time “2020-11-30T22:55:49”
Uptime “0T01:02:16”
UptimeSec 3736
Heap 26
SleepMode “Dynamic”
Sleep 50
LoadAvg 19
MqttCount 0
POWER1 “OFF”
Channel1 1
POWER2 “OFF”
Channel2 1
Color “0303”
Wifi
AP 1
SSId “indigo-priv”
BSSId “AC:86:74:EC:5C:43”
Channel 6
RSSI 68
Signal -66
LinkCount 1
Downtime “0T00:00:03”

stat/tasmota_57CF7C/STATUS = {“Status”:{“Module”:54,“DeviceName”:“XD0102”,“FriendlyName”:[“XD0102”,“Tasmota2”],“Topic”:“tasmota_57CF7C”,“ButtonTopic”:“0”,“Power”:0,“PowerOnState”:3,“LedState”:1,“LedMask”:“FFFF”,“SaveData”:1,“SaveState”:1,“SwitchTopic”:“0”,“SwitchMode”:[0,0,0,0,0,0,0,0],“ButtonRetain”:0,“SwitchRetain”:0,“SensorRetain”:0,“PowerRetain”:0}}

Virtual device started to work on with the temperature bar showing. Don’t know if you did anything but it worked!!

It worked! Nothing to do here!

I tried to use the virtual switch. There is a “ON” command and a “OFF” command. What do I put in there? Just the “Data: 0x…” Do I need to put the Brand, Model etc etc like the full tasmota command?

Also, I saw that the “whirlpool” brand there are some “models” . How do I chose the models on the “virtual hvac” device?