[RELEASE] Tasmota (Connect) for Sonoff, Tuya, SmartLife & other ESP8266 devices)

cannot be chosen during setup? am I doing smth wrong or just I need to choose generic 3ch switch?

for Sonoff T3EU3C-TX

thanks

It is Mac address. The DNI is auto-filled by the SmartApp - no need to manually add in ST IDE. Do you have a ST hub?

Choose generic switch.

Hi Tan,
I found the reason. Guest access caused the issue. Just deactivated and it works. I tried that option few week’s ago and did not realise that the subnet is different, so Tasmota could not connect.
Thanks for your help.

is there a way to have 3ch switch in one as in ewelink app, now it creates 3 separate switches in ST app?

Is there any way to state track rfraw data or similar ?

I am trying to keep rf bridge sniffing for rfraw data to make some automations based on rf signals

No. It is not supported in the new ST app.

Not yet. The rfraw 177 seems to crash/stop frequently for me, so I didn’t add it.
Should be able to include the raw data - I’ll check.

@w35l3y - Rfraw data is available now. Update the code, then go to the Tasmota SmartApp and tap “done”.

You have to manually rfraw 177 in the Tasmota console to enable it.

The RF code/data would be the raw RF code (in bold) as captured.

“AA B1 03 019A 042E 2B3E 28190908181818181818190909090908181818190909090908 55”

That is because the device loses “rfraw 177” state when turned off.
I will power it on with my no-break. (A new rule to re-enable it when turned on should do the trick too)

It worked for me. Thanks.

Hi
Somehow it is possible to make Sonoff TX (t3eu3c) buttons act as a “doorber” :slight_smile: when it gives signal as long as you press. (5-7s is enough though)
I am trying to dim LED tape via its transformer which understands “hold” signal as dimming command and dims immediately.
This function works with most of simplest regular push button switches but how to make my switch do this right?

my guess are switchmodes but I am not really sure how to do this.


SwitchMode 5
Set push-button with long press mode ( 0 = TOGGLE , 1 = ON ( default ), long press = HOLD )
Tasmota will send a TOGGLE command when the button is released (opening the circuit). When pressing the button (closing the circuit) nothing will happen. Default state is ON and when pressed it’s OFF. When held for the time set in SetOption32 ( default = 4s ), Tasmota sends HOLD (use Switch<x>#state=3 in rules)

any help would be appreciate and if someone could lead me, that would be awesome and beer (via paypal) is on me.

Tasmota (Connect) does not support this feature. It supports only ON/OFF.

thanks charles. I tried with a tasmota minimal bin image and it failed…info for those who having the same issue as me where the sonoffs are in a super tight crawlspace in the attic and you have gained weight over the past few months of lockdown!!..happy flashing

hongtat, maybe you know if it is possible to do all? connecting different way?
maybe you could guide where to look for some help in this situation?
thanks

@pashkustva - I don’t know, I don’t have a Sonoff TX. There are many options in Tasmota, I’d try the various options to see whether it works or not; and reset back to defaults, if there is issue.

Hi. How can I add a siren like this?
https://m.mydigoo.com/433mhz-wireless-diy-standalone-alarm-p-80.html

Hi Hongtat,

Great work on this - though i was hoping you could help me debug something. i’ve got a Sonoff S31 and it seems like I can send commands to it fine though smartthings, but it’s not reporting any kind of realtime status back (so i don’t see power or if the switch is manually operated).

I believe the device is sending suitable messages

07:04:46 CMD: Group 0, Index 1, Command "WEBSEND", Data "[192.168.2.2:39500] /?json={"StatusSNS":{"ENERGY":{"Power":"42"}}}"
07:04:46 RSL: RESULT = {"WebSend":"Done"}

That’s definitely the address of my hub and it’s listening on that port, but those messages never seem to appear in live logging. I tried adding debugging in the device handler parseEvents method, but those calls never even seem to get there.

Any idea how to troubleshoot that further?

Are the Tasmota and ST hub on the same subnet/network? It’s likely a networking issue.

Thanks - that’s definitely it.

I’ve got a v2 hub so it’s on ethernet and my wifi devices all exist on different subnets. I assume that smartthings uses the MAC address of the incoming web call to route it to the right device handler, and presumably it sees my router’s MAC when the request comes in from a different segment. Do you know of any good smartthings docs that explain that process or possibly other ways to deal with it? I think probably moving the ST Hub onto the “wireless” segment is probably the easiest option.

[Also for anyone reading this in the future, it’s pretty unlikely that this will be an issue for you. Most v2 hubs will be set up in a way that this all works beautifully. It’s a well-written smart app and my issues are absolutely a result of my esoteric network set up]