[RELEASE] Tasmota (Connect) for Sonoff, Tuya, SmartLife & other ESP8266 devices)

Wow thanks it works perfect !

I am close to getting my 2 DW1 door sensors working with my RF Bridge. The problem is that they stay showing OPEN in the new ST app. When I activate the sensors I get the following on the Tasmota console

. I entered the names (FD12A9) and (EA1C69) for the codes that represent the open state. I am using hongtat: Tasmota RF Bridge and Tasmota Virtual Contact Sensor Device Handlers. What am I missing?

I am repeating my previous post with more information.
ISSUE: DW1 Door Contact Sensors connected to a Sonoff RF Bridge do not respond and are stuck showing OPEN in SmartThings.
STEPS COMPLETED:

  1. Installed Tasmota (Connect) Smart App (on the new ST app) and the hongtat: Tasmota RF Bridge and Tasmota Virtual Contact Sensor Device Handlers (20200913 versions)
  2. Tasmotized the Sonoff RF Bridge and configured the template. (Note that I left the MQTT enable box checked.)
  3. Set static IP addresses for the RF Bridge and my ST Hub.
  4. Used the Tasmota (Connect) smart app to set up the RF Bridge and the Virtual Contact Sensors. I activated each DW1 Door sensor and used the codes FD12A9 and EA1C69 to represent the OPEN state. Since DW1 sensors only show OPEN , I left the codes for CLOSED blank and entered 3 seconds to go the pseudo closed state.
    The Tasmota Console displayed the the following when the DW1 door sensors were activated:
    22:06:28 RSL: tele/tasmota_A281E0/RESULT = {“Time”:“2020-09-20T22:06:28”,“RfReceived”:{“Sync”:12610,“Low”:420,“High”:1230,“Data”:“FD12A9”,“RfKey”:“None”}}
    22:06:34 RSL: tele/tasmota_A281E0/RESULT = {“Time”:“2020-09-20T22:06:34”,“RfReceived”:{“Sync”:12740,“Low”:430,“High”:1260,“Data”:“EA1C69”,“RfKey”:“None”}
    Note that the dates shown in the Console are correct, but the times are not. I’m not sure if this matters?
    In the ST App there is no history for the DW1 devices, the status always shows OPEN, and they show they are connected to the ST Hub.

ANY IDEAS WHY MY DOOR SENSORS ARE NOT RESPONDING AND STUCK ON OPEN? ANY SUGGESTIONS ON WHAT I CAN TRY?

I connected this today and looks awesome, nice to just see the switches in my device list. Can anyone help with a few questions though:

  • When connecting a new device there is no option for a Sonoff T1, do I just select generic switch?
  • Does this overwrite rule1 and rule2 on the switch when it is connected? I found my websend rules for 2-way switching were removed and replaced (see below)
  • When I add my 2-way switching to rule3 it no longer seems to work, does the new rule1/rule2 prevent rule3 from running? If I overwite rule1 with my original rule then 2-way switching works but the status of the switch in Smartthings does not seem to update

After connecting a T1 switch I find that rule1 and rule2 change to (the IP is my ST hub):
{“Rule1”:“ON”,“Once”:“OFF”,“StopOnError”:“OFF”,“Length”:487,“Free”:24,“Rules”:“ON Power#state DO WebSend [192.168.10.85:39500] /?json={“StatusSTS”:{“POWER”:”%value%"}} ENDON ON Power1#state DO WebSend [192.168.10.85:39500] /?json={“StatusSTS”:{“POWER1”:"%value%"}} ENDON ON Power2#state DO WebSend [192.168.10.85:39500] /?json={“StatusSTS”:{“POWER2”:"%value%"}} ENDON ON Power3#state DO WebSend [192.168.10.85:39500] /?json={“StatusSTS”:{“POWER3”:"%value%"}} ENDON ON Power4#state DO WebSend [192.168.10.85:39500] /?json={“StatusSTS”:{“POWER4”:"%value%"}} ENDON"}

{“Rule2”:“ON”,“Once”:“OFF”,“StopOnError”:“OFF”,“Length”:391,“Free”:120,“Rules”:“ON Power5#state DO WebSend [192.168.10.85:39500] /?json={“StatusSTS”:{“POWER5”:”%value%"}} ENDON ON Power6#state DO WebSend [192.168.10.85:39500] /?json={“StatusSTS”:{“POWER6”:"%value%"}} ENDON ON Power7#state DO WebSend [192.168.10.85:39500] /?json={“StatusSTS”:{“POWER7”:"%value%"}} ENDON ON Power8#state DO WebSend [192.168.10.85:39500] /?json={“StatusSTS”:{“POWER8”:"%value%"}} ENDON"}

Thanks

Hey, Hongtat! I absolutely love the Tasmota Connect it helps so much with my smarthome integrations.

I’ve recently flashed a Sonoff RF Bridge and tried to use it with my Smartthings Link Hub (the one that comes with Nvidia Shield), but every time I press a button on the RF Controller the following message shows:

17:46:47 RUL: RFRECEIVED#DATA performs "WebSend [0.0.0.0:0] /?json={"RfReceived":{"Data":"BDDBE1"}}"
17:46:52 RSL: RESULT = {"WebSend":"Connect failed"}
17:46:52 RUL: RFRECEIVED#RFKEY performs "WebSend [0.0.0.0:0] /?json={"RfReceived":{"RfKey":"NONE"}}"
17:46:57 RSL: RESULT = {"WebSend":"Connect failed"}

The SmartApp as well as the Device Handlers are all updated and I’m not sure if it has anything to do with my hub being the Smartthings Link and not a regular one.

Thanks for being so helpful!

Check the RF bridge & virtual contact sensor settings. It should do a WebSend to the ST hub IP address for each received “data”.

04:49:55 RSL: tele/tasmota/RESULT = {"Time":"2020-09-22T04:49:55","RfReceived":{"Sync":7280,"Low":240,"High":710,"Data":"9BF929","RfKey":"None"}}
04:49:55 RUL: RFRECEIVED#DATA performs "WebSend [192.168.1.207:39500] /?json={"RfReceived":{"Data":"9BF929"}}"
04:49:56 RSL: stat/tasmota/RESULT = {"WebSend":"Done"}
04:49:56 RUL: RFRECEIVED#RFKEY performs "WebSend [192.168.1.207:39500] /?json={"RfReceived":{"RfKey":"NONE"}}"
04:49:57 RSL: stat/tasmota/RESULT = {"WebSend":"Done"}

Thanks, Hongtat,

Where or how do I go about checking the RF Bridge and virtual contact sensor settings? I assume this is from the Tasmota Console and not in SmartThings?
Does this require me to enter commands in the Tasmota console to set RULES?
What information should I read to understand this?
In your example above, I assume that 9BF929 is the virtual device code and your hub IP address is 192.168.1.207

Would the following be a rule or close to it that I would enter in the console:
RULE1 RFRECEIVED#DATA performs “WebSend [192.168.1.207:39500] /?json={“RfReceived”:{“Data”:“9BF929”}}”
Where I would substitute my IP for my hub and code for my sensor?
What does the following RULE do, ie,
RULE2: RFRECEIVED#RFKEY performs “WebSend [192.168.1.207:39500] /?json={“RfReceived”:{“RfKey”:“NONE”}}”

Have you setup the RF bridge in the Tasmota Connect App? And is the IP address correct? After you enter the IP address, it would setup the correct Rules in the RF bridge. You don’t have to enter the rules manually in the Tasmota console. To confirm the rules are correct, enter rule1 in the Tasmota console, it will display the rule1. To understand more about rules, please find them under here.

Yes. Select a generic switch.
It uses rule1 and rule2. You have to use rule3 for the 2-way switching. Or use the “Mirror switch” under ST Smart Lighting App.

It’s unable to get the ST hub IP address. The 0.0.0.0:0 should be the ST hub IP address. 0.0.0.0 is not correct. Do you have other Tasmota devices using the Tasmota Connect - do they work?

It works and tested only on ST hub v2 & v3.

Hi Hongtat:

I have a question regarding the setup in ST device.

  1. Under the DEVICE NETWORD ID, should I use MAC address (do I need “:” icon with the Mac address) or Ip address or ESP Chip id from the RF Bridge info (figure 2)
  2. SInce it is a virtural device, I dont have a psycial hub and there is no Hub selection (Can I leave it blank?)

Thanks

Figure 2

A ST hub v2 or v3 is a requirement for this to work.

Thanks, I am not sure why it wasn’t working yesterday but I tried again today with rule3 and now my rule runs after yours and Smartthings gets updated immediately. Previously I had tried this with Smartthings automations but there was too much lag between button press and the automation running.

I have two other Tasmota devices using the Tasmota Connect and they work flawlessly. One is a Smart Plug from Sonoff and the other is the Sonoff Mini. I really wish there were a better solution other than buying a regular hub, because Samsung doesn’t sell them down here in Brazil and shipping one from the USA would cost 100 dollars extra. No Joke.

But if that’s what has to be done, it has to be done…

Thanks, should I use IP address OR Mac address to fill in Device Network ID section, thanks

Thank you Hongtat for your quick and pithy response.

I think my problem is that I entered the IP address of the RF Bridge in the Tasmota Connect App and should have entered the IP address of my ST Hub.

I will try that as well as checking the rules. I am slowly getting a better understanding of how this works!

I changed to the ST Hub IP address and verified that it is correct
The RF bridge is set up in the Tasmota Connect App. The IP address for the ST Hub is correct,but should I add :39500 after the IP address? It does not make any reference to performing a websend. I am now noticing (!!!) displayed on the Tasmota (Connect) app after the IP address?

This shows the console display for triggering both contact sensors as well as the result for rule1:
15:38:57 RSL: tele/tasmota_A281E0/RESULT = {“Time”:“2020-09-22T15:38:57”,“RfReceived”:{“Sync”:12540,“Low”:420,“High”:1240,“Data”:“FD12A9”,“RfKey”:“None”}}
15:39:09 RSL: tele/tasmota_A281E0/RESULT = {“Time”:“2020-09-22T15:39:09”,“RfReceived”:{“Sync”:12680,“Low”:430,“High”:1250,“Data”:“EA1C69”,“RfKey”:“None”}}
15:39:30 CMD: rule1
15:39:30 RSL: stat/tasmota_A281E0/RESULT = {“Rule1”:“OFF”,“Once”:“OFF”,“StopOnError”:“OFF”,“Length”:0,“Free”:511,“Rules”:""}
15:40:35 RSL: tele/tasmota_A281E0/STATE = {“Time”:“2020-09-22T15:40:35”,“Uptime”:“4T00:10:08”,“UptimeSec”:346208,“Heap”:25,“SleepMode”:“Dynamic”,“Sleep”:50,“LoadAvg”:19,“MqttCount”:0,“Wifi”:{“AP”:1,“SSId”:“SHAW-669811”,“BSSId”:“C0:7C:D1:8A:EC:A8”,“Channel”:6,“RSSI”:100,“Signal”:-31,“LinkCount”:1,“Downtime”:“0T00:00:03”}}

It’s odd. If the other Tasmota devices work, then this should also work. Try this:

  1. Access the other Tasmota devices console and this device Tasmota console (http://<ip address>/cs?)
  2. Go to the Tasmota (Connect) smart app main page (where it lists all your devices)
  3. Tap “Done” to exit
  4. In the Tasmota devices console, do you get similar to this? The IP address in WebSend [192.168.1.207:39500] should be the same in all your Tasmota devices.

The IP address is your ST link hub IP address.

03:58:35 RSL: stat/tasmota_445D49/RESULT = {"Rule1":"ON","Once":"OFF","StopOnError":"OFF","Length":203,"Free":308,"Rules":"ON IrReceived#Data DO WebSend [192.168.1.207:39500] /?..."}

This has to be the IP address of your Tasmota device.

It’s working !!! Virtual Contact Sensors with the Sonoff RF Bridge:smile: These are the changes I made:

  1. used the IP address of the RF Bridge.
    2.deleted and reinstalled the devices and updated the Tasmota (Connect) App to the latest version.
  2. changed the device network ID for the Bridge to it’s MAC address without :'s
  3. unchecked the MQTT box in the console configuration.
    Some of these changes may not have been required.
    Thankyou Hongtat for all your help.
    My next project is to get a Sonoff Mini working using Tasmota (Connect)