[RELEASE] Tasmota (Connect) for Sonoff, Tuya, SmartLife & other ESP8266 devices)

Because before of your edge driver , change shelly to tasmota permit to manage in local lan, before in groovy no dh exist

1 Like

Exactly as @joinwind says. I add that I over and over again had asked Shelly CEO for an integration that would allow him to work locally with SmartThings but I was always told that this was not possible :pensive:

Hi, do your tasmota sockets still send their instantaneous power draw to the hub? I saw that some automations no longer worked, and now I’ve found out why. I ask this to understand if it is my problem or a problem of SmartThings or other related to tasmota. The plug in question It is a shelly plug s. Screenshot_2022-01-24-21-01-08-58_ee29f370f755f274a0693481416ae4a8|225x500

Well now with Edge they’ll be able to do it. I expect Shelly will come out with their own official Edge driver once it is out of beta. That will make all my work obsolete, but I’ll have laid the groundwork for a possible tasmota version.

What is the concern you have about flashing your devices back to the OEM firmware? Seems like that would be the easiest path.

from shelly to tasmota I had found an online procedure to do it by ota in wifi. The reverse is more complex and I burned two devices to do it, I wouldn’t want to risk it. Alternatively I should take them apart, buy a device to connect to the pc and install the firmware via pc, which I don’t intend to do

Sometime , like sonoff , they don’t offer the original firmware and your stuck there.
I did flash mine back in 2018 or something with this and now it still work but no more support , tasmota offert a large variety of device .

1 Like

sorry, but am I the only one who has problems with logging consumption in the history, or am I the only one who uses them? If I check the instantaneous absorption value it works, but it is not recorded in the history, so the automations do not work

Go to the http://<Tasmota IP>/cs?

Does it WebSend to your ST hub IP address? And result is {"WebSend":"Done"}

04:14:07.175 RUL: TELE-ENERGY#TOTAL performs "WebSend [192.168.1.208:39500] /?json={"StatusSNS":{"ENERGY":{"Total":"458.095"}}}"
04:14:08.104 RSL: stat/tasmota/RESULT = {"WebSend":"Done"}
04:14:08.123 RUL: TELE-ENERGY#VOLTAGE performs "WebSend [192.168.1.208:39500] /?json={"StatusSNS":{"ENERGY":{"Voltage":"243"}}}"
04:14:09.253 RSL: stat/tasmota/RESULT = {"WebSend":"Done"}
04:14:09.271 RUL: TELE-ENERGY#CURRENT performs "WebSend [192.168.1.208:39500] /?json={"StatusSNS":{"ENERGY":{"Current":"0.097"}}}"
04:14:10.153 RSL: stat/tasmota/RESULT = {"WebSend":"Done"}
1 Like

Thank for your help, all of my n. 08 tasmota device (shelly1pm and shelly plug s) have this situation. Whit command websend:


And with websend 192.1… :ipport this:

Sorry I’m not practical, I didn’t know which string was correct.
I did not understand now what I should do.

These are the results, if I understood correctly:
07:49:47.210 RUL: TELE-ENERGY#POWER performs “WebSend [192.168.1.2:39500] /?json={“StatusSNS”:{“ENERGY”:{“Power”:“0”}}}”
07:49:47.537 RSL: RESULT = {“WebSend”:“Done”}
07:49:47.550 RUL: TELE-ENERGY#TOTAL performs “WebSend [192.168.1.2:39500] /?json={“StatusSNS”:{“ENERGY”:{“Total”:“129.527”}}}”
07:49:47.807 RSL: RESULT = {“WebSend”:“Done”}
07:49:47.820 RUL: TELE-ENERGY#VOLTAGE performs “WebSend [192.168.1.2:39500] /?json={“StatusSNS”:{“ENERGY”:{“Voltage”:“232”}}}”
07:49:48.147 RSL: RESULT = {“WebSend”:“Done”}
07:49:48.159 RUL: TELE-ENERGY#CURRENT performs “WebSend [192.168.1.2:39500] /?json={“StatusSNS”:{“ENERGY”:{“Current”:“0.000”}}}”
07:49:48.675 RSL: RESULT = {“WebSend”:“Done”}

It looks fine. It doesn’t log the consumption value in history, because it is too much.
Which automations do not work?

This is a routine that:
If power of socked is > 100W tourn on tv and Onkyo. And the same routine for tourn off if the power is <20w.
With these routines I could synchronize the display status of the tv icon and Onkyo in the SmartThings App, because they are driven by IR blaster, so if turned on by remote control the status is not synchronized.

sorry, but do you see the current draw in Smartthings? I don’t, and consequently the automations don’t work

It appears your tasmota energy and power are “0”, so it is correct to be 0 on Smartthings. Is the tasmota device working? Do you see the values on the main page (like below)?

Yes, I took a bad example. The same thing happens for all 8 tasmota devices.




View consumption from web, console, SmartThings in Apps, but not in the history of events and therefore not in routines.

Are you referring to the “Automations” > “Add routine”?

It works fine for me. Did it work before for you?



1 Like

Yes s, I can made, but not work becouse In the history I see that it does not record Consumption, but only on and off. Until a month ago it worked.




If the values as highlighted in the box below are updating, then there is nothing wrong with the device.

It’s likely your automations or Smartthings issue. I can’t help on this, as it’s beyond my control.

1 Like

Ok, I understand, but please check in the history if your devices record consumption. I see the instantantaneans too, But they are not seen in history and this blocks routines. I wanted to understand if it’s a problem Just for me.

Would anyone be able to explain to me how to move tasmota devices from a v2 hub to a new aeotec hub just bought? Thank you

Delete all devices from the old hub. Add new devices to the new hub.

1 Like