[RELEASE] Tasmota (Connect) for Sonoff, Tuya, SmartLife & other ESP8266 devices)

SmartThings now has the capability of using Sonoff devices that have not been Tasmotized. I just connected a Sonoff Mini to SmartThings. This required 2 steps: First I had to connect the Mini to eWeLink and Second I added my eWeLink devices to SmartThings.
SmartThings lists both Sonoff and eWeLink as brands that work with SmartThings. However, I couldn’t get the Mini to pair directly with SmartThings as a Sonoff device.

1 Like

Thanks for creating this, has been working brilliantly for my tuya and sonoff devices - now I want to attempt something a bit more DIY, some weight scales, as per this hookup video:

Fully supported in Tasmota, but i’m guessing as there is no device handler for it yet wouldn’t work with tasmota connect? is it possible to have a generic device handler that just displays what value the device is sending? ie weight in this case

Hi @hongtat , I created s virtual switch turn on and off my TV. However the command and data are the same (samsung). I wrote the data on the monitoring field to track the device state. It works for turning it on but it doesn’t update for turning it off even though the data is received in the IR Bridge. Any thoughts?

@barrie, thanks, I wasn’t aware of that. Have just read about it at eWeLink has officially integrated with SmartThings

@hongtat, yes, that solved the problem. Thanks for your excellent work!

@hongtat, regarding the POW R2, there’s a small piece of functionality that @GaryMilne wrote into his now-defunct DH called “Operating State”, which was very useful for me when used in webCoRE.

It allows for a setting of “standbyThreshold” in watts.

  • If the power consumption of the electrical device connected to the POW R2 is zero, the operating state is considered to be Off.
  • If the power consumption of the electrical device connected to the POW R2 is above zero but below the standby threshold, the operating state is considered to be Standby.
  • If the power consumption of the electrical device connected to the POW R2 is above the standby threshold, the operating state is considered to be On.

If you perchance had the time and inclination to add this to your DH, is this kind of customization even possible in the new ST app?

1 Like

Hello Hongtat,

I am able to successfully setup the tasmota connect with smartthings. one thing that I am looking for is to have multiple schedules during the day but current setup only allows one setting for power on and power off. could you suggest how can I have multiple schedule ?

Today I flash all my shelly with Tasmota firmware, and after add in ST with your best smartapp!
One question, with a standard Shelly I can change light or socket and in ST I see correctly light, but with firmware tasmota and template shelly1 I see socket. Is possible change? Thank you Screenshot_20210103-091907|230x500

Hi @hongtat, one question on those TUYA WIFI Door Sensors. Does the App supports those devices? What type they would be? A On/Off switch? Does it have battery monitoring? The Tasmota firmware have that information for Battery (custom firmware).

tried but I’m not happy, I have a lot of lag on my shellys. Would anyone know how to go back to shelly firmware if possible ??

If the IR data is the same for ON & OFF, then it doesn’t know whether it’s on or off state.

Use the built-in ST automations or Smart Lighting. Or use Webcore.

No. It doesn’t support wifi sensors.

Reflash from the backups.

1 Like

I try with this guide, https://github.com/yaourdt/tasmota-to-mgos but not work for me unfortunately

Hi @hongtat, I saw in my IDE many errors like this in the picture. All on Shelly devices with Tasmota (shelly1, shelly 2rgbw, and shelly 1pm) not all, just some, but these errors are repeated cyclically and I don’t know what they could depend on

Can you update the Tasmota Connect codes to the latest (if isn’t), and let me know the device type of the error please.

Hi, @hongtat,
the smartapp it’s already update
The error in the shelly1, shelly1pm, shelly PlugS and Shelly rgbw2 (all the type)
I report all the errors found in the log in the last hour, divided by device type. All Tasmota with latest firmware available. If there is anything else I can do to help you identify the problem, ask and I will definitely:

Shelly PlugS
image

Shelly 1PM
image

Shelly 1


Shelly2

I hope @hongtat i hope this report will help to understand the origin of theproblem:

  1. I deleted all shelly tasmota devices from smartapp and left only the 3 devices I had previously (ex tuya now tasmota)
  2. I verified that there were no more errors in the IDE
  3. I started re-inserting all the tasmot shellys one by one using the smartapp and I checked the IDE for errors.
    No error messages until the 14th Shelly is inserted (therefore 17 total tasmota devices)

From the insertion of the 15th Shelly the errors started, but not only in the last one inserted, but on all the devices already inserted, exactly like the errors indicated in my previous message

I have inserted a total of 28 tasmota devices (25 are Shelly) and the errors appear in the ide exactly as before on all devices.

I notice my devices are not as instantaneous as I hoped, can my delays be linked to these errors?

Hi

Wanted to first say that this has been working flawlessly with just about all my Tasmota devices. I am running into a problem with only of them - the RF Bridge. I frequently get the error below, and of course, in these cases, it does not trigger the event.:

19:40:37 RUL: RFRECEIVED#DATA performs “WebSend [192.168.0.xx:39500] /?json={“RfReceived”:{“Data”:“xxxxxx”}}”
19:40:42 RSL: stat/tasmota_C2867F/RESULT = {“WebSend”:“Connect failed”}
19:40:42 RUL: RFRECEIVED#RFKEY performs “WebSend [192.168.0.xx:39500] /?json={“RfReceived”:{“RfKey”:“NONE”}}”
19:40:47 RSL: stat/tasmota_C2867F/RESULT = {“WebSend”:“Connect failed”}

(Obfuscated the IP and Sonoff Code)

Any help appreciated.

Hi there

I have +25 wall switches and sensors (zigbee and Z-Wave) on my Smartthings setup and i want to use it as my home automation “brain”.

I’ve flashed tasmota on a couple of Zemismart WiFi Curtain Switch and its working good with timers configurated.

I think tasmota connect is the exact missing piece for advanced users to implement Tasmota on ST devices but once I installed it, noticed it doesn’t have blind/shutter device handler. It works perfectly fine as a dual switch.
For example, I have 4 windows shutters in my house, so I have 8 switches on ST that control the up and down relays, but not the fine tune in percentage.

I wonder if it is possible to create a device handler for shutter functions in tasmota, with “shutterposition1 (x)” command? Similar to a window blind control in ST

I also have a roller shade / blind controlled by tasmota.
A tasmota (connect) device handler for ST would be great

Hi guys,

I have added a simple 25V DC sensor to the analog pin of an ESP-12F that I am using with a bunch of relays in an arcade machine I am building. I flashed it with the tasmota-sensor variant.

Is there any device handlers that can read from the measurement from the analog0 pin? Or a way to configure Tasmota so an existing handler can be used?

I’m not too bothered about it having configuration to read the voltage accurately, I am just trying to detect if power is present (i.e. is a device powered on?).

Thanks in advance

Slatty