[RELEASE] TankUtility Propane Tank Monitor SmartApp

I created a smart app and device handler for the TankUtility propane tank monitor.

Device Handler: https://github.com/joshs85/ST_TankUtility/tree/master/devicetypes/joshs85/tank-utility.src

Smart app: https://github.com/joshs85/ST_TankUtility/blob/master/smartapps/joshs85/tank-utility-connect.src/tank-utility-connect.groovy

Install Instructions


BTC: 14Q4ioMMGj1tJ8BLNctY1PwYH5CAGneiZ1
Paypal: paypal.me/joshs85123



I’ve been trying to get your TankUtility integtration working and having some difficulty.

It seems to work, but then stops – “Tank Utility (Connect)” shows the following error:

a83f908a-bd15-4308-a50f-ebc460ea3db5 7:37:26 AM: error groovyx.net.http.HttpResponseException: Unauthorized @line 146 (doCall)

a83f908a-bd15-4308-a50f-ebc460ea3db5 7:37:26 AM: info starting RefreshDeviceStatus()

a83f908a-bd15-4308-a50f-ebc460ea3db5 7:37:26 AM: info starting pollChildren

a83f908a-bd15-4308-a50f-ebc460ea3db5 7:37:26 AM: info starting pollChildren

And the DH when polled from the simulator shows:

141594ee-4700-42d6-aaf0-8b47c63aef7e 7:50:09 AM: error java.lang.reflect.UndeclaredThrowableException @line 67 (poll)

141594ee-4700-42d6-aaf0-8b47c63aef7e 7:50:09 AM: debug Executing ‘poll’ using parent SmartApp

141594ee-4700-42d6-aaf0-8b47c63aef7e 7:50:09 AM: debug Executing ‘poll’ using parent SmartApp

But sometimes it works when I initiate manually.

Any suggestions?

Thank you,


If you open the app up does it ask you for your credentials again?

No, when I open the app it just says “Authentication Succeeded!” without having to reenter my credentials.

Sorry for the late reply. I started getting the same issue on mine after a smart things firmware update. If you open the app and click save at the top right, it should fix it. It looks like maybe the scheduling got stopped by smart things or one of the stored values got removed somehow… not sure why though. If it happens to you again, let me know. I’ll try to keep an eye on mine and debug it more.

I’ll give it a try.


It looks like it worked, but it was only temporary.

That is, resaving resulted in sending the data to grovestreams just the one time.

Any other ideas?


I figured it out and fixed it. Looks like the api tokens expire after 24 hours and I originally didn’t account for that. Should be working now. Just update the Smart App to get the update.

Hello, I have been using your integration and recently had to switch the smart app to a new hub. It worked and created my tank in the list of devices, but it stopped polling after 24 hours. Found your notes above, and have removed and reinstalled the device handler and smartapp multiple times, but the device never appears in my list of devices. Can you help me figure out what is going wrong?

Yeah. I can help. Remove the app, make sure you’re updated to the latest available version and re-install with live logging opened up and send me the logs from the device handler and smart app once you’ve entered your credentials and saved the app’s settings. and completed configuring the app. Make sure to send them in a private message because the logs may contain your API key\secret.

Thanks Josh! Not sure what happened but I went in to remove the SmartApp and it looked a little different. My username and password no longer displayed and it said authentication succeeded. I clicked save and the device appeared as it normally did. If I have further issues, I’ll let you know. Thanks again for setting this up for the community!

Hey Josh, thanks for this integration. I just installed a new Tank Utility and it and your integration with smartthings seem to work fine. However the issue I have is when I try to use it with the “new” smarthings app and with ActionTiles; they both report the “level” as an energy value (kwh), not a percentage. Not a huge deal since the value is correct but just wondering if you have any ideas how to work around this?

Best regards,

I tried to find a workaround for this a while back and couldn’t. The app needs to be adjusted so it works with the new ST app, but I haven’t had much time to work on this. When I do, I’ll try to fix this in the new app.

Thank Josh,

I actually managed to make it work by switching it from energy to battery capability. I got that suggestion from the good folks at ActionTiles.


Mike Puiu
Waterside Beach Holdings Inc.
c (954) 295-9056

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.