[RELEASE] Super Notifier - All your alerts in one place!

Yep, just make another instance to separate audio and push notifications if you only want the virtual switch to control one and not the other. I guess I could’ve made that switch restriction just for the audio, or I could add another to it in the next update so you don’t need extra instances.

I did have it automatically remove the timestamps from notification, so you can use the same instance otherwise. For example, I have a “Fridge left open” notification that I always want, so I just needed to turn on audio for the instance I had already set up for push notifications. I get a text with the timestamp but the audio announcement is just the default “Fridge is still open.”

You rock. Nice extension. I’ll take a percent of all that revenue you’re generating from the idea. What’s 25% of zero? :rofl:

Look forward to the day you extend audio notifications to TTS devices like Sonos as well!

1 Like

Hah! Truth.

I’ll have to look into how those work. I don’t think it’s complicated, I just don’t have any experience with them. I’ll shoot you a PM when I get a chance to play with it, and give you the link to where I throw betas if you don’t mind being a guinea pig and testing it before I push it out. (You’d just have to copy/paste the code into the smartapp on the API instead of using the github repository). It’ll probably be a bit, I pushed off some work to do some coding on this and other projects, but that’s coming back to bite me!

Yeah sounds good. Happy to be your pig, I mean, beta tester.

Hello JMZ:
I was wondering if you could help me.
I’m trying to get SuperNotifier working (a great idea! Precisely what I need).
I want to have many child apps run, at a specific time of day, to check to see if a contact sensor is still open.
Well, in testing, I left open that specific window, but it fails to notify me.
The log shows the following:
822496f0-49e1-4a38-9684-60285ed80afa 2:32:01 AM: info updated with settings: [messageText:Breakfast Room Window Open, snoozeSwitchOnOrOff:Off, useTimeStamp:true, waitThreshold:1, modeChange:false, speechDevices:[Google Assistant Relay Speech, Home group], periodicNotifications:true, starting:2019-01-09T02:30:00.000-0500, endingX:A specific time, controlSwitchOnOrOff:On, sunChange:false, snoozeSwitch:Sensor Switch, monitorType:Contact Sensor, speakNotifications:true, myContact:BR Window Sensor, controlSwitch:Sensor Switch, phone-0:false, startingX:A specific time, modes:[Home], openClosed:Open, wantsPush:true, ending:2019-01-09T02:35:00.000-0500]

822496f0-49e1-4a38-9684-60285ed80afa 2:32:01 AM: info updated with settings: [messageText:Breakfast Room Window Open, snoozeSwitchOnOrOff:Off, useTimeStamp:true, waitThreshold:1, modeChange:false, speechDevices:[Google Assistant Relay Speech, Home group], periodicNotifications:true, starting:2019-01-09T02:30:00.000-0500, endingX:A specific time, controlSwitchOnOrOff:On, sunChange:false, snoozeSwitch:Sensor Switch, monitorType:Contact Sensor, speakNotifications:true, myContact:BR Window Sensor, controlSwitch:Sensor Switch, phone-0:false, startingX:A specific time, modes:[Home], openClosed:Open, wantsPush:true, ending:2019-01-09T02:35:00.000-0500]

6b07c0f8-532e-4

The specific sensor is called BR Window Sensor, and I set it to notify me as well as a message on my Google Home. I left open this sensor, and set the execution to be at 2:30AM.
No notification, and no message on my Google Home.
Can you spot any issues?
I am also attaching some screen shots of the input parameters:

Longshot but at that time is smartthings in away or night mode or I guess anything but home?

Nope. In Home mode.

in the last picture, the one with your restrictions, the bottom of screen is cutoff. It looks like you have a “Only when this switch is…?” setup. I can’t see the last setting, the way you have it set up, you’ll only get a notification if that last switch is on or off (whichever you chose) while your window is open and the time is between 2:30 and 2:35.

Long shot there, but everything else looks just fine. Let me know; we’ll figure it out!

So, I thought that it might be that switch.
So, I re-did the entire thing, and put on no restrictions at all!
I still didn’t get any notifications!

Let me re-phrase exactly what I’m trying to do - in a simple manner.

  1. I have a sensor on a window - BR Window Sensor
  2. If it has been left open, and the time is after 11pm, then Notify.
    That’s all - I will change the notification to notification to my Google Home once I get this working.
    I’m attaching a revised set of screen shots.

Well this one is easier. You have “Send Push Notification?” off and “Jack” in “Send Contacts to send SMS Notifications:” is off as well, so it won’t send either. You had “Send Push Notification?” on in your earlier post, so you should’ve been getting push notifications, but you need to make sure you’ve allowed the SmartThings app to send you push notifications within your phone’s settings too. Let’s do a couple things to try prevent a lot of back & forth:

1)I’d turn both push and SMS on to eliminate any other issues

2)Verify your phone number is entered correctly in the main Super Notifier settings. Assuming you’re in the US, it should be “12223334444” (countrycode-areacode-number)

  1. PM me your debug log: First, turn on the “Debug Logging On?” setting by clicking on the “Advanced” section at the bottom of the main Super Notifier settings page. Then go to the SmartThings API logging page on your computer. Change the settings to notify you if the window is left open during a time window you’re about to be in (so you can capture the logs and not have to stay up late), but make it for a time in the future (5 minutes or something). Save settings, so that the debug log shows them, and then open the window. Wait until the time arrives, give it the respective 1 minute delay time you have in the settings, and watch the log. If you don’t get any push or text notification, screenshot the logs and PM them to me, and I’ll see if there is something in there.

Sorry you’re having the issues, I haven’t made any changes to this app in quite a while, and it’s been stable the whole time, which leads me to believe something in your settings wrong. I’d also recommend adding an instant alert to that window opening, just for test purposes, and see if you get notifications from that. It’ll help narrow down whether its a notification sending issue or something else.

I just installed this app and tried to setup a notification for a specific time frame. It only works if the event started inside the time period. If for example the contact sensor open just before and stay open during the time period, it would not trigger the notification. Any ideas?
Also the “save” button at the top is missing sometime making it very difficult to setup.

That’s not how it is programmed, so if that is how it is behaving either your setup has an error or Smartthings changed something and I need to fix the code. I use tons of child app instances everyday, for things like “garage door left open,” that only notify me if the garage door is still open after my presence has left. So it tracks the door opening and closing all the time, and then when my presence leaves, it determines whether the door is still open or not. Shoot me your debug logs in a PM so I can take a look at a what is wrong. It could be the time window restriction has an error, I’m not sure I use that, but you’d be the first person to report the issue.

Regarding the save button disappearing, that is outside the control of the smartapp. There is no way to program its behavior, it is only controlled by Smartthings themselves. If you’re having issues with it, I suggest asking Smartthings support. Let me know if you do, I’ve never heard of anyone with that issue, interested to know!

@JackTheMan18 & @maxony Are you still having issues? I retraced the app and for all trigger conditions, it tracks the trigger no matter what, records it, and only after all that does any restriction kick in, only preventing whether or not a notification is sent. So regardless of when the window is opened, it will keep track of that and wait to notify until the restriction conditions are met (e.g., if you only want to know about it if the window is left open between 9pm and 7am, then you can open it anytime during the day, but you won’t get a notification until the current time is between 9pm and 7am).

Can you add a battery or wired strobe/siren to the configuration to allow audio and visional notifications?

Couple updates in the works:

@MLUCK - I finally got some clarity on TTS devices and added it in beta. Could you please try it out? Just update from the repository as normal. It should pause currently playing tracks (if any) and resume them after the notification is complete. Can you test it both while it is playing something and also when it is not? Please let me know if you have any issues and I’ll troubleshoot. Probably best just to post logs in a PM with descriptions of the issues. Sorry for the massive delay. It was both easier and harder than I thought, and I’ve been focusing on some other projects.

@swdeason - I added an option to turn an alarm on, and another to turn a switch on or off. I tested the switch and it works well, but can’t test the alarm until later. Feel free to update your app as normal and test it out. Please let me know if you have any issues or comments.

Thanks. I was able to add the new siren but can not change the way it notifies me. Is there a way to change the type of notification you want… audio, visual, or both? I have the Dome siren with the updated device handler… [RELEASE] Dome Siren (Official). The handler allows multiple changes to the Dome setup.

If this SmartApp supports the Music Player or Speech Synthsis capability you can play the different sounds by specifying the sound number (1-10) as a custom message to play.

The Dome Siren has a setting that allows you to disable the strobe, but there’s no way to just turn on the strobe. Disabling the strobe is a configuration parameter so you won’t be able to change that using a SmartApp.

Thanks. I was able to figure it out. Have another issue with the “Only during specific mode” for notifications. I want to be able to have notifications only for motion device when in “away” mode only, I have setup the smartapp for away but no notifications come thru. Any advise. Thanks

Interesting. Can you you turn on Debug Logging? (open the Advanced settings at the bottom of the settings page) Then keep the logging API page open, set your mode to away, and trigger whatever you want triggered, and PM me the logs? I have all kinds of notifications set up with mode restrictions. Does it work without the mode restriction? Trying to figure out if it’s a problem with the mode restriction or a general notification issue.

Ok will PM you