[RELEASE] ST_Anything v2.9.2 - Arduino/ESP8266/ESP32 to ST via ThingShield, Ethernet, or WiFi

arduino
alarm
dth_misc
esp8266
esp32

(Dan) #2227

Click on my name and then click the big blue MESSAGE button in the top right of the pop-up window.


(Dan) #2228

Ahh yes, the power monitor project. Sorry, there are too many of users to remember each one… :wink:

Not sure why those would have a problem with keeping the dry contact side of the relay closed. Any chance you’re drawing too much power from the Arduino’s 5VDC voltage regulator? Do you have anything other than the 5 Contact Sensor pins wired to the Arduino? I assume you simply have one side of every relay going to Arduino GND, and the other side of each relay wired to a unique Arduino pin, correct?


(L B) #2229

Only the 5 contacts. Yes I have the ground on each relay and then each relay runs to one pin. I assume the network shield uses power as well. It works fine, but goes crazy every once in a while. Perhaps my power source is not big enough? I use an old Samsung phone charger…


(Dan) #2230

I typically power an Arduino MEGA with a 9VDC 1-2amp power supply connected to the barrel connector, not the USB port.

This is the one I’ve used with very good reliability.

It is a regulated power supply, which keeps the voltage more consistent under various loads.


#2231

I have St Anything working pretty much as I want now. Now for the next step. I have a couple of Google Home Mini devices. I have it turning on lights. What is not working is being able to operate devices in the ST Anything. When I try to operate a switch (ST) the Mini says it needs to be setup. In the Home App the devices are there with the names I setup in ST Anything on my phone. What else is there to do? Will the Mini operate the ST devices??

Thanks


(Dan) #2232

I can’t think of any reason why they wouldn’t work. It’ll take me a while to set up a test, as my primary hub is now Hubitat. Let me know if you figure it out…


#2233

It is probably my naivete. I will certainly report back if I figure it out. Thanks


#2234

I may have it figured out. I had to disable the access to all ST devices and manually select the switches. I only tested one but will check the others tomorrow night.


(Paul Mullen) #2235

I’ve run into the duplicate child problem. It’s a little random about which child is duplicated. I tried the “delete the extra child thing” and of course I get the Error in parse() routine, error = java.lang.NullPointerException: Cannot get property 'dateCreated' on null object error.

I’ve tried to build SmartApps that reference the child devices without deleting the duplicates, and I get unreliable results. I’m guessing that it’s just a not-quite-right database behind the scenes.

Do I just keep trying to add the parent until by chance I get a list of children with no duplicates?


(Dan) #2236

That’s one technique. Another is to delete the duplicate whose LastUpdated value does not change.


(Harlan Lau) #2237

Dan,

I have my Arduino Mega 2560 with W5100 ethernet shield up and running your On_Off_EthernetW5100 sketch and can turn the LED on and off from the ST app.

Now I’m trying to add your GitHub repository to my account:

  • Click on “My Device Handlers” from the navigation menu.
  • Click on “Settings” from the menu and add my GitHub Repository to your account
    • Owner: DanielOgorchock
    • Name: ST_Anything
    • Branch: master

However, when I click save to add your repository, I get the error message:
You don’t have access to DanielOgorchock/ST_Anything

I tried cutting and pasting directly from your README to avoid typos.

Suggestions?


(Dan) #2238

No clue why you’re getting an error on the GitHub integration. Have you used GitHub integration with ST for any other repositories?


(Harlan Lau) #2239

No, your repository was the first one (besides my own) that I tried to use the GitHub integration.

From googling the error, it sounds like a permission problem. It sounds like I need to be invited as a collaborator???

I wonder if this could be related to switching over to a Samsung account login?

Has anyone else added your repository using the GitHub integration recently?


(Harlan Lau) #2240

I tried to login using my old pre-Samsung credentials but no luck. Since I migrated to Samsung account that appears to be the only way I can login.

Has anyone else been able to use the github integration to add Daniel’s github repository since they migrated to Samsung account?

Daniel, I don’t suppose you could invite me as collaborator? My github owner name is charredwater

I really don’t want to manually add all your device handlers one by one since you’ve automated the process…


(Dan) #2241

Hmmmm, we have never had to add anyone as a collaborator to this repository. I am not sure what is wrong, but it seems to be specific to your account. Have you tried adding any other GitHub repositories from other developers?


(Harlan Lau) #2242

I logged into github to make sure my account is working.
I have one repository named apache but I’ve never committed anything to it.
I just created it so I could pull stuff from github.

When I look at My Device Handlers > Settings I see
Owner: charredwater
Name: SmartThingsPublic
Branch: master

But I don’t have a repository named SmartThingsPublic

I tried to add my own repository
Owner: charredwater
Name: Apache
Branch: master

and got the same error message as when I tried to add the ST_Anything repository:
You don’t have access to charredwater/apache

Any idea why I don’t have access to my own github repository???


(Dan) #2243

No clue. You may want to start a new topic to see if anyone else can help you troubleshoot GitHub integration. Or, contact SmartThings Support for assistance.

One question for you…what country are you in? I’m not sure if ST enabled GitHub integration worldwide.


(Harlan Lau) #2244

I’m in California.

Thanks for helping me narrow down the problem. I think starting a new topic is a good idea.


(Harlan Lau) #2245

I found a thread about github integration which suggested disconnecting my SmartThings account from github and then reconnecting. This did the trick. I was able to add your ST_Anything repository and add all your parent and child device handlers!


#2246

Newbie, sort of. Trying to get ST_Anything to command NodeMCU D1 to toggle. Using ST_Anything_Multiple (customization limited to wifi parameters). Live Logging shows ok communication. IDE serial communication shows seemingly good data transfer. I’m expecting to see a child thing magically built for the switch device when I upload the sketch, but it doesn’t happen. No child devices are generated. I gotta be missing something embarrassingly fundamental. After several hours of try, re-try, re-read, repeat, I’m out of ideas.
BTW, I was successful in getting the timed relay function to work using the ST_Anything_Relays_ESP8266 sketch but, of course, I’m looking for a toggle ON/OFF.