[RELEASE] ST_Anything - Arduino/ESP8266/ESP32

I just built the ST_Anything_Multiples_ESP32WiFi.ino sketch using the Arduino IDE 1.8.16 + ESP32 Board Manager v1.06 on Windows. There were no compilation errors.

I then upgrade the ESP32 from v1.06 to v2.02, which did cause compilation errors.

Please use the Arduino ESP32 v1.06 and try again.

1 Like

Ogiewon, I wanted to ask if this is still being looked at/worked on at all? I have been running it for some time and really appreciate having it. I use the thingshield code for some motion sensors and temp/humidity sensors. I have had issues with humidity for some time and recently replace them with aqara(sp?) units that just work great.

Last week I trimmed down the thingshield_multiples project to just the motion sensors. I made sure I had the latest from github etc… Compiled and uploaded.

Part of what made me do all this cleaning house is that all the devices report offline and show no history etc… but my light control with a motion sensors still triggered on motion so it wasnt pressing but its been this way for at least 1 or more years.

So I cleanup, upload, make sure i have the latest of everything in the development IDE from this project. Still I have everything shows offline. I removed a device expecting to see it re-add on its own. Nope it never has. Even stranger though… the light control app still triggers the light it always did and shows the device by name in the config for the automation. I dare not tamper with it lest it quit altogether but the device itself is most certainly not in my “all devices” list in the app?

I have not done anything to it other than update handlers when I saw new ones in the dev. ide all the way through the new samsung version of the mobile app. Last week was the first serious effort I have made to maintain this since long before the new app.

How is this possible and what am I missing? I hope there was a post a while back that I missed and this is a simple fix otherwise I am at a loss?!

I am not using SmartThings as my primary home automation hub these days. I do use it every now and then help existing ST_Anything users, like yourself. I am not actively developing ST_Anything for the ST platform at this time. The last effort was to try to make it work as much as possible with the new ST App, which I feel was successful.

Wow! I haven’t used a ThingShield for many years now. Glad to hear it has been working for you all this time!

Did you remove the Child Device? Or the Parent Device?

That doesn’t make sense, if you successfully removed the device from ST. Have you looked in the ST Web IDE (Groovy)? Is the device still listed there?

You may need to delete the Parent Device, and then reset the ThingShield, and then re-pair it to your ST hub (if you’re willing to take the chance.) I seem to recall that the move from the Classic App to the New ST App may have required such an extreme step in order to get things to work in the New ST App (but it has been quite some time, and I may be remembering wrong.) There should be some posts above which discuss the move from Classic to New app.

Not sure, as I don’t have enough information. My advise is to look into the Web IDE and look at your installed devices there. Also, make sure when you updated all of the ST_Anything DTHs that you also Published them. You can watch Live Logging to see what information you can glean from there as well.

You were right and even while I was writing the part about the motion sensor working I thought “I should check the IDE” Sure enough it was not in the mobile app (I deleted the motion sensor “child” I guess from the app but was in the IDE.

As far as risk, I actually have a second thing shield so I could “risk free” pair it with the similar code on another Mega and see what happens before deleting the original.

Thanks for the reply!

1 Like

@ogiewon and others i have had quite a few projects using ST_anything that still work but i tried to resurect one that i never deployed [RELEASE] ST_Anything - Arduino/ESP8266/ESP32 - #2772 by richland007
I got it set up on ide and its communicating it is showing values on the ide ut on the app it keeps saying “checking”
Is there a solution to this that i can change or i am missing… to be honest it has been quite some time that i have not messed with new devices on SmartTHings and i have not read above for any solutions that may have been answered in the past

Thank you in advance

Denis



You’ll need to update and publish all of the ST_Anything DTHs. The remove and re-add the Parent device so it picks up all of the changes that were made to support the change from Classic App to the New ST App. I haven’t tried using ST_Anything with ST for quite a while. Good luck!

Hi Dan,

How can I define “virtual” devices in ST_Anything? Specifically, I want to connect a couple of light sensors via LoRa to a receiving station, which would then relay data to using ST_Anthing to my SmartThings home network.

I know I can define ST_Anything luminance sensors directly attached to a ESP32 device, but in this case the sensors are remote. Ideally, these sensors would appear as “illuminance” devices on the ST app. Any recommendations would be appreciated!

I’d recommend simply modifying the PS_Illuminance device’s C++ code to collect the data from your LoRA sensors. That is exactly what ST_Anything was designed for end users to do. Use it as a template to build whatever type of device you’d like, and integrate with SmartThings or Hubitat.

I am new to ST_Anything (where have I been?) I am currently using Blynk to monitor multiple ESP8266/sensors around my house. The Blynk App that I have been using is going away so I am moving to ST_Anything.
I followed the README and to my joy, was able to get three different sensors and a switch up and connected to my Smartthings in no time: DS18B20, DHT22 and BME280. Here is my problem: The BME280 Pressure Measurement does not display the Pressure only shows Status Connected. Looking at the logs in the ST IDE ,it shows the parent receiving the pressure and the child parsing it and sending it (to the hub I assume). But it doesn’t show up on the App or when I list the events for the device in the IDE. The Temperature and Humidity work fine. I think I’ve seen this problem referenced a long time ago on this thread, but the solution did not seem to apply. Any thoughts?

The last time I checked, SmartThings did not have a “pressure” Capability. Thus, there is no direct mapping into the “New ST App”. Long ago, with the Classic App there were options to define Tiles that could display custom attributes.

I haven’t used ST for my home automation for just over 4 years now. Thus, the lack ST_Anything releases to support all, of the recent changes Samsung has made to the platform. I use Hubitat these days, but still try to help ST users when possible.

2 Likes