[RELEASE] ST_Anything - Arduino/ESP8266/ESP32

Throw something small like a RIB-U1C relay on your incoming non-ups power and wire the NO relay side into a digital input. When you lose power the input will turn on and then you can use that for whatever. Can get those for like $11 on Amazon.

1 Like

Damn, I really didn’t think that! I have some 120 ac coil relays. Duh!( Stupid me)

Can anyone recommend where to start if I want to setup a ST temp sensor with an ESP8266 + DS18B20

The old blog post I found so far has a sketch I can’t make work

You can start with https://github.com/DanielOgorchock/ST_Anything/blob/master/Arduino/Sketches/ST_Anything_Multiples_ESP8266WiFi/ST_Anything_Multiples_ESP8266WiFi.ino

As it includes a DS18B20 device.

You can comment out the devices that you don’t want to use in the above example sketch.

Dan,
Can you point me in the right direction for updating device handlers to work with the new app.
Worked great for over two years then forced migration and now clouds with lines through them and Alexa voice commands don’t work.

Thanks for any help and all the work you put in.

TC

Start here, but be sure to read the second linked post as well to save a little bit of time…

Hope this helps!

Hi @ogiewon I found my ESP32 locked up this morning, not responding to inputs or to commands from ST. The logs for the parent device show that its presence went not-present at 3:04AM. I can ping its IP address. I have been running a modified version of ST_Anything running on an Hiletgo ESP32 with OLED display and shows every refresh and the state of any input when it changes, and the display is frozen.

I am thinking this could have something to do with the DST switch-back at 2AM, potentially?

Is there any debugging you think I should do while it’s in this state before I press RESET?

Are there any firmware resources that I should be searching to see if there are known issues with the firmware on this ESP32? I have never updated/figured out how to update the OS/BIOS on this device…

I would just reset it and move on. I can’t think of any reason why it would lock up. Others have been using these devices for years with no issues reported.

Solar flare?
Power blip?
Buggy code?
SmartThings being SmartThings?
Power supply going bad?
ESP32 board going bad?
WiFi network glitch?

Well the latter one, definitely not. It’s WiFi interface is up. Is there any way to telnet into it or something to get status of the running firmware/application? Found this debug library via Wifi https://github.com/JoaoLopesF/RemoteDebug have you tried it?

No, I have not.

Since you’ve added custom code to the sketch, you may want to closely examine it to see if there are any issue that pop out to you.

Also, make sure you’re running the most up to date versions of all of the ST_Anything libraries, DTHs, Arduino IDE, ESP32 Board Manager, etc…

However, if this has run for years without issues for you, I would just reboot it and be done with it unless it occurs again. But that’s just me. Everyone has to determine where to draw that line for themselves.

I got the pressure sensor working in the NEW ST App.
Your suggestion to try the voltage measurement did the trick.
Thanks for the help.

The Water Sensor is still a mystery.
I too am using iOS.

1 Like

Understood. Is there ever a reason to update to the latest ESP32 firmware, in case there is any kind of DST bug in the OS? Do you have any links on how to do this?

Not sure about the possibility of a DST bug, as I don’t think these microcontrollers even know the current date and time…at least stock ST_Anywhere sketches do not try to keep track of DTTM.

You can ask @vseven about ESP32 specific questions as I believe he uses them. I have no ESP32 boards running.

I have a couple ESP32’s and I don’t know of any reason they would need to know the time at all, at least for ST_Anything. With that said I usually run the most up to date firmware. You can get pre-compiled builds at https://www.espressif.com/en/support/download/all , select the ESP32 checkbox and find the bin file for your model/type. Then to flash the board use NodeMCU PyFlasher which you can get at https://github.com/marcelstoer/nodemcu-pyflasher/releases . Personally I click the option to erase all data when flashing new firmware then reload my sketch afterward. So far no issues doing so.

So I got my pressure sensor to display in the NEW ST App as a voltage measurement.
This certainly solves my problem with the new app not displaying any value for pressure.
Now it would be nice if i could change the word “voltage” to “pressure” and at least display the correct units (PSIG).

I tried editing the Device handler as shown here:

But this change had no effect.

Is there a way to modify the Child Voltage Sensor" device handler so the it will display the correct units and measurement type (pressure)?

Thanks for any help.

SmartThings doesn’t understand what pressure is as there is no “standard” capability for it. You’d have to create your own custom capability and modify the DTH for it but it’s a lot of work if it works at all. See Custom Capability and CLI Developer Preview for more info.

1 Like

I am pretty sure the entire “TILES” section is now completely irrelevant in the “New” SmartThings App.

Looks like it’s going to be too difficult and time consuming to get my pressure monitor to display anything that resembles what i was able to get from the Classic ST App. Smartthings is making it more and more difficult to workout custom views. It looks like it might be time to consider switching to Hubitat and HubDuino.

1 Like

Finally was forced to use a new app ( :face_vomiting:)
After that, all my ST_Anything devices stopped working.
Here is what I have done so far without any success.
Updated in IDE “My device handlers” and “My Smartapps”.
Reflashed one device with a new set of libraries from github.com/DanielOgorchock,
Forced stopped a new app, cleared cache and data, change the device type in IDE (per @vseven suggestion Here)
Here is a strange thing - all devices stuck in the “Checking status” stage, therefore cannot be controlled/viewed.
I went back to the old, classic app to see if the device still visible there, and before the classic app kicks me out I was able to see contacts status and was able to toggle a switch, so I was able to confirm the device working properly but cannot communicate with a new app.

What am I missing? :thinking:

Now that you’ve updated all of the DTH’s (and hopefully published them as well!), you’ll need to now delete all of the child devices, it the Parent. Then simply restart your microcontroller and the child devices will be recreated and should work with the New ST App.