[RELEASE] ST_Anything - Arduino/ESP8266/ESP32

I deleted all child devices in new ST app. The child devices were recreated in both ST apps.

The child devices work in the classic app, but not in the new ST app.

In new app, each child device has cloud with slash through it.
In IDE, the child device’s Current States is correct contact:open or contact:closed.

Perhaps my device handlers are still downlevel?

ogiewon: Child Contact Sensor and several other ST_Anything DTHs are green instead of black.
Can’t figure out how to update DTHs.

Not sure what to tell you. If your microcontroller is working properly, running ST_Anything, and you’ve restarted it, or hit REFRESH on the Parent Device, then the child devices will be recreated.

You’re going to need to do this first…

I didn’t wait long enough. My child devices were recreated.

The new child devices work in class app, but still show cloud with slash in the new ST app.

Still trying to figure out how to update DTHs in IDE.

Did you use the GitHub integration to originally install all of the DTHs? If so, just log into the Web IDE, click “My Device Handlers”. Then, you’ll see a button near the top of the page that lets you update fro GitHub. Select ST_Anything, and make sure you check all of the updated DTHs AND a select PUBLISH in the bottom right corner before you click Update.

Yes, I used GitHub integration to originally install all of the DTHs.

I found help which explains that green DTHs indicate files exist only in IDE and do not exist in repository. So I must have obsolete DTHS that you renamed at some point in the past?
Child Alarm
Child Contact Sensor
Child Relay Switch
Child Temperature Sensor
Child Water Sensor
On/Off Ethernet
I guess I could delete these DTHs?

Help says magenta DTHs have been updated in repository but not IDE.
Since my DTHs are black (unchanged vs repository) or green (only in IDE, not repository), I’m up to date with repository.

I haven’t made any local edits of your DTHs.

So now I’m stuck since I already deleted and recreated all my child devices and they are not working in new ST app (although they do work in IDE and in classic app)

I was hoping I had a downlevel DTH which was causing the problem.

ogiewon,

ST_Anything is working on new ST app for me.
It turns out my github integration had broken and I had lost access to your ST_Anything repository.
I had to disconnect from github and re-add ST_Anything repository.
I deleted my ST_Anything DTHs and started from scratch, configuring parent anew.
Once child devices were recreated with latest DTHs, they worked in both classic and new ST app!
At least until Groovy goes away. I also bought a Hubitat as a backup.

Thanks for your help debugging ST_Anything on the new ST app!

1 Like

Congratulations! So happy to hear you figured it out.

I am still having issues with my ST Anything device and the NEW ST App.
My device has two child temperature sensor devices that work fine in the new app.
However, it also has two child pressure measurement devices which only display “CONNECTED”
and one child water sensor device which displays the cloud with a slash.
All 5 child devices work and display properly in the OLD app.
All 5 child devices work and display information in the ST IDE.
In the APPs, I have a smart app notification set up with the child water sensor device that works in both apps.
The latest device handle is published and in use for all 5 devices.

I have tried deleting the child devices and letting the be recreated several times, but nothing changes.

In the live logger, the pressure and water sensor devices are parsing correctly and no errors are reported.

Can anyone offer any suggests of what the problem may be and possible solutions or will these devices just not work with the new app?

Thanks for any help or suggestions.

The Water sensor works fine in the new app. I have no idea why it doesn’t work for you. Are you using iOS or Android? I am using iOS.

As for your Pressure sensor, since it is not a standard capability of ST, it will not work as-is.

You could try simply switching the name of your pressure sensor in the Arduino sketch

From

F(“pressure1”)

To

F(“voltage1”)

As this will cause a ‘Child Voltage Measurement’ device to be created instead of the Child Pressure device.

At least this way, the numeric value will be displayed when you click on the tile in the new app. Unfortunately, the voltage device does not display its value in the tile, as I cannot determine any way to do so without creating a custom capability for the new app (which I am not going to even try to wrestle with.)

I know this is not 100% smartthings anything …but once I can get it to work I intend to use the PulseCounter code to implement the final solution… anyways I can’t get interrupts to work correctly and hoping someone smart had an idea so I could move forward

Trying to use interrupts on ESP8266 NodeMCU ESP-12E
Here is waveform https://www.youtube.com/watch?v=sGJrUbsZiQ4
and here is code

[code]volatile uint32_t pulseCount = 0;

#if defined(ARDUINO_ARCH_ESP8266) || defined(ARDUINO_ARCH_ESP32)
#define IRQ_HANDLER_ATTR ICACHE_RAM_ATTR
#else
#define IRQ_HANDLER_ATTR
#endif

void IRQ_HANDLER_ATTR onPulse()
{
pulseCount++;
Serial.println(pulseCount);
}

void setup() {
#define DIGITAL_INPUT_SENSOR D2
// initialize our digital pins internal pullup resistor so one pulse switches from high to low (less distortion)
pinMode(DIGITAL_INPUT_SENSOR, INPUT);

attachInterrupt(digitalPinToInterrupt(DIGITAL_INPUT_SENSOR), onPulse, RISING);

Serial.begin(9600);
pulseCount = 0;
}

void loop() {
}[/code]

I should be getting a positive pulse around 1/sec but the interrupt counter is going up 10-15 or more a sec.
I have the hall effect/amp/schmitt trigger circuit and nodemcu on the same 5v supply.
Any ideas why this isn’t working ?

Hi Dan,

I wanted to ask about adding new devices in the “new app” environment. Since using the Classic App is out of the question, what’s the option to add new devices? thanks,

Alex

You should still be able to fill in the settings using the New ST App. However, as you have found, it is often much simpler to use the ST IDE to configure the user settings via the web browser.

Hi Dan,
Im the one who had emailed the newbish question (Ended up being a Ethernet Shield Hardware issue).
So I got your example sketch (Mega Multiples) working, and i modified it for my needs so far. All of what i am looking at works amazingly well, and i can not wait to deploy for my generator and household system control, except for one small issue: When you add multiple buttons to a LAN connected(shouldn’t matter) Mega running the ST_Anything library, i cant seem to get the buttons to populate as being seen as individual buttons, it combines their functionality and indicated status on the one button in the primary device created. So regardless if i press button 2 there is no button 2 created, but still shows up in the device. I checked the logs on the IDE side, and its seeing the button1,2,3,4 respectfully.


What i see on the appside.

ST_Anything Button devices are not created as Child Devices. The Parent Device simply generates the various button ‘pushed’ and ‘held’ events, along with the button number. You should be able to use an app like SmartLighting or webCoRE to use these various ‘button events’ to trigger whatever automations you’d like.

Unfortunately, the ‘New’ ST App only seems to only support one button per device. I believe this is a known limitation of the ‘new’ app.

I just tested this using the SmartLight SmartApp. Configuring the button number was a little wonky, but going back into the SmartLighting app a second time presented additional options to select the button number and type of button event. Worked fine.

Awesome, I will give it a whirl! By the way, again, an absolute amazing library and feature set.
Here is my setup, outside of its enclosure, to be built into my utilities room, controlling and running the generator I have tweaked for remote starting and shutdown. The idea is to make it ultra easy for wife to start using a Alexa skill for her when im at work.

Looks like you’re having some fun, for sure! :slight_smile:

So, you lose power without losing the internet? If losing power = losing the internet, then how are you expecting Alexa to work?

I am assuming you want to power on the generator when the power goes out… This may be a poor assumption on my part.

Thats a great question. I actually have UPS protection on the Echo in the living room, as well as on the router, cable modem(custom extended runtime UPS), server arrays Im using for file sharing, and also the ST Hub. What sucks is i came from IRIS and their v1 hub had power failure monitoring right at the hub, but i have yet to find that for ST. I also have a redundant WAN connection over cellular in the unlikely event Optimum has a failure.

1 Like

Cool! You’ve got it covered then.