[RELEASE] ST_Anything - Arduino/ESP8266/ESP32

I have never had this issue. Thus, I really don’t have any advice on how to avoid it from happening again.

ogiewon,

Fully powering down ST Hub didn’t help. I did reserve IP address for ST Hub in my router.

I’m trying to update code for my Device Handlers but can’t remember how to do so on the IDE.
On my Device Handlers page I can see Status for your Child Alarm, Child Contact Sensor, Child Relay Switch, etc shows they have been Editted.

I have a github repository pointing to DanielOgorChuck’s ST_Anything master branch.

But when click Update from Repository for ST_Anything (master), the boxes for Obsolete (updated in GitHub), Conflicted (updated locally and in Github) and New (updated only in Github) are all empty, as if nothing needs to be updated.

I tried clicking on the individual device handlers, but I don’t see anywhere to update from github.

How do I update the ST_Anything device handler code?

Sounds like you’ve actually updated all of the ST_Anything DTH code, but forgot to check the “publish” box when you did so.

So, now all you had to do to change the status from EDITED to PUBLISHED is to click on the name of each and every one of the DTHs, and the click the PUBLISH->ForMe button.

How would I go about trying to use the Voltage Measurement for my pressure readings? Is this a change to the DH or the ESP8266 code?

Yes, water sensor works fine in classic app.
Any ideas on how to get it to work in the NEW app?

It works fine for me in the new app. Maybe double check that the Child Water Sensor DTH has been updated AND Published?

Here is an example showing it working.

ogiewon,

Thanks for your help. Ran PUBLISH->For Me for each of my ST_Anything DTHs and everything started working again in the classic app.

I then migrated to new ST app and my non ST_Anything devices seem to work.

However, my ST_Anything devices no longer display their state as they did in the classic app.

Which I click on a ST_Anything child, it shows Contact sensor with a picture of a cloud with a slash through it.

When I look at the ST_Anything child in the IDE, Current States displays the correct state of contact:open or contact:closed, even though the new ST app does not display the state.

Is this expected behaviour under new ST app?

ST_Anything appears to be working in the IDE based on the IDE Current States, even though the app does not display the Current States like it did in the classic app.

Did you delete all of the Child Devices and the let them be recreated automatically? If not, they will not work in the New ST App, unfortunately. Yes, this means you’ll have to redo all of the automations that use these child devices.

No, I didn’t.

What is the recommended procedure for deleting all of the Child Devices? Searching this thread I see warnings about manually deleting child devices as it may break the Parent.

That was quite some time ago. It appears ST has corrected that issue, as my recent testing was successful with deleting child devices in the new ST App.

I deleted all child devices in new ST app. The child devices were recreated in both ST apps.

The child devices work in the classic app, but not in the new ST app.

In new app, each child device has cloud with slash through it.
In IDE, the child device’s Current States is correct contact:open or contact:closed.

Perhaps my device handlers are still downlevel?

ogiewon: Child Contact Sensor and several other ST_Anything DTHs are green instead of black.
Can’t figure out how to update DTHs.

Not sure what to tell you. If your microcontroller is working properly, running ST_Anything, and you’ve restarted it, or hit REFRESH on the Parent Device, then the child devices will be recreated.

You’re going to need to do this first…

I didn’t wait long enough. My child devices were recreated.

The new child devices work in class app, but still show cloud with slash in the new ST app.

Still trying to figure out how to update DTHs in IDE.

Did you use the GitHub integration to originally install all of the DTHs? If so, just log into the Web IDE, click “My Device Handlers”. Then, you’ll see a button near the top of the page that lets you update fro GitHub. Select ST_Anything, and make sure you check all of the updated DTHs AND a select PUBLISH in the bottom right corner before you click Update.

Yes, I used GitHub integration to originally install all of the DTHs.

I found help which explains that green DTHs indicate files exist only in IDE and do not exist in repository. So I must have obsolete DTHS that you renamed at some point in the past?
Child Alarm
Child Contact Sensor
Child Relay Switch
Child Temperature Sensor
Child Water Sensor
On/Off Ethernet
I guess I could delete these DTHs?

Help says magenta DTHs have been updated in repository but not IDE.
Since my DTHs are black (unchanged vs repository) or green (only in IDE, not repository), I’m up to date with repository.

I haven’t made any local edits of your DTHs.

So now I’m stuck since I already deleted and recreated all my child devices and they are not working in new ST app (although they do work in IDE and in classic app)

I was hoping I had a downlevel DTH which was causing the problem.

ogiewon,

ST_Anything is working on new ST app for me.
It turns out my github integration had broken and I had lost access to your ST_Anything repository.
I had to disconnect from github and re-add ST_Anything repository.
I deleted my ST_Anything DTHs and started from scratch, configuring parent anew.
Once child devices were recreated with latest DTHs, they worked in both classic and new ST app!
At least until Groovy goes away. I also bought a Hubitat as a backup.

Thanks for your help debugging ST_Anything on the new ST app!

1 Like

Congratulations! So happy to hear you figured it out.

I am still having issues with my ST Anything device and the NEW ST App.
My device has two child temperature sensor devices that work fine in the new app.
However, it also has two child pressure measurement devices which only display “CONNECTED”
and one child water sensor device which displays the cloud with a slash.
All 5 child devices work and display properly in the OLD app.
All 5 child devices work and display information in the ST IDE.
In the APPs, I have a smart app notification set up with the child water sensor device that works in both apps.
The latest device handle is published and in use for all 5 devices.

I have tried deleting the child devices and letting the be recreated several times, but nothing changes.

In the live logger, the pressure and water sensor devices are parsing correctly and no errors are reported.

Can anyone offer any suggests of what the problem may be and possible solutions or will these devices just not work with the new app?

Thanks for any help or suggestions.

The Water sensor works fine in the new app. I have no idea why it doesn’t work for you. Are you using iOS or Android? I am using iOS.

As for your Pressure sensor, since it is not a standard capability of ST, it will not work as-is.

You could try simply switching the name of your pressure sensor in the Arduino sketch

From

F(“pressure1”)

To

F(“voltage1”)

As this will cause a ‘Child Voltage Measurement’ device to be created instead of the Child Pressure device.

At least this way, the numeric value will be displayed when you click on the tile in the new app. Unfortunately, the voltage device does not display its value in the tile, as I cannot determine any way to do so without creating a custom capability for the new app (which I am not going to even try to wrestle with.)