[RELEASE] ST_Anything - Arduino/ESP8266/ESP32

@ogiewon or does anyone else know exactly is line 37 calling for in the ST_Anything_Multiples_ESP8266WiFi sketch?

#include <SmartThingsESP8266WiFi.h>

This is the umpteenth time I’ve had issues trying to upload/compile a sketch and every time I get this error.

So I found that file but wondering if I have the directory structure setup incorrectly. Where exactly does that file need to be? Not sure if this really shows what I have now but I will try anyway.

I see the issue… You need to MOVE the contents of the ST_Anything ‘libraries’ folder into the matching structure within your user profile… same for the Sketches folder.

libraries

sketches

Hi Dan,

I’ve been using ST_Anything for a year or so and have just updated to the latest device handlers - thanks for that.

I have a persistent issue - when I change the state of a switch in the App, it can take +5 seconds to take effect. This has been happening on both the Classic App and the new one, with both the old and new groovy code. It started about 1 year ago. When I run logs on the developer site, it seems to be a delay in the message getting from the App … which kind of rules out the Arduino and everything downstream … any ideas ?

Thanks
Darren

Might sound crazy, but have you performed a full power down of your ST hub? If a v2 hub, be sure to remove the batteries as well. This has solved performance related issue for others.

1 Like

Just a FYI for people still having trouble. Once you update your device handlers there is a caching issue with SmartThings, it can take up to 12 hours before the new device handlers actually start working. And even then sometimes they’re a little goofy. What worked for me because thankfully I don’t have that many automations was to just delete all the child devices but leave the actual controller alone. Once I did that I did a Refresh on the controller and all the child devices recreated on their own. Now they’re all working properly.

Thanks for the update @ogiewon, I had some custom child DTH’s before that I was using for testing but I just switched all my devices over to your new ones and everything seems to be working properly.

2 Likes

This makes perfect sense and is an excellent idea, @vseven. In addition to the metadata changes to the Child DTHs, the Parent Code was changed to created Child Devices slightly differently, which seems to make the child devices work much, much better with the ‘New’ ST Mobile App. So, your process definitely is the simplest way to accomplish and incorporate these changes.

Another donation back to the community that has been so helpful to me. Here is a solar powered moisture sensor based on ST_Anything and a few off-the-shelf components:

1 Like

Dan,

V2 hub, power down, batteries out, waited 2 mins for good luck and everything working as it should !

I’d tried numerous reboots with no success, no idea why this should have worked, but perfect - thanks !

Dan,

I know it’s hard to anticipate anything with ST, but do you expect ST_Anything to be irrevocably broken once they sunset the Groovy IDE? I hope not, but in any case, thanks for your many, many contributions!

Hi. I am new here.

Are you talking about it getting replaced by ST Device SDK? And the new SmartThings app
@ps0001

Most likely, yes. Someone would have to completely rewrite the integration to either work with whatever ST replaces Hub-Connected LAN DTHs with, or as a direct-connected device to the ST cloud.

Fortunately, ST_Anything does work with Hubitat, so you’ll have that as a potential option should the need arise.

2 Likes

Hello, can I install ST_Anything on a Nano Pi Neo - https://www.friendlyarm.com/index.php?route=product/product&product_id=132

Thanks

No. ST_Anything only runs on microcontrollers that compatible with the Arduino IDE, not full blown computers that rely on full operating systems.

A NodeMCU ESP8266 or NodeMCU ESP32 are both very low cost and effective microcontrollers that ST_Anything can be run on.

Is there a reason you want to use the Nano Pi Neo?

Just that I have it spare. Thanks for confirming. I’ll get some NodeMCU’s ordered.
Any Zigbee devices to cut the wifi traffic down?
Thanks again.

SmartThings used to sell an Arduino shield called the ThingShield. It was Zigbee based and is what prompted my son and I to write ST_Anything. It is very hard to find used ThingShields these days, and I am guessing that their days are numbered… Once the Groovy IDE gets shut down in sometime in 2021, I am not sure if there will be a way for them to still function properly. (Note: I do have the ThingShield working on Hubitat! :wink: )

In addition to the old Zigbee ThingShield, there are two other Zigbee devices that community members have created and offer to the community. The first is @iharyadi’s Environment Sensor EX and the second is @drandyhaas’s Mona Lisa. Both work very well, however I do wonder what will come of them once the ST Groovy IDE is shut down next year. Hopefully creating custom drivers for whatever replaces the current Groovy ST IDE for hub-connected devices will not be too hard.

1 Like

Hello ogiewon,
I see today that you made changes to the ST_Anything DTHs to make them work properly with the New SmartThings Mobile App. I have some ST-Anything devices that are not displaying the values in the New ST App.
I understand that I need to update to the latest device handles.
I am not sure how to do this, can someone provide the steps to this process?
It would be greatly appreciated.

If you’re using the GitHub integration in the ST Groovy IDE, it should be pretty easy to UPDATE and PUBLISH all of the ST_Anything DTHs. Just be sure to click the PUBLISH checkbox before updating all of the DTHs.

Thanks ogiewon,
That was easy.
However, it did not change anything in the NEW app.
My child temperature sensors still display as no connection (a cloud with a slash thru it).
My child pressure measurements still display as “CONNECTED”. No values.
My Child Water Sensor still display as no connection (a cloud with a slash thru it).

These all work fine on the Classic App.
Any ideas?

It may just be a matter of time, as the New ST App caches data about the devices for quite a while. If you don’t see improved results after 12 hours…you will probably need to delete all of the child devices (NOT the DTHs) and allow them to be recreated automatically.

Please see the following post from @vseven for details.