[RELEASE] ST_Anything - Arduino/ESP8266/ESP32

It would help to have a little more information. What type of child devices are you referring to?

Have you deleted the existing Parent Device (which will also delete all of its children), and then recreated the Parent Device?

The changes to the Parent DTH will only be effective once it creates NEW child devices.

Here is an example of a working ST_Anything device in the new app. (Ignore the Wemo outlet and the hub, they just happen to both be in the same room)

I have the following child devices: temperature, humidity, contact and doorControl.
I deleted the existing parent device, which deleted the child devices, then recreated the parent device with the new parent DTH.
The child devices all appear to be online, however they are not getting updated and the history of each device is empty.
The doorControl button is also not working. What’s interesting is that with the old parent DTH the doorControl button did work, although the child devices were showing offline.
Is it possible the firmware of the hub has anything to do with this? My hub is V2 with version 0.31.4.

Dan,
I can’t get Smartthings ThingShield to connect. I followed what i have done before but no children created. (Add Parent_ST_Anything_Thingshield in IDE and updated number of buttons). No Child was created. Thank you, I really appreciate all your help. My Habitat is in transit now :slight_smile: looking forward to play with it.


For a ThingShield, you do not manually create the device. You must PAIR the Zigbee shield to the hub, like any other Zigbee device. After it is paired successfully, you then change the DTH to the Parent ST_Anything ThingShield DTH.

I just added an IS_DoorControl device to my test ESP8266. It is actually working in the New ST App, although the New ST App seems to get confused by the fact that I have multiple Capabilities declared within the device. I am hesitant to remove the extra capabilities, lest it break someone else’s current system.

As for why your devices are not being updated, I don’t have any idea. You can try a full power down (remove batteries if needed) of your ST hub and then power it back on. I know that has helped some users in the past.

All I know, it the New ST App is now behaving much better with ST_Anything than it ever did previously in my testing over the past year. Be sure you’re running all of the lasted ST_Anything Groovy Code as well as Arduino code.

All - I have made changes to almost every ST_Anything DTH to try and make them all work properly with the New SmartThings Mobile App. For the most part, I believe things are working pretty well. @vseven had already made some changes a few years back, which was a nice start - THANK YOU! I had to piece together bits and pieces from a variety of sources to try and get things to look correct and display the correct values in the New ST App. In the process, I also did clean up some custom attributes which will not properly display in the New ST App, including @vseven’s old ‘lastUpdated’ custom attribute. Since it can no longer be displayed in the New ST App, I did not see any reason to keep it. I did leave the code for it commented out in every Child DTH, so feel free to uncomment those lines if you need that attribute for anything. Just remember that in two weeks the Classic ST App will be gone for good. :wink:

I really hope this helps the ST_Anything users!

Good luck everyone with your transition from Classic to ‘New’

Note: We all know how well that switch went for Coca-Cola! :wink:

2 Likes

@ogiewon or does anyone else know exactly is line 37 calling for in the ST_Anything_Multiples_ESP8266WiFi sketch?

#include <SmartThingsESP8266WiFi.h>

This is the umpteenth time I’ve had issues trying to upload/compile a sketch and every time I get this error.

So I found that file but wondering if I have the directory structure setup incorrectly. Where exactly does that file need to be? Not sure if this really shows what I have now but I will try anyway.

I see the issue… You need to MOVE the contents of the ST_Anything ‘libraries’ folder into the matching structure within your user profile… same for the Sketches folder.

libraries

sketches

Hi Dan,

I’ve been using ST_Anything for a year or so and have just updated to the latest device handlers - thanks for that.

I have a persistent issue - when I change the state of a switch in the App, it can take +5 seconds to take effect. This has been happening on both the Classic App and the new one, with both the old and new groovy code. It started about 1 year ago. When I run logs on the developer site, it seems to be a delay in the message getting from the App … which kind of rules out the Arduino and everything downstream … any ideas ?

Thanks
Darren

Might sound crazy, but have you performed a full power down of your ST hub? If a v2 hub, be sure to remove the batteries as well. This has solved performance related issue for others.

1 Like

Just a FYI for people still having trouble. Once you update your device handlers there is a caching issue with SmartThings, it can take up to 12 hours before the new device handlers actually start working. And even then sometimes they’re a little goofy. What worked for me because thankfully I don’t have that many automations was to just delete all the child devices but leave the actual controller alone. Once I did that I did a Refresh on the controller and all the child devices recreated on their own. Now they’re all working properly.

Thanks for the update @ogiewon, I had some custom child DTH’s before that I was using for testing but I just switched all my devices over to your new ones and everything seems to be working properly.

2 Likes

This makes perfect sense and is an excellent idea, @vseven. In addition to the metadata changes to the Child DTHs, the Parent Code was changed to created Child Devices slightly differently, which seems to make the child devices work much, much better with the ‘New’ ST Mobile App. So, your process definitely is the simplest way to accomplish and incorporate these changes.

Another donation back to the community that has been so helpful to me. Here is a solar powered moisture sensor based on ST_Anything and a few off-the-shelf components:

1 Like

Dan,

V2 hub, power down, batteries out, waited 2 mins for good luck and everything working as it should !

I’d tried numerous reboots with no success, no idea why this should have worked, but perfect - thanks !

Dan,

I know it’s hard to anticipate anything with ST, but do you expect ST_Anything to be irrevocably broken once they sunset the Groovy IDE? I hope not, but in any case, thanks for your many, many contributions!

Hi. I am new here.

Are you talking about it getting replaced by ST Device SDK? And the new SmartThings app
@ps0001

Most likely, yes. Someone would have to completely rewrite the integration to either work with whatever ST replaces Hub-Connected LAN DTHs with, or as a direct-connected device to the ST cloud.

Fortunately, ST_Anything does work with Hubitat, so you’ll have that as a potential option should the need arise.

2 Likes

Hello, can I install ST_Anything on a Nano Pi Neo - https://www.friendlyarm.com/index.php?route=product/product&product_id=132

Thanks

No. ST_Anything only runs on microcontrollers that compatible with the Arduino IDE, not full blown computers that rely on full operating systems.

A NodeMCU ESP8266 or NodeMCU ESP32 are both very low cost and effective microcontrollers that ST_Anything can be run on.

Is there a reason you want to use the Nano Pi Neo?