[RELEASE] Sonoff, Sonoff TH, S20, Dual, 4CH, POW, & Touch Device Handler & SmartApp ($5 & $10 Smart Switches)

I stopped using the new app pretty quickly. It’s rubbish in comparison to the classic app.
I have a couple of THs and they work fine in the classic app

1 Like
  • Mine is offset by 1.5 degrees and i am happy i could calibrate it via the settings, i input 1.5 but save it but is showing 15 (fifteen) in the saved settings. it is calibrated to + 1.5 .

  • I don’t know if with the classic App i can det an automation as i have on the new one, basically i set the water leak sensor beneath my aquarium to shut off everything when it is triggered via Smarttings hub !!!

Le sam. 14 sept. 2019 à 13:18, Mike Harvey via SmartThings Community smartthings@discoursemail.com a écrit :

1 Like

I think you can only offset by a whole number. I cannot even type a decimal point, there is no option.

I don’t see why you can’t set that automation in the classic app. I have plenty of automations. Set this up under Routines.

Otherwise, just install webcore and use that for your automations. It is far more advanced.

1 Like

To type a decimal, i just type in any other page than copy and paste, the decimal will disappear when you save but the calibration will be by decimal :wink:

1 Like

@Jeppepupu could you make the Shelly working?

@erocm1231 I’m having the same problem than @Jeppepupu, the device is rebooting itself in a loop.
I did some tests and if I keep the device powered by the serial port, the device stays on and I can cannect and configure it. The relay doesn’t work, because there is not enough power, but wifi does.
When I connect the device through the power line, the device starts rebooting.
I also tried with Tasmota and the original firmware, and it works with them, so the device doesn’t seem to be faulty

@p1x Unfortunately I didn’t get Shelly working. Tried several different methods to install firmware. Always results was the same rebooting cycle. Flashed two different Shellys unsuccesfully. Both worked fine with Tasmota.

Good morning,

I have had success installing @erocm1231’s tasmota fork onto a sonoff Mini using the DIY method, then adding the template via the web interface of the mini to give me local switch control via S1&S2

Adding the mini to smartthings using the sonoff-s20-tasmota.groovy device handler was straightforward.

I still get the orange dot on the configure icon, but everything works as expected and changes in switch state are reported to smartthings once the Hubitat / SmartThings enable checkbox is ticked and the Hub IP and port are configured to 39500.

I need to set up a Sonoff TH to report temperature, reporting of switch state is also important in this use case. Without a Device handler for the TH, can anyone suggest the best way to achieve this?

1 Like

Hello, could you explain better about this? Step by step? What firmware are you using for the sonoff mini? Are the switches physically working and returning to the ST?
Thanks.

@adamrhoades

Very nice. Can you provide us some kind of steps that we can replicate installation of Eric’s Tasmoto on mini and that also connected with ST.

I’m happy to try and help…

Some of the new Sonoff devices have a DIY mode that allows flashing using their windows tool. I did this on a virtualbox machine running windows on my mac.

Instructions : https://github.com/arendst/Sonoff-Tasmota/wiki/Sonoff-DIY

I used this to install Eric’s fork of Tasmota : https://github.com/erocm123/Sonoff-Tasmota/blob/6.6/sonoff/sonoff.ino.generic.bin

Once this was installed, I made sure it was connected to the network and reserved an IP for it.

The next step was to install the template for the mini so that S1&S2 would work as intended :
Template : https://blakadder.github.io/templates/sonoff_mini.html
Instructions : https://github.com/arendst/Sonoff-Tasmota/wiki/Templates#importing-templates

Then I added Erics device handler for the S20 to smartthings : sonoff-s20-tasmota.src

Then configure tasmota for smartthings by clicking : Configuration / Configure other & ticking ’ Hubitat / SmartThings enable

Then make sure the settings are correct : Configuration / Configure Hubitat-Smartthings and entering your smartthings hub LAN IP and the port 39500

Then I used Erics Sonoff Connect app in smartthings to search for the device. This should populate the device in the IDE with the correct mac address & IP etc. Make sure that the device type is : Sonoff S20 - Tasmota in the IDE / My Devices.

5 Likes

@adamrhoades You can try my Hubitat driver I just ported over. I haven’t tested it, but it should work. If it doesn’t, I may need to tweak it a bit.

In the post https://github.com/arendst/Sonoff-Tasmota/wiki/Sonoff-DIY 1 mentions that you cannot install sonoff-minimal. After installing my sonoff mini no longer flashes.

Sorry you’ve had trouble, I’ve removed that step to avoid anyone else having the same problem.

Initially I had problems getting Eric’s tasmota installed using the DIY method, I was able to switch back and forth between several different firmwares by using the minimal image as a stepping stone each time.

As it takes up less memory, there is more free ram to upload and unpack the new, larger image into.

I saw the warning, but had success regardless, I understood the warning to mean there where no settings to change, the minimal gives only very basic functionality and the ability to upload new firmware.

Is your mini bricked? Does it broadcast in hotspot mode? Any signs of life at all?

Awesome, thank you!

It may be a while before I can get to testing it, but will keep you posted.

Again, thanks!

1 Like

@erocm1231 @p1x Now I flashed Shelly with Tasmota firmware and then OTA upgraded to SonoffShelly.ino.generic.bin Same rebooting loop started.

With Tasmota firmware Shelly works fine.

@Jeppepupu, I don’t remember which settings I compiled that firmware with, but it may have been different than what was used for the Tasmota (which is likely causing the issue).

So, if you still want to use that firmware you will probably need to flash it with something like esptool using the flash mode of dout.

I actually recommend that you just use my Tasmota fork with the device handler for the s20. If you have regular Tasmota on it then first OTA to the sonoff-minimal.bin from the tasmota github release section. Then OTA my Sonoff Tasmota fork.

@erocm1231 Flashing Shelly1v3 with SonoffShelly.ino.generic.bin is not working. Tried with several methods and Shelly just keep rebooting itself. Same results also from @p1x

Following your advise with flashing with Tasmota then OTA to s20 worked. Then Configure Other and enable Hubitat / Smarthings. After reboot configured Smartthings Host and Port. Smarttings devicehander sonoff-s20-tasmota.src installed. Shelly is stable and configurations should be ok

For some reason Shelly is not discoverable in Sonoff (Connect) and if manually added not working. Any tips how to proceed?

@Jeppepupu for now set the device template to sonoff s2x in tasmota and try discovery again. It can take 5 to 10 minutes to discover. After it is discovered and saved you can switch the template back to a Shelly.

@erocm1231 Changed Module type Sonoff S2X (8) and tried to discover Shelly. Not successful with Hubitat port 39500 nor 39501. Waited in with both ports more than 15 minutes.
Manual Add Device did not work either. There is no selection for S20.

Something that could be tested? Willing to flash Shelly if new firmware will be generated. SonoffShelly.ino.generic.bin not working based of my experience.

@Jeppepupu What make and model of router do you have? Also, try rebooting it.

The forked Tasmota firmware should send out an ssdp packet every 5 minutes which Sonoff Connect should see. Check the Sonoff Connect logs over 10 - 15 minutes and see if you notice the ssdp coming in.

Can you post the results of http://ipaddress/description.xml ?

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.