[RELEASE] Sonoff, Sonoff TH, S20, Dual, 4CH, POW, & Touch Device Handler & SmartApp ($5 & $10 Smart Switches)

@tomfontaine Your best bet is to watch the logs when you hit the “Configure” button to see what it is trying to set and what is actually happening. Also, you can try to set the auto off in the web interface for the device.

@dotan_shai That is an interesting device. It looks like they are using the neutral from the light fixture with a bypass device. There are a few devices out there doing this. As for the firmware, I’m not currently supporting it. I do have a forked version of Tasmota that should support it, but someone would have to create the device handler for it.

There are some example device handlers in my main github:

The device handlers with “tasmota” in the name.

Have you tried mini ? Did you flash it with firmwire Eric created ?

Have you tried Mini flashing with Eric’s firmware?

this is what I get on the live logging
result: [success:false, type:configuration]

Quite where do you mean “web interface” ? !

Thanks.

He means using a web browser and going to the IP address of the device … then go to Advanced config - make your changes, and hit submit and it will call for a reboot . But, it doesn’t work (for me anyway) … I make the changes I want (like timeout), and then submit and save - and reboot - but it does not write the config to the device see attached images

Many thanks…I guess I could put a virtual switch in there, and do it that way…

The advantage is that if the relay burns to overcome the amperage, it is easily replaceable. already replace one and it works fine

:sob::sob::sob::sob::sob::sob:
I did everything correctly, but when trying to detect the device in smarthings classic app takes 20 minutes scanning and it doesn’t detect any device, I even use the function configure manual to detect sonoff using fixed IP and it doesn’t work either

To be more specific in my problem watch this video. This video From the minute 13 is where my problem begins, nothing that the boy does in the video happens to me.Those last steps don’t work for me. the app scan and scan for Long time looking for my Sonoff modified and connected to the network but nothing’s happen :sleepy:

And I spent a lot of time following this tutorial and it doesn’t work, I can’t find the error.

Note: the device is on my network and I can only control it from the web interface with the new firmware:crying_cat_face::sweat::sleepy: help me please!

here you have it Right Here

Not sure where you are stuck…try the YouTube video by Taylortech, and note that you sometimes need main voltage supply to the sonoff, not powered by the flash and pc, in order to find it.
Note also that you sometimes need to allow a few minutes when starting the sonoff again, or even remove and 're add it, in Smartthings.
I used both of the above and have not had any problems with numerous sonoff. The video makes it all very clear.
Meantime, sorry if I misunderstood your issue.

1 Like

Thanks for answering. I already saw the video you suggest and from minute 13 is my problem. nothing that should happen after the thirteenth minute happens to me. smart things classic app does not recognize my connected sonoff. I even put it fixed IP .
Here is the link video
From minute 13 it doesn’t work for me :sob: PLEASE HELP!

Difficult to know what you are doing wrong! There are two videos by the same guy…maybe try the other one in case you are misunderstanding a step.
Just check that you set up the device handler correctly and in the right “location” .On my set up, location has a default and then my actual home name…maybe you are setting up the handler in the default location. Can you see the SonoffConnect app in your smartthings screen, for example, or anything in your device handlers in your IDE?
Maybe also check on your router app or software that it does see the sonoff . If it isnt showing there then of course you can’t go further into smartthings. And, as I mentioned, you may need the sonoff on 220v and not the pc/usb power supply…I had to use 220v to connect. Read the comments below the video ,too.
All I can say is the method does work, so unless you have a bust sonoff, I think you must be making a mistake somewhere (such as not flashing correctly, or not setting up the device handler correctly.). There are other videos out there that may help you find your error.
Good luck!
Edit…have you got the right Comm port,did you set the sonoff correctly into flash mode (10.40), and when flashing, do you actually get the progress blue bar to complete (you can see it on the screen behind him at about (11.12). Some of the errors I made in the past!
Also, check the Ftdi/Sonoff wiring TX goes to RX, NOT RX to RX.

I’m sorry to be bumping my own post, but does the POW version correctly report power usage?
I can’t get min to report any power data. I don’t see any data in the IDE log or going into the device webpage. (I’ve flashed two units, and neither of them reports any data.)

hello,

  • Please i need help, i did abseloutly every step of the procedure and i get everything except the température on my smartthing app [both] , its a th16 with a DS18b20 probe. when i use the IP to access the TH16 i have this :{“power”:“off”, “uptime”:“0:6:57”, “temperature”:“24.63”, “scale”:“C”, “humidity”:“0.00”}
  • What i could have missed ???
    Thank you very much for your time.

I have been playing with the mini over the last couple of days. Yes it works with Eric’s firmware (Sonoff.ino.generic.bin) BUT you lose the ability to use the switch inputs.
Unfortunately this was a big part of the reason that I wanted this device.

SO I have been trying out Tasmota (never tried it before) and whilst that works well through the browser, and gives the ability to set GPIO4 to Switch1 (9) which means the switch inputs work but I cannot get Tasmota to work with SmartThings. It just seems Tasmota is inferior in that respect (I am not criticising it, it is great firmware if that is what you want!)

@erocm1231 is there something I am missing in your firmware that would also give the ability to set GPIO4? Otherwise, I believe you have said you are not going to be supporting this project any more, is there anyway I can do this myself? (or preferably someone else here who is clevererer than me!)

@glounk You used the connect app to automatically find and add the device into SmartThings? Check the advanced configuration in the switch web interface to make sure your SmartThings hub ip and port number are correct.

@loonass You can try my tasmota fork as mentioned:

Hi,

  • Yes i did use the app to automatically find the device but i couldn’t so i added it manually, after that i can switch it on and off via SmartThings app but have no temperature reading.

  • I just checked the SmartThings hub port and IP and they are correct.

  • After a restart, everything is working on the classic App, now i will find how this will display temperature on the latest App??? Any idea ??? i am really happy i could do this, thank you Eric and the community for your time and help.

Thank you for your help Eric :slight_smile:

Le ven. 13 sept. 2019 à 01:05, Eric M via SmartThings Community smartthings@discoursemail.com a écrit :

I’m not sure if this has ever been answered. But it appears that the firmware doesn’t support the Si7021. I have flashed the Sonoff Tasmoto firmware which returns the temp and humidity but will not work with Eric’s DH.

So what is the difference between your sonoff.ino.generic.bin (from your Tasmota fork) and arendst’s sonoff.bin?

I have now flashed your firmware but am struggling to get any further. I presumed the DH would be the same as your Sonoff Wifi Switch DH as it worked with that when I flashed your original Sonoff Firmware. The only issue was that I couldn’t use the external switches.

I have tried configuring the Hubitat/Smartthings settings but still can’t get any further.
I think I’m being thick!

As you can see, no temperature displayed, only via reports in the new Smartthings App. Any idea???

1 Like

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.