[RELEASE] Sonoff, Sonoff TH, S20, Dual, 4CH, POW, & Touch Device Handler & SmartApp ($5 & $10 Smart Switches)

I’m have been using successfully ESP8266Flasher in DOUT mode. Now with your updated firmware Shelly keeps constantly clicking the relay and WLAN AP not visible. Expecting that Shelly is rebooting, but not able to verify that

Since the last week, no Sonoff switch has been refreshing the status. I turn on the light and only after 30 minutes the status of the light on the Smartthings changes. Also, the temperature on the TH switch and power on the POW switch are refreshed for half an hour. IP on hub is 192.168.1.161 (static IP)!. I did the reboot switches - nothing helps. If I press refresh in the application, the status is fixed. I also made the update DH and smartapp.
What could be wrong?


pow

The hostname and uptime report interval look weird on the bottom switch. I don’t think that is the problem, just an observation.

I’d try rebooting your router and SmartThings hub.

Hello, eyerytime if i update my WLAN-FW, the TH-16, Dual & Touch doesn’t reconnect. After power off/on, all works fine. Today i update via OTA the Dual with the new FW from github, https://github.com/erocm123/SmartThingsPublic/tree/master/devicetypes/erocm123/sonoff-dual-wifi-switch.src.

The update works fine, i have access to the web-interface of the dual, but i have problems with the relais. The interface show me, that i toggle on or off, but the relais doesn’t work. Any ideas why?

THX
Michael

update,
just flash back with an older version from 2018, all works fine.
@erocm1231 Eric, is there a bug in the FW

greetings
Michael

I flashed a TH16 and everything went well. I used ESP Easy and it said it was successful. Unfortunately, the device will no longer power up. Any ideas?

So i’m trying to use the sonoff with my dimmer and having a ton of issues… If i place it between the dimmer and the light it will only power up if the dimmer is on high.

I found the manual for my dimmer on Lutron’s website showing it used with a manual switch. i swapped the switch with a sonoff in the diagram… will this work?

I can only add the devices manually, am I doing something wrong? (I get the screen on the arm with no fields to fill)

“Curiosity”
I flashed 3 SonOffS20 devices just had to set up the wifi passorwd in the first, lol? because? how did others connect to the wifi network by themselves?

Hi Everyone,

Having some issues with my Sonoff Basics, some help would be appreciated.

I have flashed a number of Sonoff Basics successfully using Tasmota 6.5 direct from github as i’m using a mac.

I’m able to access the configuration within the browser on my desired network, I can also turn it on and off within the browser.

I am unable to detect them when trying to discover them.

I have also tried to add them manually but smartthings doesn’t seem to be connecting to the devices correctly as the app reads Turningoff for a long period of time without the state of the switch changing.

One weird thing I do have going on is that the LED lights on all the devices continually blink even though i can connect to them on my home network.

Please let me know what I could try next to get these working.

Problem Solved

Using this recently published tutorial on youtube I flashed the Sonoff’s with the binary published in this project on Mac OS.

The process is simpler than other methods and final outcome works as described.

1 Like

Hi All,

I’m new in Smartthings and Sonoff. I avoid doing shoulder on the sonoff (to flash).

I am now renovating my house and is trying to wall switch wire up the whole house. My logic is mostly in webcore. And so i narrow down to using Sonoff T1 wall switch as the best option (as i am trying not put a non-smart wall switch then connect to sonoff basic which can prevent the smart switch to stop working if the wall switch is switched off).

And i am trying to have link up more services e.g Google Home, IFTTT so that the whole ecosystem is complete.

But the question will be, am i able to add this Sonoff into Smartthing so that i can also controll the switch via Google Home and IFTTT. I really hate to shoulder.

any kind souls out there have some better idea for me? Thanks in advance!!

erocm1231,

I installed the firmware “https://github.com/erocm123/SmartThingsPublic/raw/master/devicetypes/erocm123/sonoff-wifi-switch.src/Sonoff.ino.generic.bin”.
The device normally operates through Smartthings, on, off. But the pulse button works sometimes 10 consecutive times ok, once you need 2, 3 clicks to turn off or on. Any suggestion?

You might want to try messing with the “debounce” setting. The default is 20 and lowering it may make it more responsive.

@Anthony_Persichini It seems like your circuit is not providing 120V to the Sonoff unless the dimmer is turned up all the way which makes me think that it is not going to work.

@erocm1231

I see you have the sonoffTouch firmware and that works great for the single touch switch. What can I do for the 2 and 3 switch sonoff touch? Do you have support for these? I tried the sonoffDual firmware however that does not work

1 Like

I’ve heard of people using the 4ch firmware and just disabling the extra channels in SmartThings.

Hi all, I just flashed the Sonoff TH10 and that went well. The device is responding to on/off commands in Smartthings, but no temperature or humidity values are showing. The AM2301 sensor is plugged in (all the way) and I’ve tried several reboots. Here are a couple screen shots:

Any suggestions for what I might try? Thank you!

1 Like

Has anyone ever tried this flash this new Sonoff switch - SONOFF MINI?
03_2

https://www.itead.cc/smart-home/sonoff-mini.html

2 Likes

I was looking at those as well. They look really promising.

Hi having some problems with some of my sonoff wifi switc.manage to install all of them (around 20) in the house but some keep on showing unavailable. if I turnn them off and on they eventualy connect to the hub and show available. but affter a while either the same sonofwifi switch or another shows unavailable. Any reason?

Everyone,

Is it possible to change the GPIO allocation in the firmware? Or is there an open source firmware @erocm1231 to do this?

I’d love to be able to use the ESP-03 8266 and use the 4CH Sonoff firmware to Control GPIO 15, 14, 13, 12.

It looks like the GPIO allocation on the 4ch Sonoff is GPIO4, 5, 12, 15.

Please let me know regarding this as the ESP-03 will be the perfect candidate for my project.

Thanks

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.