[RELEASE] Sonoff, Sonoff TH, S20, Dual, 4CH, POW, & Touch Device Handler & SmartApp ($5 & $10 Smart Switches)

dth_lighting

(Mitchell Elwell) #1788

I’ve poked around quite a bit and haven’t seen anything to change, I’m sure its my lack of experience/knowledge. Should I be looking in the switch settings via the IDE?

EDIT: completely ignore what I just said! had no idea you could access settings from the switches IP!! this has immediately become perfect for my set up will share immensely! thank you! @erocm1231 !!!


(Nathan Beiley) #1789

Just wanted to know if there was any chance on getting a firmware that can match these GPIO pinouts.

GPIO12 – LED (0 = On, 1 = Off)
GPIO13 – Button (0 = On, 1 = Off)
GPIO15 – Relay
GPIO01 – RXD
GPIO03 – TXD

Thanks again,
Nathan


(Ken Dickson) #1790

I’m new to the forums. I may have replied to the wrong post. I broke the button on my Sonoff basic. I used a thin narrow stainless steel pocket ruler to short the two pins closest to the 5 header pin holes. That worked great for me to get mine in program mode.


(Cristian) #1791

Guys,

Any way to make this Device Handler work with the new samsung app?. I can toggle the lights on and Off but the status wont change (Looks like it is not refreshing it in the main window).

Thnks


(Eric M) #1792

Does anyone know if Samsung has released documentation on getting custom device handlers to work on the new app? I know some forum members have discovered adding the “vid”, but I’m wondering if there is anything official.

I recommend sticking with the classic app until Samsung releases that documentation.


(Dave) #1793

Does Tasmota do local processing ?


(Kevin Taylor) #1794

I wish I would have the same success as others, but no, not so much.

I have several new Sonoff Basics (Sonoff RF R2 Power) with the 8285 chip. I think I have the latest NODEMCU 64 bit, but its hard to tell as there is no version number. I grabbed the latest Sonoff.ino.generic.bin and tried to flash (baud 115200, size 1MB, speed 40 MHz and mode DOUT). Voltage is 3.3, rx -> tx and tx-> rx and this is all I see in the log …
Note:Detect serial port changed.
Note:Auto MAP serial port.Port–>COM6

Note:Serial port connected.
Note:Begin find ESP8266.

I have tried an FTDI232 and a CP2102 adapter, but no joy with either.

Doing this on a 64 but version of Windows 7. Is that the issue?

Love any help I can get, other wise, I bought a lot of junk for no payoff :frowning:

/Disgruntled


(Kevin Taylor) #1795

Took the time later today to move all to a Windows 10 PC (I was questioning the drivers installed on Win7). It made no difference.

It seems that the nodemcu program can’t find the 8285 on the new Sonoff Basic. Is the because the FTDI232 is bad? Not sure how to test it!?!


(Albert Santiago) #1796

I flashed mine at 8 MBytes, just checked my settings to make sure, I also use windows 10 64, so thats not your issue. you holding the button down when you plug in the FTDI232 ?


(Kevin Taylor) #1797

If you mean am I holding the button on the sonoff down to put it into program mode when it Powers up and the answer is … yes, I am.

I selected this model because of a recommendation by Drew Taylor, of TaylorTech on YouTube. Is there any way to tell if the ftdi232 is good or bad? Any way to test it

Regards,

Kevin


#1798

Make sure you run nodemcu as administrator. I had the same problem and that was the solution for it. it might still take you a few tries, but that should get it working.


#1799

Thanks @erocm1231, took a while to get there but i’ve now got 2 Sonoff RF R2 V1.0 working and running through smartthings.

Mistakes i made:

  1. Check joints and pins onto board, mine where not the best.
  2. Get RX and TX the right way round… Duh!
  3. Once flashed don’t forget to hold down button for 10 seconds to get wifi to show up (Took about 30 secs)

Thanks again for your hard work!


(Nathan Beiley) #1800

First off, I know just enough to make me dangerous.

I was trying to build my own ecoplug.bin with the following:

#if defined ECOPLUG
#define REL_PIN1 15
#define LED_PIN1 0
#define KEY_PIN1 13
#define EXT_PIN 14
#endif

YAY, I serial flashed a NodeMCU first with no problems!.
Then I successfully OTA flashed a .bin I created to NodeMCU, with no problems.
BUT when I OTA bin flashed my generic ESP8266 plug, I bricked it.

I’m guessing I don’t have the flash setting (Flash size, mode, Erase…) right when exporting to binary? (I also tried Erase: everything, which kinda worked, as button toggles relay, but it didn’t connect to AP, so I’m unable to use that plug too.)

BTW, the .bin files created here OTA flashes fine.
I really don’t want to brick another plug.

It would be GREAT if someone could build a generic.bin that would allow you to set REL, LED, KEY and EXT PINs via web.:pray:

Any help would be appreciated
Thanks.
Nathan


(Amin) #1802

Hi Eric,
The Sonoff Th in ST app after the new update is crashing, is it known issue?
Thanks


(Eric M) #1803

Seems to be working fine for me.