SmartThings Community

[RELEASE] Sonoff, Sonoff TH, S20, Dual, 4CH, POW, & Touch Device Handler & SmartApp ($5 & $10 Smart Switches)


(Mike Harvey) #1667

I originally got a TH for my daughters radiator cover. I have put an LED light strip in it along with a calming lavender smelly plug in. We use that as a night light for her and the air freshener comes on as well but it will also come on in the day if the radiator is hot so she can see it is on.

Unfortunately, that just wouldn’t work with the stock TH as the timers and the temp auto switch don’t work well together, hence why I went down the route of this dth and firmware. now it all works well! Thank you again @erocm1231!

After that, I just decided that any I now buy will also be TH’s as you have that bit more functionality and the price difference is next to nothing.

(Steve ) #1668

looks great that nice idea with the LED’s
My SonoffTH has been so temperamental the humidity always seems to be stuck at about 90-99% even though the my old probes measure totally different and thats the same with other sensors ive tried.
yesterday it only shown one report for humidity in the recently tab all day for some reason.

(Ocelotl) #1669

Does anyone have the compiled bin file for the Shelly1? I tried compiling it but doesn’t appear to work. It is asking me for a password and the SSID is called SHELLY when its supposed to be SONOFF


(Duy Hoàng) #1670

can you add “Boot Up State” on config? ( I’m used sonoff-tasmota.groovy)

(Ben) #1671

Boot up state is located under advanced config

(Barry Murphy) #1672

Anyone have issues with their devices not being configurable (state change etc) via SmartThings, but works fine by going directly to the IP address of the device and using relay control? It has a static IP and is in Smartthings and works fine after a reboot of the device, but after some time stops working

(Barry Murphy) #1673

This is what shows in sonoff debug

12:09:24 PM: debug Device data: ( - reporting data: (
12:09:22 PM: debug Device data: ( - reporting data: (
12:09:22 PM: debug Device data: ( - reporting data: (

You can see the device with a fault reporting with when it should be I have tried to statically set the IP address of the device though this didn’t fix it, the only fix is to hard reset the device

12:15:40 PM: debug Device data ( does not match what it is reporting( Attempting to update.
12:15:40 PM: debug Device data: ( - reporting data: (

After reboot, i get standard expected results
12:20:45 PM: debug Device data: ( - reporting data: (

(Chris) #1674

Has anyone been successful with getting the Sonoff Dual R2 working with this firmware? I can get it to flash successfully, can see it in Smartthings but it doesn’t actually fire the relays. I threw on Tasmota firmware and had it working as intended in about 5 minutes.

(Eric M) #1675

Do you have the latest SmartApp? To be honest, this just started popping up with people over the last couple of months. Maybe SmartThings changed something since it has been working great for over 2 years. I added code in the SmartApp to ignore when a address is sent from the device, but since none of my devices do it, I can’t test it.

(Mike Harvey) #1676

Have you updated the smartapp code? I had this but since the latest update it all works great again.

(Robert) #1677

I have the same problem and did the same things you did. What device handler did you use. I can only use one relay.

(Ian Bruce) #1678

Hi Qiusj

Did you ever get the 2 and 3 gang to work??



(ToyzRUsKid1976) #1679

This has to be the coolest thing I have ever seen!!! I just purchased a nearly 100 year old home and it has a boiler & radiators (Which is very uncommon in the US). So many questions I could ask, but I’ll keep it simple. Did you build your radiator box? I LOVE the idea of it lighting up when it’s hot. Genius! I’m in the process of adopting and had wondered if I would have issues with my exposed radiators. The agency honestly didn’t know how to respond because… who has radiators in the US lol
Thanks for sharing the picture!

(Mike Harvey) #1680

Thank you. Because I am in the UK most houses here do have radiators, because of this it’s very easy to find radiator covers. This one was from a hardware store. You just get them as a flat-pack kit in a size to suit your radiator and build it and paint it yourself. I think it cost £50 as bare MDF to paint at home.
There are online companies that make them to measure but they are generally 4 times the price.

(Dan Miles) #1681

I’m having the same problem. My IP’s are static so need dynamic detection of the IP’s. Is there a way to turn this off to avoid the problem?

(Eric M) #1682

Do you have the latest SmartApp? I added a checking method but haven’t tested it in practice because my devices don’t do it.

There is a line of code you can comment out, but I’d rather check to see if the checking is working.

Also, did you compile the firmware yourself or did you use the one in Github?

(Mike Harvey) #1683

I have been using the new smartapp and it appears to be working brilliantly. I was getting the problem a couple of times a day or more but since the new app it has been perfect.

(Killer23d) #1684

Starting from a couple days ago, my Sonoff basic switch is turning off by itself. I’ve tried unplugging and checking the logs, even disconnect it from wifi… It seems the issue is the switch is turning off by on its own, and I can always turn it back on with either the physical button or with ST.

I am using the latest firmware and smart app from erocm123, I wonder what could be wrong? I have a few of these at home and this is the only one that is causing problem? Should I write this switch off?

(Mike Harvey) #1685

Stupid question, have you checked to see if the auto off has somehow been turned on? Do they seem to turn themselves off after the same time period?

(Killer23d) #1686

I was suspecting it was ghost switching due to the poorly insulated Sonoff and I was right.

I disabled the physical button by changing the external device type to “disabled” and the random shut off stopped.

Since it is tucked under my couch and I don’t need that button anyways, I changed to boot up state to “On”, so if my internet is ever down, I just have to power cycle the switch.