[RELEASE] Sonoff, Sonoff TH, S20, Dual, 4CH, POW, & Touch Device Handler & SmartApp ($5 & $10 Smart Switches)

dth_lighting

(Adas4190) #1504

Hi. Could any1 please help me as my sonoff th16 recently being unresponsive on smartthings. Is there any fix? Anyone having similar issue? Thank You


#1505

I successfully connected Sonoff POW.
But it shows a lot of voltage. I am from the EU and I have set a 240V.
Is there a solution for that?


#1506

My error- I did not reboot the device - it now correctly displays the data.
However, I have problems with on / off. The device is not responsive to the on / off command.on_off


#1507

Actually I believe they are pretty smart and hit both communities of folks not flashing and folks flashing. For instance the S31 modules. I recently flashing 2 of these for some home automations for the washer and dryer based on energy usage. They could have glued these devices together but they went out of their way and made them easy to open and flash. Down to even labeling the pads for flashing. There aren’t any holes, just pads but it was pretty simple to throw some wires in to a male header and tape it to the board for flashing. I could have soldered it then unsoldered but a piece a tape holding it for the few minutes to flash was easiest.

Seems like it would be easily adaptable with the firmware sketch provided in this thread. I had it running with the MQTT control for a bit and never had touched any Arduino IDE code until around the time I got into the Sonoff’s, it wasn’t too hard to learn and get going. I’m sure someone can adapt the code and take over the project here that is a ST user. The hard work is already done.

I would do it as I do enjoy the ESP8266 programming now due to the challenge of it but I can’t buy all the necessary Sonoff’s to be dedicated for testing purposes and don’t have a SmartThings hub anymore as I moved over to Homeassistant 100%.


#1508

OOps, i flashed tasmota, poor response in smartthings, flashed my TH16 back to Eric’s firmware, now smartthings won’t control it. I;'m guessing there is a “piece” of tasmota code left over. Anyone know how to fully flash back to default sonoff, so i can start over?
TIA


(Sylvain) #1509

Did you flash it with the web interface ? i Would try to flash with nodemcu, maybe !!


#1510

Thank You Sylvain, I discovered that it is a bad idea to have 3 concurrent projects. I was creating a vlan for my IOT devices, and DUH I had the wrong IP assigned to the TH16.

All is well, and yes I only use NodeMCU, as espeasy never works for me.
Switch works well but data from the am2031 temp/humidity sensor is not showing and i was wondering if anyone has had sensor report properly


(Maz) #1511

Anyone having issues with firmware?
Just noticed they are updated recently by @erocm1231 .
A couple of my newer sonoffs are not functioning as intended with the new firmware.
Tried flashing the old firmware now the web interface works as before but unable to control via app.


#1512

The two chips are basically the same with the ESP8285 having 1MB of built-in flash memory.


(Maz) #1513

Need some help with adding external switches to the 4ch Sonoff V 2,0 (non Pro)
Will appreciate if someone could clarify where wires should be soldered for the relay switches.


(CS Goh) #1514

HI. I did mine by soldering all the wires at the back of the board. These is what i have done

  1. Solder a wire for GND to the GND terminal
  2. Solder 4 wires with each one to IO14, IO10, IO9, and E-FW-IO0

It worked but somehow, with long wires and put into real use, at times there are interference which causes the relay to on/off. Very seldom but it happened where the sonoff unit itself need to be reconfigured to connect to the wifi.


(Maz) #1515

Cheers for the info mate. Will be testing this today.
Also i am aware that sonoff devices sometimes tend to react to interference when wires are attached (got a few sonoff basics misbehaving).
Have you had any interference experience and possibly solutions to rectify this, perhaps by adding resistors and capacitors.

Update: I tested the GND + IO14, IO10, IO9, and E-FW-IO0 for physical switching, works like a charm Thanks, however the device handler in SmartThings (classic app) dose not update the status when switched / toggled externally. Any workarounds for this?


(Barry Murphy) #1516

Just wondering if there will be an update for the Sonoff POW R2, power on/off works fine, just can’t get any useful data from it such as voltage, load etc, just sends 0 values


(CS Goh) #1517

For the basic, I added both the resistor and also capacitor which for the most part solved the interference issue. Try that. I believe the diagram is up in this forum somewhere. You can also do a Google search on sonoff basic diagram capacitor… It’s a hand drawn diagram for the connections.
On the update to smartthings, mine updates fine. Try checking it you have the HA IP configuration on the advanced page keyed in correctly as in it is the IP of hour smarrthings hub.


(Devesh Batra) #1518

looking to get couple of 4CH units to make power strips for my Home Media servers and Cable Modem / Switches to reboot them without walking to the basement (cheap WattBox alternative). None of the devices i have draw over 2A

Can these devices return to ON state when power is restored or can it be configured to do so ?

Also has anyone flashed a WiFi power strip with this firmware ?

thanks


(Blake Northrup) #1519

This flashing method seems to no longer work. Is there an updated way to do this from a PC?


(Maz) #1520

Thank you for the valuable input mate.
It turned out exactly as you pinpointed.
The hub IP was missing for some odd reason.
Software control is working flawless now with external switches.

I think I know roughly what i should be doing with the interference issue.
I plan to use 5k resistors but still researching on the capacitors maybe 40uF.

Thanks again for your help.


(CS Goh) #1521

Great! If you can resolve the 4CH on the interference, do share the solution. I tried with both capacitors and resistors on the 4CH but couldn’t get it to work.


(Dek Fortyyet) #1522

I flashed (with Sonoff 4ch) it using esp and nodemcu, both baudrate 78880, entering flash mode with press on Touch button and hitting reset immediately.

I could control 4 individual channels ok via web, but smarthings integration seem broken since I cannot see the child devices even though I’ve installed the most current DH and child devices.

Did a lot of reading and others are able to see the 4 child devices using the 4ch firmware but no go for me. Hope hope erocm123 sees this.

Hope it helps a little.

Thanks.


(Dek Fortyyet) #1523

Hi, I have a US T1 US and it flashes (sonoff 4ch) good with Nodemcu and esp but couldn’t get smarthings to see the child devices, main device is there but no childs, the 3 touch controls ok via web and could turn on and off in harmony via smarthings but not individually. can you share how you’re able to see your child devices?.

Thanks.
dk