[RELEASE] Sonoff, Sonoff TH, S20, Dual, 4CH, POW, & Touch Device Handler & SmartApp ($5 & $10 Smart Switches)

dth_lighting

(Piotr Taraś) #1421

@digiblur Do you mean 1.20 or 2.0? Because I’ve tested both - without positive result.


#1422

More than just the version, I don’t even recognize those screens as the correct firmware for this project. Make sure you use the firmware off of the OP’s github.

https://github.com/erocm123/SmartThingsPublic/raw/master/devicetypes/erocm123/sonoff-wifi-switch.src/Sonoff.ino.generic.bin


#1423

Spoke too soon. Still having the odd random network dropping. Cant re-establish connection without rebooting device. Anyone else have switches dropping network with this firmware. Driving me mad. Any help appreciated!


#1424

Thanks Digiblur, I wish I had those skills. I did see other ESP easy frimware that supports the si7021,however I don’t think it would work with smartthings. If I understand correctly Eric modified the esp firmware to be compatible with smartthings, and as far as I can tell Eric did not release the source code.

Thank You


#1425

I have 2 sonoff basic and 1 sonoff TH16, all are solid over the last 5 days. I used the firmware from the OP above and flashed with nodemcu, also from above. All switches are within 10 ft from my router(R7000 flashed with asusmerlin.

I use Net Analyzer android app to do site surveys and to check for interefence and set optimal wifi channel.
The wifi “antenna” on these switches is small, not sure I’d expect great range, but nonetheless you shouldn’t have to reboot to establish connectivity.
I’d reflash one of your switches and for testing purposes, leave switch near your router and see how long it can remain connected without issue.
Good Luck


#1426

Actually he did release the source code. He didn’t modify the ESPEasy source code, he more of built it from the ground up. I dug all through it when I was adding in the MQTT support I wanted while I was running my ST hub and Homeassistant.

I probably wouldn’t be too hard to add this sensor in but I don’t have one to test. Which Sonoff and exact sensor do you have?


(Piotr Taraś) #1427

I missed the dedicated firmware and had tried to connect ST with standard EasyESP. So great point @digiblur. Unfortunately it seems that I have new Sonoff Basic with 8265 module, so only flashing non-compile packages through Arduino IDE works for me. I tried flashing Eric’s firmware Sonoff.ino.generic.bin in many ways - tried esptool.exe, tried NodeMCU - always succesfull flashing but never with succesfull establishing ‘Sonoff’ SSID. I also tried to flash Sonoff.ino.generic.bin throught OTA over standard EasyESP R120 but with the same output (succesfull flashing, no SSID)
Do you know is there non-compiled version of the software to compile it with Arduino IDE using ESP8265 libraries?


#1428

Did you use the DOUT method to flash? Yes, the OP posted the source back in March in this thread.


#1429

Cheers. So it’s just my devices it seems. I was using all these switches with sonoff factory firmware and no drops at all. Some are very close (5 foot) from router and still drop. I think I may be on to something this time. I disabled “packet aggregation” on my router and have not dropped one since this morn. I know it’s not devices as from trying to diagnose if I log onto router make a small change to WiFi and force a router WiFi restart all devices come back online. It proves the sonoff code was still working and attempting WiFi retry all along and not just crashed. I’ll get it in sure but so annoying as can’t really rely on them. Thanks again Rxich


#1430

Hi all, I have successfully flashed some basic sonoff devices and have not had any problems with them. I used the smartthings classic iphone app and was able to control the switch. However, i believe samsung is currently migrating to the new smartthings app on the iphone. I was able to control all other devices in my home on the new app except for the sonoff switches. Any guidance would be appreciated.


(Peter Schultze) #1431

I can confirm that I can control my sonoff devices on the classic app but not on the new one on Android.
Are folks having a good experience with the 2 and 3 button switches?
If I was able to have success flashing the Basic should the 2 and 3 button switches also be fairly straightforward (I had to use the uppermost method dout nodemcu etc).
John - were you able to get it going? I had reached out by PM to try and help but maybe I’m too much of a noob to be that useful.


(Max Hammond) #1432

Hi

Did you get to flash this and integrate to ST? How did you get it in to program mode?


#1433

Still constantly dropping. Downgraded my Asus router firmware and can’t keep them online as client. Constantly need rebooting. They are solid when on sonoff factory firmware 1.5 and 1.6. is there any parameters I can change on WiFi service to maybe keep them up


#1434

Left with 12 useless switches I’m afraid now. I went on ahead an flashed them all. Problem didn’t come for a few hours :-(. Does the tasmota firmware integrate as nice into smarthings. I will have to try something else as putting the sonoff original ain’t an option now ;-). Or does anyone have the binary for that. Hate to have to go back to their unreliable servers although I didn’t need reboot every few hours was every few months with ewekink. Anyone have experience with tasmota and how well does it work in ST hub


#1435

Bridged and old WiFi router through lan and have them all on that. One hour now and looks good. Asus router is supposed to be a good reliable router but found similar issues when having multiple esps on network from other threads online. Fingers crossed


#1436

I have a couple of basics running tasmota because they kept ghost switching with this firmware, even after adding a resistor. Tasmota doesn’t seem to have that issue. It works ok with Smartthings. The developer for the device handlers hasn’t quite got tasmota to report back to smartthings when the switch is toggled locally with the button. You have to manually refresh to get it show it’s status correctly in smartthings. If switched from within smartthings it reports fine.


(GASPAR DE ELIAS) #1437

Hi all, I managed to flash 15 wall switches at home. They were all setup properly and working for about 3 weeks. Suddenly all sonoff devices show up as unavailable. Strange. So I rebooted the smartthings router and now sonoff devices show up properly, but they don’t turn on or off, and they don’t show the current state… I’d hate to remove all the wall switches and flash them again with some other firmware like tasmota or espeasy… Any ideas. Any known issues I should be aware of? Thanks guys. I’m disappointed since this was working flawlessly for 3 weeks. Now all fail.


(Max Tay) #1438

When flashing, there is a message “wifi required” pop-up in the flashing program. What did I miss?


#1439

Cheers.
Yeah I had some hassle trying out tasmota device handler in smartthings. Seem to have got things going. It is my Asus router causing the prob. I have tuned wiif every possible way. Still dropping them. Went to a cheap router and boom. Not a single one dropped in 24 hours. I have 14 devices on it. I will run a second network for my smartthings. Seems to be better


#1440

What switches / keypads can one use to trigger a scene or a single Sonoff Device with ST