[RELEASE] Sonoff, Sonoff TH, S20, Dual, 4CH, POW, & Touch Device Handler & SmartApp ($5 & $10 Smart Switches)

dth_lighting

(Ms30250) #1400

Resolved this by changing the devices ip and readding it


(Sebastian) #1401

@erocm1231 and everyone

Finally managed to setup two Sonoff basic devices, tried forever with ESPeasy and the wifi ap didn’t show, tried with NodeMCU and it worked on the first try!!

Thanks everyone for your inputs and Eric, great job on the handler and the implementation.

Two Sonoff devices working fine and responding in 700-1200ms, awesome! Now to order the 8x pack, bye bye lunch money…


(Dave) #1403

Till date I have been able to flash only one basic. Rest of them gives espcomm failures. I have tried multiple FTDI usb adapters. I have probably tried every means of flashing, except ESP8266Flasher which i didn’t know till day before. Anyone who is proficient in flashing should open a side business of selling flashed Sonoff for $5 extra. I am sure there will be many takers :smiley:

Even though a little more expensive, I am considering buying smart outlets instead. All I need is on and off functionality anyway, for now.


#1404

I have two TH16 devices which turn on and off flawlessly, but the temperatures and humidity readings only occur every few days or so. Are you getting consistent updates?


(Vince Lowe) #1405

All worked great for me using the new sonoff basics

used this ftdi - https://www.ebay.co.uk/itm/USB-To-TTL-FT232RL-FTDI-Serial-Adapter-Converter-Module-For-Arduino-3-3V-5V-Mini/222727769676?ssPageName=STRK%3AMEBIDX%3AIT&_trksid=p2060353.m2749.l2649

flashed with - https://github.com/nodemcu/nodemcu-flasher

thanks for this!


#1406

I too struggled with things at first since I was using the wrong method and wasn’t using DOUT, once I found the NodeMCU flasher and the right settings it took minutes. I later ordered a 6 pack and flashed all 6 in minutes after making up a small header I could just insert into the holes and not have to solder anything. Take a step back and start some process of elimination, such as the USB port, cable, computer, software, settings etc changing/checking one thing at a time to figure things out. It does indeed work and very easy to flash once you get the right setup. I myself could never go back to some switches that are controlled by someone elses server especially when they cost so much more.


(Dave) #1407

Can you tell me what was your firmware version ? Was it 1.6.0 ?

My frustration is I have been able to flash one using Arduino IDE 1.8.5, and it works great. I am using the same settings , including DOUT, upload 1115200, and I still get the error. Once you set up a correct sketch, you should be able to use it over and over and over.


#1408

Firmware version of 1.6.0 on what?


#1409

Hi I was wondering if there was a fix for this issue. After flashing my switches work perfectly. Have both basics and S20 type. They seem to drop off the netoelrk randomly. My wifi is channel 6 with no interference. Has anyone experienced it. Happens nearly all them after a few hours to a day. Seems to be more prone if I send multiple switches a command at same time from stringify. Is there benefit in using static IP. Anyone else had issues with this firmware and dropping from host. Any help appreciated. I love the firmware and how it integrates with ST but at the moment it’s not reliable enough as a router or switch reboot is necessary each time.


#1410

I just flashed my TH16 and it works great. I can’t get the temp to read other than -196.6. I loaded Eric’s DH (million thanks Eric !!) but failed to notice my included temp sensor(Si7021 ) is not listed in the DH options, otherwise I’d have bought one of the listed temp sensors.

Anyone successful at getting Si7021 to report temp correctly or know how to adjust the DH to fix temp?

Thanks


#1411

Meant to send this last week. Here is what I ended up doing. Still let’s the wire connector go on. Unfortunately it didn’t seem too make make a whole lot of difference. I went back to tasmota on two of them because they were telling all the time. No problems at all with it.


(Piotr Taraś) #1412

Hi everyone. Thanks @erocm1231 for development. I’ve managed to flash two Sonoff Basic with ESPEasy (R1.20 and R2.0) and I’m able to access devices with esp config, so I guess there is no problem on my wifi settings side. Than I tried to add them automatically with SmartApp, but after 15 minutes nothing was found, so I added them manually. Unfortunately, after manual adding, there is no responce and devices remain unconfigured. First I tried ESP Easy R2.0 Mega and than R1.20. In both cases flashing was succesfull (I was able to establish for example rules in configuration site). This is what I receieve in Smartthings IDE. Anyone has a clue what may be the reason for not responding from devices side?


(Dave) #1413

Similar thing happened to me when I changed IP of the device in my router settings but forgot to update it for the device in the app.


(Piotr Taraś) #1414

In my case IPs are correct: same in the app as in the network


#1415

Think I may have solved my issue to random wifi dropping. Sonoffs were dropping even when given static addresses. The issue seemed to be when the router gave a new key to WPA2 when the group key rotation interval timer had expired. I stopped key rotation and the issue went away. Having group key rotation is supposed to offer better security on Wireless network but Im not to worried. Rather have m smart devices reliable and not constantly needing power cycle. Anyone else had issues with sonoffs dropping as a client and not reestablishing connection. If so try this. Not sure there would be a fix in firmware possible?


(Max Tay) #1416

Would the 4 Ch DH and Sonoff (Connect) works on the Sonoff 3 gang touch switch? Do I have to remove the 4th relay on the DH?


(James Scholes) #1417

There are several people who’d be very interested in the answer to your question! I don’t believe anyone’s tried it yet, so at the moment the answer is “maybe”. I know a couple of other Sonoff firmware projects that use the same code for the 4ch and the T1 2- and 3- button models, but haven’t dug into the code to see if there are any changes.

If the firmware works, you shouldn’t have to do anything with the 4th relay except ignore it.


(Max Tay) #1418

Would be great if you could point me to the project(s) on the 3 button model. I really want to test it out on the wifi switch.


#1419

That doesn’t appear to be the right firmware on your device.


#1420

You’d probably need to roll your own firmware. The source is available and throw in the library to the sensor you need.