[RELEASE] Sonoff, Sonoff TH, S20, Dual, 4CH, POW, & Touch Device Handler & SmartApp ($5 & $10 Smart Switches)

dth_lighting

(Jon Turnbull) #1380

BT smarthub latest one

I tried last night and couldnt seem to see it in the router couldnt work out which one it was so plan to reflash tonight and try and note maybe mac address or something so I can try and find it.
It could be possible that it hasnt correctly adde to my network for somereason hence not being able to see it

Thanks

can I also ask…

to connect to wifi I put the sonoff back together and wired it to a plug and plugged in.
Is it better to just keep VCC and ground attached ie rmoving the other two jumpers and then configure wifi?


#1381

@rreims you have to have different GPIO pins for the switches though but they are pretty close. You might try the ESP Easy firmware. I think that’s the one that lets you configure what pins do what, you can figure out what pins each switch is on. Should be easy to modify this firmware for it once you get that data.


#1382

@Jon_Turnbull

Every router is different but I believe once you can figure out your network layout you’ll be off and running. There are several apps, I think Fing is one that comes off the top of my head that you can use on a phone to determine IP addresses of things on the network. You’ll also need to setup a static DHCP reservation for your SmartThings hub anyways.


(Jon Turnbull) #1383

By static DHCP for the hub do you simply mean a static ip for the Hub


#1384

Something like this… you’ll need to consult your router manual and adapt a bit.


#1385

Thank you so much for the tips! Just ordered some resistors. Looks like I’ll be pulling some switches out of the wall this weekend.


#1386

Will be doing the same myself. I will post some pics of it as well.


#1387

Fixed the one I did without a resistor. Simple way I’ve found of doing it that doesn’t get in the way of flashing or anything in the future. Looking at doing another one with 2 buttons on the wall and using the GPIO pins from the serial communication.


(Ms30250) #1388

Been trying to get this this Sonoff TH16 to work properly for 2 days straight. I have had numerous issues with getting it flashed. At this point i am able to flash it with esptool but only the tasmota firmware seems to work. When I flash SonoffTH.ino.generic.bin its successful but no leds flash and i dont see it as an AP (even after pressing the button 4 times)… HELP


#1389

Try holding the button down for 15 seconds or so. You flashing using the DOUT method? Sounds like some of the same issues we were talking about a few posts up.


#1390

Updated and pushed the firmware and source changes in case anyone wants to change stuff, etc.


(Ms30250) #1391

When you say hold the button down for 15 seconds do you mean after the flash and it has been connected to AC power?


#1392

Hold down during reset to flash. Once it flashes cycle the power on it. Wait a 5 to 10 seconds. Hold down the button for 15 seconds or so. Wait a bit and see if a AP appears.


(Ms30250) #1393

I just got the Sonoff.ino.generic.bin t flash and everything seemed to work but the smartapp kept crashing after finding the device. If I flash SonoffTH.ino.generic.bin (which is what the device is) I get no lights/web interface or AP. Why does one work and not the other?


(Ms30250) #1394

Used nodemcu programmer and slowed it down to 74880. TH version loaded and running!!!


(Ms30250) #1395

Everything seems to be working kind of. The temperature and humidity wont update and the “configure” button stay orange. Like the sonoff connect app isnt talking to the device.


(Jon Turnbull) #1396

I will try that slowing it down tonight been doing my head in have tried and tried

Worth another shot I guess

cheers


(Dave) #1397

Since yesterday I am unable to use my sonoff basic from ST. I can see the device in my network. I can turn the switch on and off from Tasmota configuration page but cannot trigger it from the app. It always shows on, no matter what I do. I have tried dropping and recreating device as well as rebooting the hub.


#1398

hi Eric and the Sonoff gang here

just got my POW today and i wanna flash the firmware
should i use the sonoff.ino.generic.bin or the sonoffTH.ino.generic.bin?

for the DH, shld i use the TH or the POW version?


(Ms30250) #1399

Mine was acting goofy after I finally got it up and going. I ended up uninstalling the handler and app then changing the devices ip. When I reinstalled handler and app it was fine.