[RELEASE] Sonoff, Sonoff TH, S20, Dual, 4CH, POW, & Touch Device Handler & SmartApp ($5 & $10 Smart Switches)

@erocm1231

Mine is showing a different date with the same version, maybe I’ll download the firmware again from your GitHub.

{“version”:“2.0.3”, “date”:“Mar 17 2017 09:01:37”, “mac”:“5ccf7f973ebe”}

EDIT: I think the ver on your github is of March 17 only.

Hi,

I am thinking to get the Sonoff POW for testing
Does anyone could share the Sonoff POW report example?

thanks

Rookie mistake… I didn’t catch the part about the FTDI adapter, now I have to wait two more days… argh :rage:

The main part didn’t take long to arrive… approx 8 days.

Yay! Looking forward.

I uploaded a firmware today that should have the external switch working for either the momentary or toggle configuration. Try it out and let me know. I tested it pretty thouroughly and I didn’t have any problems.

I made a tutorial aiming to help the general public who doesn’t have a lot of experience in this field. (from experience) I hope this helps some people make the plunge or lessen the intimidation factor. @erocm1231

@jakclark if only I uploaded this a few days sooner

@eibyer hopefully this will help :hugs:

7 Likes

Eric, thanks again and again. It works like a charm.

does it support wink hub 2?

No.this is a custom device handler for ST. You can’t make custom device handlers for wink. Also, these use http to communicate. Wink can’t do that

1 Like

Hi, on your video when you open the ESPeasy_R120 file there is a bin file for arduino that is not present when downloading from Eric Github.
Where is that bin file from?
I have tried to flash just with file downloaded from Eric github and your instructions and it always says failed.
Thanks

What are you trying to flash onto? A Sonoff? (standard one?)

The files you see in the folder of the video are the standard ESPEasy files which are included when downloading ESPTool. They dont contain any hardware relevant to this but would include the basic WiFi router tools for creations of an access point and then being able to update it via a webpage.

Hi thank you for your reply
yes i am trying to flash a standard sonoff wifi switch
always get this message
Using a windows 10 computer
with one this

I have tried several times to put the switch in flashing mode
are rx and tx conexion crossing?
I have tried noth ways anyway and always same resut.

That error implies you are not able to talk to the Sonoff at all. I think there are a few things to check in this situation (these are the main problem areas):

  1. You have got the correct COM port and you can see the COM port in device manager with associated number.
  2. The cable is dodgy between FTDI and Sonoff - can apply to any of the pins.
  3. You are not pressing the button when booting, hence it doesnt enter flash mode
  4. You have RX and TX the wrong way around. Sometimes they are labelled badly on the device so first try RX-RX and TX-TX and then try RX-TX and TX-RX.

The only way to tell if you think you have checked the above is using the LED in my experience - you should see the LED respond differently if you turn on while pressing the switch compared to not pressing the switch. Once the device has booted, if you press the switch and the LED changes then you have also missed the flash mode. Hope that helps as a first check.

1 Like

Thank you for your anwser. will check the connections again.
When i try the flash mode on the sonoff the led doesn’t turn on at all.
is that normal?

yes, by default out of the box, i believe the led blinks every second or so. When it’s put into flash mode, it shouldn’t blink at all.

Fyi for those of you who have recently bought a high current device, Itead are recalling them due to not dealing with high current very well.

https://www.itead.cc/blog/sonoff-th16-and-pow-recall-notice

@erocm1231 all your help and work has been greatly appreciated. Sonoff works with my ST and toggle switch works too👍

Something I noticed however…

Has anyone else experianced an issue whilst using the 10amp switch on a lighting circuit?

I’m in the UK ( using 240vac) and I used a small project Box to contain my switch and secure the wiring. I wired my switch into my lounge lights and placed it in a plasterboard wall. I have 2 toggle switches wired in series wired to GPIO 14 and ground.

Here’s the weird bit- when I turn off other lights off which share the same breaker ( kitchen or wc) it turns off the lights connected to my switch…

Any ideas? I’m thinking a slight current surge on the line

The sonoff and both switches work fine in all senses until I turn off a different light ( not connected to a sonoff)

Also has anyone in the UK using these in their walls or Cellings?

Many thanks

That connection goes straight into a GPIO pin of the chip with no signal conditioning at all, so it is very possible that the long open wire will get enough voltage induced to cause the pin to trigger when something else opens the circuit. If you are powering a reactive load then those can put out quite a nasty spike when turning off.

HI Eric
I have update the firmware of my both sonoff ,when i try to update the device handler i got this error

startup failed:
script14907528655111381319010.groovy: 447: expecting ‘’’, found ‘’ @ line 447, column 41.
label=“Momentary” value=“0” />
^

1 error