[RELEASE] Sonoff, Sonoff TH, S20, Dual, 4CH, POW, & Touch Device Handler & SmartApp ($5 & $10 Smart Switches)

Ok, I got one working using webCoRE. Now I have one i’d like to put in another building anyone know if there is a way to conect to a different router than my smartthings hub is on? Still the same internet I just have two routers (one configered as a AP)

Hi i need help, i have flashed my TH10/16 and i the smartthings website i can see the temperatur, but why cant i see that temperature on my smartthings app on my Iphone? i have tried so many things here please help

@TJK, you probably have to choose Manually Add Device when adding a device on a network that is routable to the network that that SmartThings hub is on. This is because Discover Devices probably listens for a broadcast that isn’t forwarded by the router.

@Akhen, you won’t be able to see the temp in the SmartThings app using this Device Handler. If you want to see the temp in the SmartThings app, I recommend that you flash the TH16 with Tasmota firmware and use [RELEASE] Tasmota (Connect) for Sonoff, Tuya, SmartLife & other ESP8266 devices) for your Device Handler.

I tried that to Yesterday, still no temperature.

With the sonoff i Can at least see the temperature inside SmartThings webpage under devices but not in app

If i use the tasmota firmware and setup the temperatur sensor i cant see any temperatur inside the tasmota page

@Akhen, did you set GPIO14 to the correct type of sensor?

Yes i did that

Hi Eric. I’m having trouble controlling my Sonoff Touch 2 gang after migrating to the new smartthings App. I have try updating the device handlers and I have deleted all the child devices. Change something in the device settings and change it back again. All the child devices are created again, but still I can’t manage to add this devices in Sonoff Connect or control the devices. But they appear in Smartthings as a device. Question: where can I find the latest update? Is it here: https://github.com/erocm123/SmartThingsPublic/tree/master/devicetypes/erocm123 and if this still don’t work for my will it help if I try to re-flash the switches?

Thanks in advance for any help I can get.

Jomeg0

Hello Eric,
I am trying to configure Sonoff Mini R2 device with your version of ESP Easy firmware and looks like it needs some modifications. With Tasmota it works well, but I just wanted to use the same firmware for all my devices.
What is good in Mini R2 that you can do everything over the air, due to DIY mode and DIY utility. You just need to activate ota using rest API and then flash using utility.

MIni has contacts for external button and when you flash with fimware for sonoff basic it’s only possible to use internal switch which is GPIO 0 to toggle device state. Contacts for external switch are GPIO 4.
I have no experience in arduino, but probably changing KEY_PIN1 to 4 should fix the problem
image
But it will disable internal button.
Not sure what EXT_PIN is, may be it’s what we need to keep internal and add external switch.

Tried to compile sketch, but getting errors from dependencies

Can you elaborate on how you access the config menu for the device? I can’t get the auto off to work either.

Edit: ignore this. There was something in the fan device handler that was edited but not published. Publishing the handler fixed this.

I’m having trouble with the Ifan02 child device
I created the Fan device using sonoff connect. It created by default as a Sonoff Wifi Switch. As a sonoff switch I can turn the light off by pressing the power on the device. I then changed the device type to Sonoff IFan02 Wifi Controller. This creates a child device too. After that the main device lets me control the fan speed, but the child device just shows the offline cloud symbol.

1 Like

I have a few Sonoff devices (switch) which I use with Tasmota firmware.
But I don’T like the behaviour of Tasmota firmware (by default keep power off) and I have some performance issues on Wifi 2.4ghz mesh. (Asus AiMesh)

is it possible to change firmware to @erocm1231 's firmware through Tasmota web UI ?

I haven’t been keeping up with other project so I am not sure. I have been able to do that in the past, but I’m not sure on the state right now. Make sure you can flash with the serial cable as a backup option.

1 Like

thanks for your reply.
actually I upgraded from Tasmota 8.1.0 to 9.5.0 and the problems were gone.
I’ll stay with Tasmota for now.

1 Like

Will Sonoff flashed with your firmware need to be flashed to say Tasmota to work with Edge drivers?

1 Like

I think so. I did. It was pretty easy because you can do it OTA. See [RELEASE] SmartLife (H801) RGBW LED Strip Wifi Controller & Bulb - #2234 by BartschLabs

1 Like

Yeah, I did just that and hit the 5 free mark with the Tasmota Edge Driver. I have a couple of others flashed with Tasmota as well and added them direct to HA.

I assume you mean Home Assistant. Are you using some sort of integration between SmartThings and Home Assistant?