[RELEASE] Sonoff, Sonoff TH, S20, Dual, 4CH, POW, & Touch Device Handler & SmartApp ($5 & $10 Smart Switches)

Strange, I haven’t seen that before. Maybe try a reflash. Try connecting it to a different access point just to rule that out. You could also reboot the router.

@dlrichna
The first post references the below which has a link to the flasher and some better information about flashing:

I set this whole thing up last month and changed assigned a new password to it. I changed my wifi password on my router today and needed to change it on the Sonoff. I unplugged the Sonoff and plugged it back in, and it started broadcasting it’s own SSID again (“Sonoff”+MAC address). I joined it’s network and when it asked for the password it wouldn’t accept the one that I had created for it last month. It took “configme”. This concerns me, because it means if the power goes out and comes back on, and the Sonoff can’t immediate reconnect to my wifi, anyone can change the Sonoff’s wifi configuration and make it connect to their own network, since “configme” is known to be the default password.

Has anyone tried this on the new Sonoff mini yet? It looks like the perfect device for adding the 13 light switches left in my house to Smartthings without breaking the bank.

2 Likes

The password is currently for control of the device & configuration. The wifi password is statically set at configme. The device tries to connect to wifi every few minutes, so if the power goes out it will shortly connect back to the access point.

Technically, if someone connected to it during that short window, they could attach it to another wifi network, but wouldn’t be able to control it or configure it.

That being said, it wouldn’t be too hard to change it have a configurable AP password. I will try to update it when I get a chance, but if anyone else wants to, that would be great.

To use the 1 Sonoff mini to control a 3-way switch setup you need the line and the load in the same gang box (see the diagram on the Sonoff mini page). Both my 3-way switches have the line in one box and the load in the other. One hack to fix this with 2 Sonoff minis would be to use the 2 traveler wires to sent power and neutral to the box with the load. Hook that switch up as a single pole. Hook the second Sonoff up without anything connected to the relay, and sync the two Sonoffs through Smartthings.

General Question , but I cannot get the Auto Off to work. In Smartthings it says succesfully saved.
Any ideas what to try?
And a second Q…
Is it possible to connect (and read) dht11/22 on a Sonoff Basic R2 V1 (the newer ones without the 5th pin , gpio14, I think?) I know there is a Sonoff TH.
Thanks.

Hi I have a th16 which I can control via smartthings however I’m not getting any temperature or humidity readings I am using the am2301 sensor which if I put tasmota firmware on the th16 I receive readings on the web interface. Any ideas what could be the problem

Hi, Does anyone has been able to make it work the inching option of the 4Ch relay with Smartthings using the custom fw and device handler ??

I´m pretty newbie on this but couldn’t get it work with the info I´ve found.
I´ve successfully added the 4 relays as “normal” switches on ST (but configured as inching in with the pin setup at the board). When I try to change the status from the ST app I´m only able to activate each switch once, and then it gets hung (I think it´s related to the inching option, but couldn’t found how to properly configure it within ST). Is there any way to make it work ? Any help or advice will be appreciated
Thanks !!

Make sense. Did you flash mini with Eric’s firmware? Or you are using eW link app?

Hi Eric
I flashed a POW R2 with your firmware and had no issue to add it to Smartthings with your connect app.
image

I’m however not getting any V, W or A readings in Smartthings. (All readings are 0).


I don’t see any errors in the IDE log:
image
The web interface also shows no readings:
image
(The switch is connected to a pool pump rated at 1500W.)
I’ve tried obvious thinks like rebooting but that made no difference. Unfortunately I flashed the firmware on receipt, not checking if the device report any readings, so it could be that the device is faulty.

Have you perhaps encountered this and do you have any suggestions?

To Eric - thanks again for all this. Just setup my first Sonoff SV as a garage door opener works great using the Rboys app. But, I have been unable to get the configure button to work on ANY of my 5 sonoff devices several of which have been running for months. For the garage relay, I want to set the auto-off time but it won’t let me. Any solution to the orange dot / inability to configure with the flashed firmware? I did not find it using search on here sorry if I missed it.

Erik,
A new Sonoff module had just released. Any Chance for a DH? The device is SONOFF T4EU1C and its main advantage that no neutral wire required !! You can find more details here :

1 Like

Bought one direct from China, problem i’m having is that the wifi chip is the same as the touch, but the board is radically different, and no idea where GPI0 is to get into programing mode. ITEAD told me its not flashable, but they would wouldn’t they.

@tomfontaine Your best bet is to watch the logs when you hit the “Configure” button to see what it is trying to set and what is actually happening. Also, you can try to set the auto off in the web interface for the device.

@dotan_shai That is an interesting device. It looks like they are using the neutral from the light fixture with a bypass device. There are a few devices out there doing this. As for the firmware, I’m not currently supporting it. I do have a forked version of Tasmota that should support it, but someone would have to create the device handler for it.

There are some example device handlers in my main github:

The device handlers with “tasmota” in the name.

Have you tried mini ? Did you flash it with firmwire Eric created ?

Have you tried Mini flashing with Eric’s firmware?

this is what I get on the live logging
result: [success:false, type:configuration]

Quite where do you mean “web interface” ? !

Thanks.

He means using a web browser and going to the IP address of the device … then go to Advanced config - make your changes, and hit submit and it will call for a reboot . But, it doesn’t work (for me anyway) … I make the changes I want (like timeout), and then submit and save - and reboot - but it does not write the config to the device see attached images

Many thanks…I guess I could put a virtual switch in there, and do it that way…

The advantage is that if the relay burns to overcome the amperage, it is easily replaceable. already replace one and it works fine

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.