[RELEASE] SmartLife (H801) RGBW LED Strip Wifi Controller & Bulb

dth_lighting

(cjcharles) #1879

I think all is fine, you would just need to press configure again in the device handler, or in the advanced configuration web page update the settings, so that it has the correct ip address and other info. Presumably the control page works ok?


(Bobby Solis) #1880

Finally got my H801 and LED strips installed and they’re lighting through ST. Although, while in ST app there are (6) ‘PROGRAM’ buttons and a ‘CONFIGURE’ button that aren’t doing anything when I press them. Are these buttons suppose to do something?

Also, I noticed the Red and Green on the H801 are backwards. Unless, my connectors and LED strips are both labeled wrong. Not a big deal, just thought I’d mention it.


(cjcharles) #1881

For the program buttons to do anything you will need to set up the programs, this can currently only be done via the SmartApp (which would need to be installed separately if not already). Also the configure button may well be doing something, just nothing visible, you can check if you go to the Web IDE and look at the ‘Live Logging’ page since that will record what commands are being sent to the H801.

Im pretty sure the pin colours arent backwards as there are quite a few users using them), but perhaps your strip is labelled wrong…?


(cjcharles) #1882

@mickfff
Ive just done another check of the firmware upgrade and it all worked for me from 2.0.6… I think this is probably to do with ST doing something funky, or not sending over the configuration parameters (hence ST will not be able to control or receive updates from the H801 initially, but the webpage for the H801 should work fine). This should fix itself after a few hours, or perhaps you do need to press the configure button… I will keep trying to re-create your problems but have so far failed.


(cjcharles) #1883

EDIT: Ive done some research and reading, I think this stems from the fact that if an ESP is flashed with QIO mode originally (i.e. by serial) then you can flash with DIO mode via the web interface (i.e. it will succeed and overwrite the chip), but then fail to boot. This is a known ESP bug which they are urgently trying to fix, due to the number of ESP8285 chips coming out which do not support QIO. The same is true the other way around (i.e. flash DIO originally and then use web update of QIO firmware).

It seems that the fix is targeted for release at the start of August and I will update if I see any more info.

Could you confirm that if you flash the chip via Serial again then it works as normal and the firmware is good for you? Its just the web upload that causes the problem… I can send you a custom version of the firmware using QIO

Thanks,
C


(Seth Miller) #1884

Whenever a program finishes, rgb will always stay on at the same level, appearing white. Sometimes it is full brightness, sometimes it is low (seems to be around level 10). I can reproduce this behavior by just using the web interface so it has nothing to do with ST.

If I pull a status, it shows that everything is off, even though the I still have a white light.
{"rgb":"000000", "r":"00", "g":"00", "b":"00", "w1":"00", "w2":"00", "power":"off", "running":"false", "program":""}

If I set an individual color to 00, it will actually turn that color off but the other two will stay on at the same brightness and the status still reports them as off.

As far as I can tell, this only happens with programs. I’m running firmware version 2.1.1 but also saw this behavior with 2.0.6. My lightstrip is rgb only, no white.


(cjcharles) #1885

That is super crazy! Can you send me the program string that you are sending so I can test with exactly the same setup. Is your default color set to previous or a hex string?


(Seth Miller) #1886

It doesn’t seem to matter what the program string looks like. In fact, if I just use program without a value, I get the same thing. It almost feels like a race condition or a power bleed. Notice in my previous post that not only do each color show as 00, the status reports that the unit is off while all of the colors are still powered on.

program?value=f~00ff00~2000_f~000000~2000&repeat=2


(Anthony Rossetti) #1887

Now i am having even more issues on version 2.0.6 on my H801’s

I just noticed today that whenever i try and use either Alexa or GH to either dim or brighten the strips
that it turns on the W1 channel 99% of the time.

I can’t dim or brighten my RGB strip because dimming or brightening when they on a color just sets them white(or turns on the white strip i have connected to W1 channel, set to mutually exclusive) now,they do dim though.
I have not changed any settings ,FW ,DTH ,nothing ,
it just started doing this


(cjcharles) #1888

Cool, Ive managed to re-create the error, though I find it tends to fix itself a few minutes later (i.e. it eventually goes back to off/on based on what it was before). I think this is another bug with ESP8266 since it doesnt like having PWM timers set to 0 without one running. I have seen a fix written on one page so I will do a little testing of that.
Thanks

Hi @anthony_rossetti there was a bug in 2.0.6 that I discovered when writing the improvements that seems to turn on W1. I fixed it as part of my coding in 2.1.1. You are welcome to give the updated firmware a go, but beware of what I said above where some people may experience bugs with the firmware until ESP8266/Arduino update the library to fix web firmware updates (in this situation you may need to downgrade the firmware again).


(Sava Ganchev) #1889

Absolutely awesome app and hardware! I’m getting this error when I try and do a program. Any advice? thanks!


(Sava Ganchev) #1890

Absolutely awsome app and hardware! Thanks! I’m getting this error when I try and make an application. Any ideas? Thank you!

Each program also says ‘true’


(RAYMOND J BOWKER) #1891

Has anyone had any luck with flashing this WiFi RGB LED controller:

It has a ESP8285 on it.

It is housed in the small white plastic box with the smart home QR code on it.

Thanks in advance…


(RAYMOND J BOWKER) #1892

Here is a pic of the back.


(Antony Pugh) #1893

sorry for the late reply.

been very busy and I seem to have stopped receiving alerts. Mine was rebooting every half a minute when upgraded. I was able to work fast to revert to 2.0.6 but now ST wont control it.

Let me know what you need I will give it a go.


(cjcharles) #1894

Thats an interesting board, it looks like an Arilux board, but without the separate ESP-12E breakout board on top. Presumably a bit cheaper…

It will run the firmware fine, and will definitely work, however the challenge is working out how to flash it… I cant see from those pictures due to the shine, but can you trace out the pins from the ESP8286 chip, and see where the RX/TX pins end up? Would be the starting place to working out how to flash it. Note the dot at one corner for orientation and U0TXD/U0RXD pins.
image


(cjcharles) #1895

So the webpage works, but the ST integration does nothing? If you check on the advanced page do all of the settings there appear correct?


(Antony Pugh) #1896

Correct. It controls fine from the webpage. Deleted and readded to st and it sees it but will not do anything. It seems to see the settings though. So if I refresh it knows it’s on 80% blue and w1. Or whatever.

Very odd.


(cjcharles) #1897

How have you added it to ST? Did you use mac address or ip address and port as the device id?


(Antony Pugh) #1898

I used the SmartLife discovery to find it.